ksmserver issues with Plasma 5.4.1

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

fusion809
Growing Hen
Posts: 116
Joined: Fri Jul 03, 2015 15:11
Location: Townsville, Australia

Re: ksmserver issues with Plasma 5.4.1

Post by fusion809 » Tue Oct 06, 2015 11:55

Sure did. Still crashing though.
Brenton Horne
Favourite distros: Arch Linux, Fedora, openSUSE, Sabayon Linux and Ubuntu.
Usernames: Fuse809 (Wikimedia), fusion809 (RuneScape), Brenton (Sabayon Wiki) and fusion809 (Gentoo Wiki).
My Blog on Sabayon | Google+

joost
Sagely Hen
Posts: 2775
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: ksmserver issues with Plasma 5.4.1

Post by joost » Tue Oct 06, 2015 13:27

Open a bug if you, provide logs and use a vanilla Sabayon Entropy system where you didn't mess around with Portage.

I have not run into such issues anywhere.
My blog | Mastodon | Please support Sabayon: Become a Patron

denijane
Growing Hen
Posts: 171
Joined: Tue Feb 13, 2007 19:54
Location: Sofia
Contact:

Re: ksmserver issues with Plasma 5.4.1

Post by denijane » Wed Oct 07, 2015 10:46

Hi guys,
after yet another error and logout, I managed to catch the logs (I forgot about them the last couple of time).
So I'm pasting them, just in case anyone wonders:
Xorg.0.log

Code: Select all

[ 54470.129] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
[ 54470.129] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[ 54470.129] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[ 54470.129] (**) PC Speaker: Applying InputClass "joystick-all"
[ 54470.129] (II) No input driver specified, ignoring this device.
[ 54470.129] (II) This device may have been added with another device file.
[ 54470.167] (II) intel(0): EDID vendor "LGD", prod id 803
[ 54470.167] (II) intel(0): Printing DDC gathered Modelines:
[ 54470.167] (II) intel(0): Modeline "1920x1080"x0.0  138.00  1920 1952 1988 2088  1080 1085 1090 1102 -hsync -vsync (66.1 kHz eP)
[ 54483.182] (II) AIGLX: Suspending AIGLX clients for VT switch
Xorg.0.log.old

Code: Select all

[ 33454.646] (**) PC Speaker: Applying InputClass "joystick-all"
[ 33454.646] (II) No input driver specified, ignoring this device.
[ 33454.646] (II) This device may have been added with another device file.
[ 33454.674] (II) intel(0): EDID vendor "LGD", prod id 803
[ 33454.674] (II) intel(0): Printing DDC gathered Modelines:
[ 33454.674] (II) intel(0): Modeline "1920x1080"x0.0  138.00  1920 1952 1988 2088  1080 1085 1090 1102 -hsync -vsync (66.1 kHz eP)
[ 54469.730] (EE) 
[ 54469.730] (EE) Backtrace:
[ 54469.730] (EE) 0: /usr/bin/X (xorg_backtrace+0x87) [0x7f3f23220ac7]
[ 54469.730] (EE) 1: /usr/bin/X (0x7f3f23034000+0x1f1a0d) [0x7f3f23225a0d]
[ 54469.730] (EE) 2: /lib64/libc.so.6 (0x7f3f20f6d000+0x35000) [0x7f3f20fa2000]
[ 54469.730] (EE) 3: /usr/bin/X (FlushAllOutput+0xe5) [0x7f3f23224d75]
[ 54469.730] (EE) 4: /usr/bin/X (0x7f3f23034000+0x56e82) [0x7f3f2308ae82]
[ 54469.730] (EE) 5: /usr/bin/X (0x7f3f23034000+0x5bbca) [0x7f3f2308fbca]
[ 54469.730] (EE) 6: /lib64/libc.so.6 (__libc_start_main+0x114) [0x7f3f20f8d1e4]
[ 54469.730] (EE) 7: /usr/bin/X (0x7f3f23034000+0x43079) [0x7f3f23077079]
[ 54469.730] (EE) 
[ 54469.730] (EE) Segmentation fault at address 0x7f40d50f1df8
[ 54469.730] (EE) 
Fatal server error:
[ 54469.730] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 54469.730] (EE) 
[ 54469.730] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[ 54469.730] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 54469.730] (EE) 
[ 54469.730] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 54469.776] (EE) Server terminated with error (1). Closing log file.
dmesg:

Code: Select all

[email protected] ~ $ dmesg|tail
[52929.511612] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[52929.511617] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
[52929.511621] cfg80211:   (5725000 KHz - 5875000 KHz @ 80000 KHz), (N/A, 1400 mBm), (N/A)
[52929.511626] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[52933.036584] usb 1-5: New USB device found, idVendor=13d3, idProduct=3402
[52933.036587] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[52933.036588] usb 1-5: Product: Bluetooth USB Host Controller
[52933.036589] usb 1-5: Manufacturer: Atheros Communications
[52933.036590] usb 1-5: SerialNumber: Alaska Day 2006
[54513.641579] kactivitymanage[4649]: segfault at 7f37b42f9c50 ip 00007f37b430f797 sp 00007ffe66a1c6e0 error 4 in libQt5Sql.so.5.4.2[7f37b42fa000+47000]
.xsession-erros

Code: Select all

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
[email protected]://gre/modules/PrivateBrowsingUtils.jsm:25:14
[email protected]://browser/content/browser.js:15695:21
No metadata file in the package, expected it at: "/home/denijane/Изображения//metadata.desktop"
No metadata file in the package, expected it at: "/home/denijane/Изображения//metadata.desktop"
No metadata file in the package, expected it at: "/home/denijane/Изображения//metadata.desktop"
qml: getTemperature: 62
qml: getTemperature: 65
qml: getTemperature: 65
qml: getTemperature: 62
qml: getTemperature: 61
qml: is ready to reload - lastReloaded: 1444208560911
qml: getTemperature: 66
qml: getTemperature: 67
qml: getTemperature: 64
qml: getTemperature: 64
qml: getTemperature: 66
qml: getTemperature: 67
qml: is ready to reload - lastReloaded: 1444208560911
qml: getTemperature: 67
qml: getTemperature: 59
qml: getTemperature: 65
kdeinit4: Fatal IO error: client killed
knotify4: Fatal IO error: client killed
kded4: Fatal IO error: client killed
[1007/122843:ERROR:chrome_browser_main_extra_parts_x11.cc(60)] X IO error received (X server probably went away)
klauncher: Exiting on signal 15
kdeinit4: Fatal IO error: client killed
firefox: Fatal IO error 11 (Временно недостъпен ресурс) on X server :0.
xcb_connection_has_error() returned true
[1007/122843:ERROR:x11_util.cc(82)] X IO error received (X server probably went away)
magneto.py: Fatal IO error: client killed
The X11 connection broke: I/O error (code 1)
XIO:  fatal IO error 11 (Временно недостъпен ресурс) on X server ":0"
      after 314767 requests (314767 known processed) with 0 events remaining.
amarok: Fatal IO error: client killed
KCrash: Application 'amarok' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/home/denijane/.kde4/socket-linux.local/kdeinit4__0
Warning: connect() failed: : Няма такъв файл или директория
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi directly
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Прекратен'

** (zeitgeist-datahub:4707): WARNING **: zeitgeist-datahub.vala:226: Unable to get name "org.gnome.zeitgeist.datahub" on the bus!
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Прекратен'

(tracker-miner-fs:4712): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Връзката е прекъсната

(tracker-miner-fs:4712): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Връзката е прекъсната

(tracker-miner-fs:4712): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Връзката е прекъсната

OK

g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Прекратен'

OK


Received signal:15->'Прекратен'

OK

XIO:  fatal IO error 11 (Временно недостъпен ресурс) on X server ":0"
      after 7055021 requests (7055020 known processed) with 0 events remaining.
X connection to :0 broken (explicit kill or server shutdown).
Unexpected response from KInit (response = 0).
startkde: Could not start ksmserver. Check your installation.
Warning: Missing charsets in String to FontSet conversion
The final error seems to be:
"XIO: fatal IO error 11 (Временно недостъпен ресурс) on X server ":0"
after 7055021 requests (7055020 known processed) with 0 events remaining.
X connection to :0 broken (explicit kill or server shutdown).
Unexpected response from KInit (response = 0).
startkde: Could not start ksmserver. Check your installation.
Warning: Missing charsets in String to FontSet conversion
"
I have no idea what this is, but if anyone has an idea how to fix it, it would be quite nice. This logouts are just killing my work.
P.S. Just to be clear, I installed everything from Entropy.

fusion809
Growing Hen
Posts: 116
Joined: Fri Jul 03, 2015 15:11
Location: Townsville, Australia

Re: ksmserver issues with Plasma 5.4.1

Post by fusion809 » Thu Oct 08, 2015 1:29

I dunno, but I just reinstalled all packages listed here with Entropy (all but one was already installed with Entropy, that package was plasma-sdk) and ran (as root)

Code: Select all

equo update && equo upgrade --purge
, rebooted, logged into KDE Plasma 5 (from SDDM) and for some reason KDE Plasma 5 seems far more stable now. I've been really using heaps of RAM and CPU with VirtualBox, RuneScape, Google Chrome and Emerge yet I haven't crashed yet... (before I did this all that would have caused a crash within minutes, but I've been running KDE Plasma 5 with all these programs running without a crash for over an hour now). If I crash later under KDE Plasma 5, I'll let ya know.
Brenton Horne
Favourite distros: Arch Linux, Fedora, openSUSE, Sabayon Linux and Ubuntu.
Usernames: Fuse809 (Wikimedia), fusion809 (RuneScape), Brenton (Sabayon Wiki) and fusion809 (Gentoo Wiki).
My Blog on Sabayon | Google+

fusion809
Growing Hen
Posts: 116
Joined: Fri Jul 03, 2015 15:11
Location: Townsville, Australia

Re: ksmserver issues with Plasma 5.4.1

Post by fusion809 » Thu Oct 08, 2015 13:06

No ksmserver crash yet (after >10 solid hours of usage), but I did get a kdeinit5 crash
Image
Brenton Horne
Favourite distros: Arch Linux, Fedora, openSUSE, Sabayon Linux and Ubuntu.
Usernames: Fuse809 (Wikimedia), fusion809 (RuneScape), Brenton (Sabayon Wiki) and fusion809 (Gentoo Wiki).
My Blog on Sabayon | Google+

notzippy
Growing Hen
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: ksmserver issues with Plasma 5.4.1

Post by notzippy » Sat Oct 10, 2015 18:43

fusion809 wrote:No ksmserver crash yet
Are you still getting an error when you log into the plasma DE for the first time ? I get the error "ksmserver could not start" when I first log in. I have even gone as far as wiping my home config files and cache and it still gives me the same error. I have done a equo --purge as well to no avail.

I noticed in my packages I have 2 versions of libkscreen installed, 1.0.5_p20150822 and 5.4.1 Should one of these go ?

thanks
Nz

v3ss0n
Young Hen
Posts: 36
Joined: Tue Jul 15, 2008 20:26

Re: ksmserver issues with Plasma 5.4.1

Post by v3ss0n » Fri Oct 23, 2015 12:26

This getting more serious on Plasma 5.4.2

i did
equo update && equo upgrade --purge

and it doesn't help either.

I never used portage , only entropy to upgrade. Never in my experience installed a portage package .

Has anyone resolved this?

v3ss0n
Young Hen
Posts: 36
Joined: Tue Jul 15, 2008 20:26

Re: ksmserver issues with Plasma 5.4.1

Post by v3ss0n » Fri Oct 23, 2015 12:29

Plasma is crashing every hour. Especially when using chrome. It kicked out to SDDM login and gives this error upon logged in :Image

v3ss0n
Young Hen
Posts: 36
Joined: Tue Jul 15, 2008 20:26

Re: ksmserver issues with Plasma 5.4.1

Post by v3ss0n » Fri Oct 23, 2015 12:43

joost wrote:ah. For the record. ksmserver is now part of kde-plasma/plasma-workspace
Joost , what that means? KSMSERVER not supposed to be installed right? Only SDDM needed right? Is that it?

Stupot
Sagely Hen
Posts: 1763
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: ksmserver issues with Plasma 5.4.1

Post by Stupot » Fri Oct 23, 2015 17:28

kde-plasma/plasma-workspace-5.4.2 should be installed, and that includes ksmserver.

I've only ever come across this issue when I updated Plasma components while running Plasma and restarting Plasma fixed it up. But that doesn't seem to be the case for you, so let's try and make sure your system is sane with the following:

Code: Select all

# equo deptest
# equo libtest

Post Reply