no KDE desktop effects and no OpenGL 3.1 anymore

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Sat Aug 30, 2014 11:49

Hello,

I have an Asus laptop with Intel video integrated in CPU and dedicated nVidia board.
After some upgrade in the past, it seems to use Intel video only, I can't select OpenGL 3.1 and KDE desktop effects are disabled.

What can I do to have the KDE desktop effects Back?

Thank you.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby albfneto » Tue Sep 02, 2014 15:31

We need more details.
Sabayon version? Is fully upgraded?
you have another video board,onboard?
you upgraded the kernel, the driver?
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Tue Sep 02, 2014 17:17

Sabayon is up to date, the kernel is sabayon 16.1, nVidia driver v340. It's a an ASUS 17.3'' N76VZ-V2G-T1179D, FHD Procesor Intel® Core™ i7-3630QM 2.4GHz Ivy Bridge, 16GB, 750GB SSH, GeForce GT 650M 2GB.
Effects worked before. I am sure it always selects the video integrated into Intel CPU.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby albfneto » Fri Sep 05, 2014 21:47

after you upgraded the kernel, you re-installed the video driver and re-seted the OpenGL?
because, sometimes, this is necessary.

Please post the output of these commands:

Code: Select all
eselect kernel list
eselect opengl list
eselect opencl list
eselect bzimage list
eselect  qtgraphicssystem list
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Sat Sep 06, 2014 7:33

Code: Select all
eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.16.0-sabayon *


Code: Select all
eselect opengl list
Available OpenGL implementations:
  [1]   ati
  [2]   nvidia *
  [3]   xorg-x11


Code: Select all
eselect opencl list
Available OpenCL implementations:
  [1]   amd
  [2]   nvidia *


Code: Select all
eselect bzimage list
Available kernel targets:
  [1]   kernel-genkernel-x86_64-3.16.0-sabayon *


Code: Select all
eselect  qtgraphicssystem list
Available Qt Graphics Systems:
  [1]   native *
  [2]   opengl (experimental)
  [3]   raster (default)
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby albfneto » Sun Sep 07, 2014 14:04

please check if your 3D acceleration is working:

Code: Select all
glxinfo | grep render


switch the renderization method to raster. Native not works good for the KDE (Kwin):

Code: Select all
sudo eselect  qtgraphicssystem set 3


only if necessary, re-install the kernel and the drivers:

Code: Select all
# equo - -av linux-sabayon nvidia-drivers nvidia-settings nvidia-userspace


and then reset the openGL to nvidia:

Code: Select all
# eselect opengl set nvidia
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Sun Sep 07, 2014 14:15

Code: Select all
glxinfo |grep render
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".


After setting qt graphics system to raster, the effects fail the same.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby albfneto » Sun Sep 07, 2014 14:22

your 3D aceleration is not working....

the expected behaviour is below.see in my system, KDE, NVIDIA also:

Code: Select all
direct rendering: Yes
OpenGL renderer string: GeForce GT 610/PCIe/SSE2
    GL_KHR_debug, GL_KTX_buffer_region, GL_NVX_conditional_render,
    GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,
    GL_KHR_debug, GL_KTX_buffer_region, GL_NVX_conditional_render,
    GL_NV_blend_square, GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering,


please see our xorg.conf:

Code: Select all
cat /etc/X11/xorg.conf


Is you nvidia driver installed?

Code: Select all
equo s nvidia-drivers
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Sun Sep 07, 2014 14:26

How is it correct? It complains about this command:

albfneto wrote:
Code: Select all
# equo - -av linux-sabayon nvidia-drivers nvidia-settings nvidia-userspace



I've run:

Code: Select all
equo i -av linux-sabayon nvidia-drivers nvidia-settings nvidia-userspace   
╠  @@ Calculating dependencies...
╠  @@ These are the packages that would be installed:
╠  ## [R] [sabayonlinux.org] media-video/nvidia-settings-340.32|0   [340.32|0]
╠  ## [R] [sabayonlinux.org] x11-drivers/nvidia-userspace-340.32|0   [340.32|0]
╠  ## [R] [sabayonlinux.org] x11-drivers/nvidia-drivers-340.32#3.16.0-sabayon#3.16.0-sabayon|0   [340.32|0|3.16.0-sabayon]
╠  ## [R] [sabayonlinux.org] sys-kernel/linux-sabayon-3.16.1|0   [3.16.1|0]
╠  @@ Packages needing to be installed/updated/downgraded: 4
╠  @@ Packages needing to be removed: 0
╠  @@ Packages needing to be installed: 0
╠  @@ Packages needing to be reinstalled: 4
╠  @@ Packages needing to be updated: 0
╠  @@ Packages needing to be downgraded: 0
╠  @@ Download size: 0b
╠  @@ Freed disk space: 0.0b
╠  @@ You need at least: 293.4MB of free space
...


Same as before after sucessfully installing them.
Last edited by msdobrescu on Sun Sep 07, 2014 14:34, edited 1 time in total.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: no KDE desktop effects and no OpenGL 3.1 anymore

Postby msdobrescu » Sun Sep 07, 2014 14:28

Code: Select all
cat /etc/X11/xorg.conf

Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "intel"
    BusID    "PCI:00:02"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Device"

    Identifier  "SabayonVga1"
    Driver      "nvidia"
    BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"
    #Option       "RegistryDwords" "EnableBrightnessControl=1"

    DefaultDepth 24

    SubSection "Display"
        Depth           8
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

EndSection



Section "Screen"

    Identifier    "Screen 1"
    Device        "SabayonVga1"
    Monitor       "Generic Monitor"
    Option       "AddARGBGLXVisuals" "true"
    Option       "RegistryDwords" "EnableBrightnessControl=1"

    DefaultDepth 24

    SubSection "Display"
        Depth           8
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes          "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
    Screen 1    "Screen 1"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest