KDE notifications raise the volume to 100% [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDE notifications raise the volume to 100% [Solved]

Postby Tedel » Fri Feb 21, 2014 17:45

The title was self-explanatory, I think, so I have two questions:

1. Can anybody reproduce?
2. Has anybody been able to sort this problem out? It is a minor thing, but it is quite annoying.

Thanking you,
Tedel
Last edited by Tedel on Sat Feb 22, 2014 18:11, edited 1 time in total.
Tedel
Simple Hen
 
Posts: 87
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Every incoming message in Kopete raises the volume to 10

Postby Fitzcarraldo » Fri Feb 21, 2014 18:24

I don't use Kopete, but I did have a similar problem to you: the volume would rise to 100% every time the Notification widget popped up a message. The 'problem' is caused by a feature of PulseAudio: flat-volumes.

flat-volumes=
Enable ’flat’ volumes, i.e. where possible let the sink volume equal the maximum of the volumes of the inputs connected to it.
Takes a boolean argument, defaults to yes.

I think the PulseAudio developer who decided on the default didn't think it through. :roll:

Anyway, I fixed the problem in my case by editing /etc/daemon.conf and finding the following line:

Code: Select all
; flat-volumes = yes

and removing the comment indicator ";" and changing the "yes" to a "no":

Code: Select all
flat-volumes = no

Then I restarted the PulseAudio daemon (you could also reboot):

Code: Select all
$ pulseaudio -k && pulseaudio --start

and the problem was solved.

Give it a try.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Every incoming message in Kopete raises the volume to 10

Postby Tedel » Fri Feb 21, 2014 20:39

Hi,

Well the file was on /etc/pulse/daemon.conf but it didn't work, I'm afraid.

mm... How about tweaking something on my local .kde4 folder?
Tedel
Simple Hen
 
Posts: 87
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Every incoming message in Kopete raises the volume to 10

Postby Fitzcarraldo » Fri Feb 21, 2014 23:08

Yes, I meant /etc/pulse/daemon.conf. If that didn't work then I have no idea, I'm afraid, as I don't use Kopete. The only other thing I could suggest (and I doubt it would make a difference) would be to reset all the PulseAudio configuration files:

Code: Select all
$ sudo rm -rf /tmp/pulse*
$ rm -rf ~/.pulse*
$ pulseaudio -k
$ pulseaudio --start
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Every incoming message in Kopete raises the volume to 10

Postby Tedel » Sat Feb 22, 2014 18:10

Ok, that worked.

Also, I need to mention that when I enable Colibri notifications the problem persists.

Marking as solved. Thank you! :)
Tedel
Simple Hen
 
Posts: 87
Joined: Sun Mar 10, 2013 5:32
Location: Peru


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest