Kdm autologin

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Sat Mar 22, 2014 16:07

Fitzcarraldo wrote:Is KDE auto-login now working for you, OmegaSW?

Just to confirm what sabayonino posted on 17 March, it works for me when configured via System Settings > Login Screen as he showed in his post.

Regarding the post by lxnay on 30 December last year, have you checked that the sabayonlive service is not running? It shouldn't be running on an installation to your HDD (and neither should sabayon-mce, another possible service that could override auto-login):

Code: Select all

sabayonkde fitzcarraldo # systemctl list-unit-files | grep sabayon
sabayon-mce.service                         disabled
sabayonlive.service                         disabled
sabayonkde fitzcarraldo #
If either is enabled and running on your installation then disable them using the systemctl command:

Code: Select all

systemctl disable sabayonlive.service
systemctl disable sabayon-mce.service
It's not working for me. I'm going to try your fix now and see if this solves it.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Sat Mar 22, 2014 19:21

Nothing works for me thus far. I guess I could try the dirty trick and prevent root from being able to access the file, but I was hoping to fix it without doing that.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Tue Apr 01, 2014 12:34

I tried:
systemctl list-unit-files | grep enabled

And I got these results:

Code: Select all

cups.path                                   enabled 
avahi-daemon.service                        enabled 
cpufrequtils.service                        enabled 
cups-browsed.service                        enabled 
cups.service                                enabled 
dbus-org.freedesktop.Avahi.service          enabled 
dbus-org.freedesktop.ModemManager1.service  enabled 
dbus-org.freedesktop.NetworkManager.service enabled 
dbus-org.freedesktop.nm-dispatcher.service  enabled 
display-manager.service                     enabled 
[email protected]                              enabled 
kdm.service                                 enabled 
ModemManager.service                        enabled 
NetworkManager-dispatcher.service           enabled 
NetworkManager.service                      enabled 
steambox.service                            enabled 
ufw.service                                 enabled 
vixie-cron.service                          enabled 
x-setup.service                             enabled 
avahi-daemon.socket                         enabled 
cups.socket                                 enabled 
default.target                              enabled 
graphical.target                            enabled 
remote-fs.target                            enabled 
Are there any of these that I should also disable?
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8094
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Kdm autologin

Post by Fitzcarraldo » Tue Apr 01, 2014 12:54

I think I read another post in these forums which stated that Steambox enabled auto-login in the desktop manager, so try disabling steambox.service if you don't use Steambox.

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Tue Apr 01, 2014 13:09

I have a feeling that disabling the steambox service will work. I'll get back with you if this works.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Tue Apr 01, 2014 13:33

I think I'm fixed. It would have reverted by now. Many thanks everyone for the help! :)

So far here are the issues that I have tackled and resolved:
1. KDEConnect (Which is now in the repo, but it wasn't before)
2. PlayOnLinux crashing due to needing to convert some PNG Files
3. Mozplugger to listen to sites that have midi files (I compiled mozplugger-1.14.5 and changed mozpluggerrc to say: controls noisy stream: timidity "$file")
4. Modified xorg config to display the right DPI when using dual monitors (This happens to me in every distro)
5.Black Stripe during the KDE Splash Screen fixed
6. Finally, KDM Autologin appears to be working! :)

TODO:
Pipelight with Netflix due to wine not being patched.

Edit: It has been a day. I really am fixed.
Edit2: It has been almost a week, and I'm still fixed.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

Post Reply