Kdm autologin

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

homer
Baby Hen
Posts: 1
Joined: Mon Dec 30, 2013 14:24

Kdm autologin

Post by homer » Mon Dec 30, 2013 14:43

Hi I have a small problem with kdm and autologin.
I try to set AutoLoginEnable=true /usr/share/config/kdm/kdmrc. But after reboot someone chage the Parameter back to false :(. Anyboy kown which script does it ?. My system-release is Sabayon Linux amd64 14.01.


Thx

Markus

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Re: Kdm autologin

Post by lxnay » Mon Dec 30, 2013 15:48

Probably it's something related to the sabayonlive service or to /usr/libexec/sabayonlive.sh
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

Bedna
Baby Hen
Posts: 1
Joined: Wed Jan 15, 2014 9:30

Re: Kdm autologin

Post by Bedna » Wed Jan 15, 2014 9:36

System Settings -> System Administration -> Login Screen -> Convenience -> Enable Auto-Login

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Sun Feb 23, 2014 5:45

Bedna wrote:System Settings -> System Administration -> Login Screen -> Convenience -> Enable Auto-Login
I did this as well, and I also keep losing my auto-login settings. There was an update today, so I'll have to test around to see if the update fixed the issue.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

k4misiek
Baby Hen
Posts: 1
Joined: Tue Feb 25, 2014 23:26

Re: Kdm autologin

Post by k4misiek » Tue Feb 25, 2014 23:43

Temporary solution.. block modifications kdmrc by root.

Code: Select all

chattr +i /usr/share/config/kdm/kdmrc
Dirty but works ;).

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Mon Mar 17, 2014 11:10

lxnay wrote:Probably it's something related to the sabayonlive service or to /usr/libexec/sabayonlive.sh
I looked at the file, should I comment out any of these?

setup_desktop
setup_password
setup_keymap
setup_x
# MOVED HERE TO AVOID RACE CONDITIONS ON WRITING
# /etc/profile.env variables
setup_locale
sabayon_setup_autologin
sabayon_setup_motd
sabayon_setup_vt_autologin
sabayon_setup_oem_livecd
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
sabayonino
Sagely Hen
Posts: 3190
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Kdm autologin

Post by sabayonino » Mon Mar 17, 2014 20:47

I run Autologin without problem

Set your systemsettings

Image
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

imaginasys
Simple Hen
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: Kdm autologin

Post by imaginasys » Tue Mar 18, 2014 4:48

Hi,

It may be entropy (rigo) that want to revert the file back to what is was.
You may have to protect the file from entropy by modifying /etc/entropy/client.conf :

add "/usr/share/config/kdm/kdmrc" (without the quotes) at the end of the following 2lines :
config-protect = ...
config-protect-skip= ...

Then entropy shall stop reseting the file to its default value.

Regards,
Bernard :mrgreen:

User avatar
OmegaSW
Simple Hen
Posts: 41
Joined: Fri Feb 07, 2014 4:47

Re: Kdm autologin

Post by OmegaSW » Thu Mar 20, 2014 10:19

imaginasys wrote:Hi,

It may be entropy (rigo) that want to revert the file back to what is was.
You may have to protect the file from entropy by modifying /etc/entropy/client.conf :

add "/usr/share/config/kdm/kdmrc" (without the quotes) at the end of the following 2lines :
config-protect = ...
config-protect-skip= ...

Then entropy shall stop reseting the file to its default value.

Regards,
Bernard :mrgreen:
I'm giving this a try, I'll test it out a few days before confirming this to be a fix.
Sabayon KDE 64Bit Edition
Samsung Galaxy Note 3
Steam User

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8094
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Kdm autologin

Post by Fitzcarraldo » Fri Mar 21, 2014 14:25

Is KDE auto-login now working for you, OmegaSW?

Just to confirm what sabayonino posted on 17 March, it works for me when configured via System Settings > Login Screen as he showed in his post.

Regarding the post by lxnay on 30 December last year, have you checked that the sabayonlive service is not running? It shouldn't be running on an installation to your HDD (and neither should sabayon-mce, another possible service that could override auto-login):

Code: Select all

sabayonkde fitzcarraldo # systemctl list-unit-files | grep sabayon
sabayon-mce.service                         disabled
sabayonlive.service                         disabled
sabayonkde fitzcarraldo #
If either is enabled and running on your installation then disable them using the systemctl command:

Code: Select all

systemctl disable sabayonlive.service
systemctl disable sabayon-mce.service

Post Reply