Mounting partitions in cinnamon

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
animated
Baby Hen
Posts: 3
Joined: Wed Oct 23, 2013 17:20

Mounting partitions in cinnamon

Post by animated » Mon Nov 18, 2013 17:01

In a cinnamon session I can't mount/unmount partitions with nemo or nautilus. It returns an error saying "Unable to access/unmount volume" and "Not authorized to perform operation".
But it works in a gnome session.
This has been an issue since an older cinnamon update, but I decided to try again with the release of cinnamon 2.0.
Any help would be appreciated.

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Re: Mounting partitions in cinnamon

Post by lxnay » Mon Nov 18, 2013 17:38

Do you use systemd? If not, please migrate to it.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

animated
Baby Hen
Posts: 3
Joined: Wed Oct 23, 2013 17:20

Re: Mounting partitions in cinnamon

Post by animated » Mon Nov 18, 2013 18:10

I just did with

Code: Select all

eselect sysvinit set systemd
That seems to have been enough. Anything else I should do?

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Re: Mounting partitions in cinnamon

Post by lxnay » Mon Nov 18, 2013 18:12

When you install systemd (you can just reinstall it and see the messages yourself) it tells you if there's something else you may want to do.

It also looks like that the Linux Mint guys have broken something in nemo:
https://github.com/linuxmint/nemo/commi ... 861aa13cb8
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

animated
Baby Hen
Posts: 3
Joined: Wed Oct 23, 2013 17:20

Re: Mounting partitions in cinnamon

Post by animated » Mon Nov 18, 2013 18:42

I reinstalled systemd, and got the following messages:

Code: Select all

 * To ensure consistent behavior, you should replace /etc/env.d/02locale
 * with a symlink to /etc/locale.conf. Please migrate your settings
 * and create the symlink with the following command:
 * ln -s -n -f ../locale.conf /etc/env.d/02locale
 * 
 * Upstream mandates the /etc/mtab file should be a symlink to /proc/mounts.
 * Not having it is not supported by upstream and will cause tools like 'df'
 * and 'mount' to not work properly. Please run:
 * 	# ln -sf '/proc/self/mounts' '/etc/mtab'
 * 
 * To get additional features, a number of optional runtime dependencies may
 * be installed:
 * - sys-apps/systemd-ui: for GTK+ systemadm UI and gnome-ask-password-agent
I created both symlinks and installed systemd-ui. That got rid of some errors at boot, but didn't change anything with regards to mounting in cinnamon.
One peculiar thing I would like to mention is that I don't get a prompt for the admin password at all.

Post Reply