Akonadi keeps failing

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
Tedel
Growing Hen
Posts: 103
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

Akonadi keeps failing

Post by Tedel » Thu Oct 31, 2013 6:55

Hello,

This appears to have started when I upgraded to KDE 4.11.2 last week. Since then, Akonadi fails to start and it prevents me to use Kontact / Korganizer and other KDE applications which depends on it.

I have already tried to regenerate the database erasing /home/username/.config/akonadi files plus /home/username/.kde/akonadi* plus /home/username/.local/akonadi as suggested searching online. I have also noticed that "sometimes" I just reboot the computer and everything works properly again.

Computers are not "moody", so I don't understand what is wrong. Akonadi configuration (kcmshell, if my memory serves me well) complains that "mysql server log contains errors", "akonadi control process is not registered with dbus" and that "akonadi server process is not registered with dbus", but dbus process appears to be working properly.

Lastly, I checked /home/username/.local/share/akonadi/db_data/msql.err and I noticed this:

Code: Select all

131031  0:35:36 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
131031  0:35:36 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
My guess is that the upgrade broke some tables (although some reboots have them rebuild it properly?), but I am lost. So far I want to know if anyone can reproduce this error, if I have to prepare myself to reinstall from scratch or what can I do because I really need to be able to work without restaring my computer as many times as necessary to have KDE read its databases as it should.

Thanks in advance for any lights you can bring.

Thev00d00
Generally Awesome (tm)
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom
Contact:

Re: Akonadi keeps failing

Post by Thev00d00 » Fri Nov 01, 2013 20:20

This is caused by the fact that dev-db/virtuoso-server was upgraded to 6.1.7 which broke akonadi.

This has been masked upstream now due to that fact however you need to nuke the database and start again (with 6.1.6). :?
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me

Tedel
Growing Hen
Posts: 103
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

Re: Akonadi keeps failing

Post by Tedel » Fri Nov 01, 2013 21:15

OK, so I just need to wait for someone to solve it? :S

Post Reply