VLC doesn't suspend the screensaver

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
msdobrescu
Old Dear Hen
Posts: 886
Joined: Sun Aug 21, 2011 8:48

VLC doesn't suspend the screensaver

Post by msdobrescu » Mon Jul 29, 2013 19:48

Hello,

I've tried several media players, I've chosen smplayer and vlc.
Under Windows, they suspend the screen savers, but under Sabayon they don't, even thouh the settings are done in both.
What's the solution?

Thanks.

bobwad
Baby Hen
Posts: 6
Joined: Sun Jul 08, 2012 14:18

Re: VLC doesn't suspend the screensaver

Post by bobwad » Wed Jul 31, 2013 18:44

Open VLC.
Go to Tools/Preferences.
Select All (at bottom left).
Select Advanced (at top left).
Ensure that "Inhibit the power management daemon during playback" is selected.
That should do the trick.

cmost
Advanced Hen
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Re: VLC doesn't suspend the screensaver

Post by cmost » Sat Aug 03, 2013 16:19

Looks like this is a known bug in VLC (https://bugs.mageia.org/show_bug.cgi?id=4027)

You could simply just suspend the screen saver yourself before starting the media player. I mean it literally takes just five quick clicks in KDE.

Or, you could just click a handy shell-script. :D

Code: Select all

#!/bin/sh
xset s noblank
xset s off
xset -dpms
AMD Phenom II 64 X6 1090T Black Edition
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Sabayon 2014.x 64 Bit KDE
"Better to remain silent and be thought a fool than to speak out and remove all doubt." -- Abraham Lincoln

Post Reply