Oh no! Something has gone wrong ... [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Oh no! Something has gone wrong ... [Solved]

Postby megamin » Sun Jul 14, 2013 18:41

that's the message I got after updating this morning, rebooting and trying to start cinnamon (same with cinnamon 2D). Gnome ist working, so does anyone have an idea, what went wrong or how to solve this issue? :|
Last edited by megamin on Wed Jul 17, 2013 16:47, edited 1 time in total.
megamin
Young Hen
 
Posts: 20
Joined: Mon Jan 21, 2013 10:45

Re: Oh no! Something has gone wrong ...

Postby lxnay » Mon Jul 15, 2013 6:09

Sure, you posted so many useful information that's very easy to help you out! :roll: (sarcasm)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Oh no! Something has gone wrong ...

Postby megamin » Mon Jul 15, 2013 9:38

Well, I posted that information that I got:
- everything I changed was doing the weekly update
- it seems to be no 3D issue (because cinnamon 2D doesn't work also)
- it seems to be a cinnamon-specific thing (because gnome is working)

So part of my question was: what additional information do you need to help me solve that problem?
megamin
Young Hen
 
Posts: 20
Joined: Mon Jan 21, 2013 10:45

Re: Oh no! Something has gone wrong ...

Postby reitermaniac » Mon Jul 15, 2013 12:06

hi,

I have the same problem since the last updates I installed today.

Is it possible that the file editor nemo is bricked now and then cinnamon doesnt start?

when it starts it says:

nemo
nemo: error while loading shared libraries: libgnome-desktop-3.so.4: cannot open shared object file: No such file or directory

Otherwise gnome is upgraded to a newer version that cinnamon 1.6.7 doesnt support?

thx for help ;)
reitermaniac
Baby Hen
 
Posts: 9
Joined: Sun Feb 26, 2012 15:24

Re: Oh no! Something has gone wrong ...

Postby lxnay » Mon Jul 15, 2013 12:11

nemo has been removed from repositories. Did you remove the packages that have removed from repositories?
Code: Select all
equo upgrade --prune


And perhaps read the actual output of the upgrade process? :-)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Oh no! Something has gone wrong ...

Postby megamin » Mon Jul 15, 2013 13:00

I did remove nemo - I was wondering why but I did. 'equo upgrade' says:
- nothing to upgrade
- nothing to remove
- no configuration files to update

'equo deptest' and 'equo libtest' also doesn't report any problem ... :?
megamin
Young Hen
 
Posts: 20
Joined: Mon Jan 21, 2013 10:45

Re: Oh no! Something has gone wrong ...

Postby megamin » Mon Jul 15, 2013 13:27

... more information:

Code: Select all
joachim@jo-leppi ~ $ cinnamon --replace    JS ERROR: !!!   Exception was: Error: No JS module 'dbus' found in search path
    JS ERROR: !!!     message = '"No JS module 'dbus' found in search path"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/main.js"'
    JS ERROR: !!!     lineNumber = '4'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/main.js:4
"'
    JS ERROR: !!!   Exception was: Error: No JS module 'dbus' found in search path
    JS ERROR: !!!     message = '"No JS module 'dbus' found in search path"'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/js/ui/main.js"'
    JS ERROR: !!!     lineNumber = '4'
    JS ERROR: !!!     stack = '"@/usr/share/cinnamon/js/ui/main.js:4
"'
Fensterverwalter-Warnung:Log level 32: Execution of main.js threw exception: Error: No JS module 'dbus' found in search path


I hope this helps 8)
megamin
Young Hen
 
Posts: 20
Joined: Mon Jan 21, 2013 10:45

Re: Oh no! Something has gone wrong ...

Postby reitermaniac » Mon Jul 15, 2013 20:27

maybe our gnome framework is not compatible with cinnamon 1.6.7 - current version available is cinnamon 1.8.2 - but this version is not available in gentoo repos ... I search for the error msg but couldn't find a solution.

anyone running cinnamon desktop without that problem with current gnome ?
reitermaniac
Baby Hen
 
Posts: 9
Joined: Sun Feb 26, 2012 15:24

Re: Oh no! Something has gone wrong ...

Postby lxnay » Mon Jul 15, 2013 20:28

Cinnamon 1.8.8 will be available in sabayon-limbo in a couple of hours, please test.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Oh no! Something has gone wrong ...

Postby megamin » Mon Jul 15, 2013 22:21

I tried to upgrade using sabayon limbo but there is nemo as unresolved dependancy ( needed by cinnamon 1.8.8 )
megamin
Young Hen
 
Posts: 20
Joined: Mon Jan 21, 2013 10:45

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest