How to avoid laptop to suspend when close lid?

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

How to avoid laptop to suspend when close lid?

Postby dudumomo » Thu Jun 27, 2013 14:10

Hi guys,

I'm just installed Sabayon on a reasonably old laptop (4-5 years old) and then I close the lid, the system suspends.

I've installed gnome tweak tool and set "Laptop lid close action on AC" to "blank" but no success.

What should I configure to make it stop?

Thank you !
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: How to avoid laptop to suspend when close lid?

Postby cmost » Sat Jun 29, 2013 3:28

It would be helpful to know which DE you're using (i.e., Gnome, KDE, MATE, etc.) before answering. Thanks!
AMD Phenom II 64 X6 1090T Black Edition
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Sabayon 2014.x 64 Bit KDE
"Better to remain silent and be thought a fool than to speak out and remove all doubt." -- Abraham Lincoln
cmost
Advanced Hen
 
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Re: How to avoid laptop to suspend when close lid?

Postby dudumomo » Fri Jul 19, 2013 4:45

Sorry for late answer,
I'm using GNOME 3.8.3

I still haven't found the way.

Thanks!
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: How to avoid laptop to suspend when close lid?

Postby dudumomo » Thu Jul 25, 2013 14:58

Hi guys,

Any idea how to do that?

Thank you !
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: How to avoid laptop to suspend when close lid?

Postby smouty » Tue Feb 18, 2014 11:40

Hi,

I followed the advice given on http://blogs.dailynews.com/click/2013/1 ... id-closed/ which worked until updates! :lol:

Now when the lid is closed it blanks the screen, and then suspends the machine when I open the lid.....
This seems bizzare and counter-intutitive any clues? :x
smouty
Baby Hen
 
Posts: 3
Joined: Wed Feb 05, 2014 10:10

Re: How to avoid laptop to suspend when close lid?

Postby imaginasys » Wed Feb 19, 2014 4:26

I've installed gnome tweak tool and set "Laptop lid close action on AC" to "blank"


Since you are using both gnome to control the lid and systemd logind.conf, is it possible that they are in conflict ?

Use either gnome or systemd to control the lid, not both ???

Just my 0,02$, I don't have gnome on my laptop.

Regards,
Bernard :mrgreen:
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: How to avoid laptop to suspend when close lid?

Postby smouty » Thu Feb 20, 2014 8:25

Hi, Fixed It!!! :D :lol: :mrgreen:

What I have done is in /etc/systemd/logind.conf I have un-commented, or deleted the '#' from the start of the line LidSwitchIgnoreInhibited=yes and rebooted and all works as I want. As in close the lid and the screen goes blank, not suspend when opening the lid either!!
smouty
Baby Hen
 
Posts: 3
Joined: Wed Feb 05, 2014 10:10

Re: How to avoid laptop to suspend when close lid?

Postby smouty » Sun Feb 23, 2014 15:34

Ignore my last post all is not well again, rebooted machine today and old annoying behaviour is back
smouty
Baby Hen
 
Posts: 3
Joined: Wed Feb 05, 2014 10:10

Re: How to avoid laptop to suspend when close lid?

Postby dudumomo » Mon Jun 09, 2014 17:13

Have you found the way to do it?
dudumomo
Growing Hen
 
Posts: 149
Joined: Tue Nov 16, 2010 14:40

Re: How to avoid laptop to suspend when close lid?

Postby Fitzcarraldo » Mon Jun 09, 2014 20:07

smouty wrote:What I have done is in /etc/systemd/logind.conf I have un-commented, or deleted the '#' from the start of the line LidSwitchIgnoreInhibited=yes and rebooted

Ignore my last post all is not well again, rebooted machine today and old annoying behaviour is back

Code: Select all
[email protected] ~ $ cat /etc/systemd/logind.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See logind.conf(5) for details

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

You wrote that you uncommented "LidSwitchIgnoreInhibited=yes" but I read that as meaning you have told systemd not to ignore the inhibiting of the lid switch. Try commenting it out again, uncomment "HandleLidSwitch=suspend" and change it to "HandleLidSwitch=ignore". (I'm not using systemd on any of my laptops, so I can't try it myself.)

From logind.conf:

LidSwitchIgnoreInhibited= defaults to "yes". This means that the lid switch does not respect suspend blockers by default, but the power and sleep keys do.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron