XFCE Audio Mixer Hotkeys [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

XFCE Audio Mixer Hotkeys [Solved]

Postby Mattlxdesign » Thu May 09, 2013 8:40

After a recent upgrade i have noticed my audio mixer hotkeys are no long work and the Audio Mixer icon has disappeared from my panel. Also when i try to add a new Audio Mixer item to the panel it's greyed out and i can't add it. I thought i must have missed a conf update after the upgrade but
Code: Select all
equo conf update
shows nothing to do.
I can still change the volume by opening the Audio Mixer from the Applications Menu but no panel icon nor hotkeys....
An hour or so of forum and google searches have brought me no luck. Any ideas on what i might have forgotten to do?
Last edited by Mattlxdesign on Fri May 10, 2013 13:14, edited 1 time in total.
Mattlxdesign
Baby Hen
 
Posts: 7
Joined: Sun May 05, 2013 13:38

Re: XFCE Audio Mixer Hotkeys

Postby Fitzcarraldo » Thu May 09, 2013 20:42

Is the Xfce volume control daemon installed and running?

Code: Select all
aspire5536 fitzcarraldo # equo search xfce4-volumed
>>  @@ Searching...
>>      @@ Package: xfce-extra/xfce4-volumed-0.1.13 branch: 5, [sabayonlinux.org]
>>         Available:     version: 0.1.13 ~ tag: NoTag ~ revision: 1
>>         Installed:     version: 0.1.13 ~ tag: NoTag ~ revision: 1
>>         Slot:          0
>>         Homepage:      https://launchpad.net/xfce4-volumed
>>         Description:   Daemon to control volume up/down
>>                        and mute keys
>>         License:       GPL-3
>>  Keywords:  xfce4-volumed
>>  Found:     1 entry
aspire5536 fitzcarraldo # ps -ef | grep xfce4-volumed
fitzcar+  6947     1  0 20:13 ?        00:00:00 xfce4-volumed
root     14422 14017  0 20:38 pts/0    00:00:00 grep --colour=auto xfce4-volumed
aspire5536 fitzcarraldo #
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: XFCE Audio Mixer Hotkeys

Postby Mattlxdesign » Fri May 10, 2013 1:24

Thanks for getting back to me Fitzcarraldo,

Xfce volume control daemon is indeed installed anf a quick check of my task manager confirms it is running.
Code: Select all
[email protected] ~ $ equo search xfce4-volumed
>>  @@ Searching...
>>      @@ Package: xfce-extra/xfce4-volumed-0.1.13 branch: 5, [sabayon-weekly]
>>         Available:     version: 0.1.13 ~ tag: NoTag ~ revision: 1
>>         Installed:     version: 0.1.13 ~ tag: NoTag ~ revision: 1
>>         Slot:          0
>>         Homepage:      https://launchpad.net/xfce4-volumed
>>         Description:   Daemon to control volume up/down
>>                        and mute keys
>>         License:       GPL-3
>>  Keywords:  xfce4-volumed
>>  Found:     1 entry

Another thing that's been playing up since the weekend is playback on xbmc has been a bit choppy. Using my best forum and google searching skills the most likely the most likely culprit is to do with my sound set up, but none of the suggestions i've read have fixed it. What does work is if i log out of an Xfce session and into an xbmc session. Playback returns to normal. With that in mind when i get a chance later today i'll create a new user to check if it's something in my user preferences that's causing me grief.
I'll post my results either way.
Mattlxdesign
Baby Hen
 
Posts: 7
Joined: Sun May 05, 2013 13:38

Re: XFCE Audio Mixer Hotkeys [Solved]

Postby Mattlxdesign » Fri May 10, 2013 13:26

That was a hard one. Logging in with a new user account had no problems so i began the trial and error process to find the culprit. Cut a long story short it was my panel config file

~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml

I copied over it with my test user version but i expect deleting it would have worked just as well and then i wouldn't have had to change its owner and group.
Multi-media hotkeys, Audio Mixer Icon and xbmc all back to normal.
Mattlxdesign
Baby Hen
 
Posts: 7
Joined: Sun May 05, 2013 13:38


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests