KDE 4.10.1 - bad fonts in same dialog [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDE 4.10.1 - bad fonts in same dialog [Solved]

Postby jjkra » Wed Mar 20, 2013 2:22

Hi,

From 4.9 to 4.10.1 no change, still bad font in dialog window.

OS: Sabyon - last upgrade

Picture, in RED rectangle see bug?:
https://docs.google.com/file/d/0B60uq6_ ... sp=sharing
jjkra
Baby Hen
 
Posts: 11
Joined: Mon Mar 04, 2013 15:22

Re: KDE 4.10.1 - bad fonts in same dialog

Postby Fitzcarraldo » Wed Mar 20, 2013 11:47

You have Arabic-Indic numbers in your locale. You need to fix that as follows:

1. Kickoff > System Settings > Locale. Make sure your language, number format, currency symbol, date format and so on are selected.

2. Follow the procedure in Re: en_GB language missing after install., obviously replacing the keymap code and locale codes with the appropriate ones for your locale.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.10.1 - bad fonts in same dialog

Postby jjkra » Wed Mar 20, 2013 12:48

Hi, thanks for answer, but

Kickoff > System Settings > Locale. - OK setting
locale - OK setting
locale-gen OK

All setting OK, delete .kde .setting, and problem exist.

Any other idea ?

Thx
jjkra
Baby Hen
 
Posts: 11
Joined: Mon Mar 04, 2013 15:22

Re: KDE 4.10.1 - bad fonts in same dialog

Postby Fitzcarraldo » Thu Mar 21, 2013 0:19

Open a Konsole window, enter the following commands and post the output in this thread (using the Code button):

Code: Select all
$ locale
$ cat /home/jjkra/.kde4/share/config/kdeglobals
$ cat /usr/share/config/kdm/kdmrc
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.10.1 - bad fonts in same dialog

Postby jjkra » Thu Mar 21, 2013 0:58

If change locale to US or SK this problem no change.
try remove /tmp kde-cache, no change

Code: Select all
locale
LANG=sk_SK.UTF-8
LC_CTYPE="sk_SK.UTF-8"
LC_NUMERIC="sk_SK.UTF-8"
LC_TIME="sk_SK.UTF-8"
LC_COLLATE="sk_SK.UTF-8"
LC_MONETARY="sk_SK.UTF-8"
LC_MESSAGES="sk_SK.UTF-8"
LC_PAPER="sk_SK.UTF-8"
LC_NAME="sk_SK.UTF-8"
LC_ADDRESS="sk_SK.UTF-8"
LC_TELEPHONE="sk_SK.UTF-8"
LC_MEASUREMENT="sk_SK.UTF-8"
LC_IDENTIFICATION="sk_SK.UTF-8"
LC_ALL=

Code: Select all
cat /home/jj/.kde4/share/config/kdeglobals
[$Version]
update_info=kwin.upd:kde3.2Xinerama

[DirSelect Dialog]
DirSelectDialog Size=780,576
History Items[$e]=

[General]
BrowserApplication[$e]=!firefox
ColorScheme=Default
UseSystemBell=false
XftAntialias=true
XftHintStyle=hintmedium
XftSubPixel=rgb
dbfile=/home/jj/.mozilla/firefox/pucdo252.default/places.sqlite
desktopFont=Sans Serif,9,-1,5,50,0,0,0,0,0
fixed=Monospace,9,-1,5,50,0,0,0,0,0
font=Sans Serif,9,-1,5,50,0,0,0,0,0
menuFont=Sans Serif,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=Sans Serif,9,-1,5,50,0,0,0,0,0
taskbarFont=Sans Serif,9,-1,5,50,0,0,0,0,0
toolBarFont=Sans Serif,9,-1,5,50,0,0,0,0,0
widgetStyle=oxygen
                                                                                                                                                               
[Icons]                                                                                                                                                       
Theme=oxygen                                                                                                                                                   
                                                                                                                                                               
[KDE]                                                                                                                                                         
AutoSelectDelay=-1                                                                                                                                             
ChangeCursor=true                                                                                                                                             
DoubleClickInterval=400                                                                                                                                       
ShowDeleteCommand=false                                                                                                                                       
ShowIconsOnPushButtons=true                                                                                                                                   
SingleClick=true                                                                                                                                               
StartDragDist=4                                                                                                                                               
StartDragTime=500                                                                                                                                             
WheelScrollLines=3                                                                                                                                             
contrast=7                                                                                                                                                     
                                                                                                                                                               
[KDE-Global GUI Settings]                                                                                                                                     
GraphicEffectsLevel=6                                                                                                                                         
                                                                                                                                                               
[KFileDialog Settings]                                                                                                                                         
Automatically select filename extension=true                                                                                                                   
Breadcrumb Navigation=false                                                                                                                                   
Decoration position=0
LocationCombo Completionmode=5
PathCombo Completionmode=5
Preview Width=204
Previews=false
Recent URLs[$e]=/usr/share/backgrounds/,$HOME/Dokumenty/
Show Bookmarks=false
Show Full Path=false
Show Preview=true
Show Speedbar=true
Show hidden files=false
Sort by=Name
Sort directories first=true
Sort reversed=false
Speedbar Width=206
View Style=Simple

[KShortcutsDialog Settings]
Dialog Size=600,480

[Locale]
Country=sk
DigitGroupFormat=3;2
Language=sk:en_US:en_GB

[PreviewSettings]
MaximumRemoteSize=5242880

[Toolbar style]
ToolButtonStyle=TextBesideIcon
ToolButtonStyleOtherToolbars=TextBesideIcon

[WM]
activeBackground=96,148,207
activeFont=Sans Serif,9,-1,5,50,0,0,0,0,0
activeForeground=255,255,255
inactiveBackground=224,223,222
inactiveForeground=20,19,18


Code: Select all
cat /usr/share/config/kdm/kdmrc
[General]
ConfigVersion=2.4
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
DataDir=/var/lib/kdm
GreeterUID=kdm
PidFile=/var/run/kdm.pid
ReserveServers=:1,:2,:3
ServerVTs=-7
StaticServers=:0

[Shutdown]
BootManager=None
HaltCmd=/sbin/shutdown -h -P now
RebootCmd=/sbin/shutdown -r now

[X-*-Core]
AllowNullPasswd=false
AllowRootLogin=false
AllowShutdown=Root
AutoReLogin=false
ClientLogFile=.xsession-errors-%d
Reset=/usr/share/config/kdm/Xreset
Session=/usr/share/config/kdm/Xsession
SessionsDirs=/usr/share/apps/kdm/sessions,/usr/share/xsessions
Setup=/usr/share/config/kdm/Xsetup
Startup=/usr/share/config/kdm/Xstartup

[X-*-Greeter]
AntiAliasing=false
ColorScheme=
FaceDir=/var/lib/kdm/faces
FaceSource=AdminOnly
FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0
ForgingSeed=1362625985
GUIStyle=
GreetFont=Serif,20,-1,5,50,0,0,0,0,0
GreetString=Welcome to %s at %n
GreeterPos=50,50
HiddenUsers=
Language=en_US
LogoArea=Logo
LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png
MaxShowUID=65000
MinShowUID=1000
Preloader=/usr/bin/preloadkde
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/elarun
UseBackground=true
UseTheme=true
UserCompletion=false
UserList=true

[X-:*-Core]
AllowNullPasswd=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-nolisten tcp
ServerCmd=/usr/bin/X -br -novtswitch -quiet
ServerTimeout=30
TerminateServer=true

[X-:*-Greeter]
AllowClose=false
DefaultUser=jj
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=Previous

[X-:0-Core]
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=
ClientLogFile=.xsession-errors

[Xdmcp]
Enable=false
Willing=/usr/share/config/kdm/Xwilling


Code: Select all
equo query list installed | grep kde-l10
>> # 12254 kde-base/kde-l10n-en_GB
>> # 12573 kde-base/kde-l10n-sk
jjkra
Baby Hen
 
Posts: 11
Joined: Mon Mar 04, 2013 15:22

Re: KDE 4.10.1 - bad fonts in same dialog

Postby Fitzcarraldo » Thu Mar 21, 2013 4:24

I can't spot anything obviously wrong in the output you posted. Are you seeing that problem with Arabic-Indic DigitSet in just Dolphin, or does it occur in all applications in KDE (KDE and non-KDE applications)?

If I understand your second post correctly, you have already tried deleting the /home/jj/.kde4 directory? If not, try doing that, as KDE will automatically recreate it (and you will have to reconfigure your Panel and Desktop).

If you have already tried the above, have you tried creating a new user, to see if the problem occurs for that user too?

Also, do you see the problem if you launch Dolphin as the root user, using the command given below?

Code: Select all
$ kdesu dolphin
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.10.1 - bad fonts in same dialog

Postby jjkra » Thu Mar 21, 2013 4:38

This problem in all KDE applications, also in setting panel.

nonKDE aplication is OK (Firefox ok)

yes i tried delete .kde and .config, yes KDE automatic recreate, and problem persist

new user today try and write result
edit: NEW user aslo bad font (user create with Kuser)

kdesu dolphin is also wrong
jjkra
Baby Hen
 
Posts: 11
Joined: Mon Mar 04, 2013 15:22

Re: KDE 4.10.1 - bad fonts in same dialog

Postby Fitzcarraldo » Thu Mar 21, 2013 19:05

I've been trying hard to replicate your problem, but I can't make it happen, even if I set DigitSet=1, DateTimeDigitSet=1 and MonetaryDigitSet=1 (Arabic-Indic numbers, which is what you're seeing) in kdeglobals:

Code: Select all
$ cat /home/sabayonuser/.kde4/share/config/kdeglobals
[$Version]
update_info=kwin.upd:kde3.2Xinerama

[General]
BrowserApplication[$e]=!chromium
ColorScheme=Default
UseSystemBell=false
XftAntialias=true
XftHintStyle=hintmedium
XftSubPixel=rgb
desktopFont=DejaVu Sans,10,-1,5,50,0,0,0,0,0
fixed=DejaVu Sans Mono,8,-1,5,50,0,0,0,0,0
font=DejaVu Sans,10,-1,5,50,0,0,0,0,0
menuFont=DejaVu Sans,9,-1,5,50,0,0,0,0,0
shadeSortColumn=true
smallestReadableFont=DejaVu Sans,8,-1,5,50,0,0,0,0,0
taskbarFont=DejaVu Sans,8,-1,5,50,0,0,0,0,0
toolBarFont=DejaVu Sans,8,-1,5,50,0,0,0,0,0
widgetStyle=oxygen

[Icons]
Theme=oxygen

[KDE]
AutoSelectDelay=-1
ChangeCursor=true
DoubleClickInterval=400
ShowIconsOnPushButtons=true
SingleClick=false
StartDragDist=4
StartDragTime=500
WheelScrollLines=3
contrast=7

[KDE-Global GUI Settings]
GraphicEffectsLevel=6

[KFileDialog Settings]
Automatically select filename extension=true
Breadcrumb Navigation=false
Decoration position=0
LocationCombo Completionmode=5
PathCombo Completionmode=5
Recent URLs[$e]=/usr/share/backgrounds
Show Bookmarks=false
Show Full Path=false
Show Preview=true
Show Speedbar=true
Show hidden files=false
Sort by=Name
Sort reversed=false
Speedbar Width=92
View Style=Simple

[KShortcutsDialog Settings]
Dialog Size=600,480

[Locale]
Country=sk
DateTimeDigitSet=1
DigitGroupFormat=3;2
DigitSet=1
Language=sk:en_GB:en_US
MonetaryDigitSet=1

[Toolbar style]
ToolButtonStyle=TextBesideIcon
ToolButtonStyleOtherToolbars=TextBesideIcon

[WM]
activeBackground=96,148,207
activeFont=DejaVu Sans,8,-1,5,75,0,0,0,0,0
activeForeground=255,255,255
inactiveBackground=224,223,222
inactiveForeground=20,19,18

All I can suggest is that you post your problem over on the KDE Community Forums as a KDE expert there may be able to suggest something else to try.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.10.1 - bad fonts in same dialog

Postby Fitzcarraldo » Thu Mar 21, 2013 23:49

Further to my previous post, I have now discovered the following KDE bug report of 3 January 2013, marked 'Resolved Upstream', regarding a bug in Qt: Bug 312525 - No Arabic numbers in applications (Arabic-Indic are used). It is indeed actually a Qt bug: Arabic-indic numerals instead of Arabic numerals in Slovak localization and apparently it is still outstanding in Qt 4.8.4-*, which is what Gentoo (and hence SL) uses. So it requires the Gentoo developers or someone else to create a patch and modify the Qt 4.8.4-*ebuild accordingly, or for Qt to release 4.8.5, for the problem to be fixed. So all you can do is wait. What I cannot understand is why I could not replicate it in VirtualBox, but perhaps I did not set up the environment to be completely Slovak.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.10.1 - bad fonts in same dialog

Postby jjkra » Thu Mar 21, 2013 23:58

Super i wait :)
Last edited by jjkra on Fri Mar 22, 2013 0:00, edited 1 time in total.
jjkra
Baby Hen
 
Posts: 11
Joined: Mon Mar 04, 2013 15:22

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron