ATI driver showing artifacts in Gnome [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
xjonquilx
Simple Hen
Posts: 81
Joined: Tue Oct 25, 2011 18:23

ATI driver showing artifacts in Gnome [Solved]

Post by xjonquilx » Sun Nov 20, 2011 15:47

The ATI driver in Gnome shows artifacts every time I do anything in the GUI, like bring up the bottom panel or switch to the Activities menu. Can someone walk me through using another driver?
Last edited by xjonquilx on Sun Nov 20, 2011 23:05, edited 1 time in total.

xjonquilx
Simple Hen
Posts: 81
Joined: Tue Oct 25, 2011 18:23

Re: ATI driver showing artifacts in Gnome

Post by xjonquilx » Sun Nov 20, 2011 15:56

Or even better help me fix whatever is causing the artifacts?

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: ATI driver showing artifacts in Gnome

Post by Fitzcarraldo » Sun Nov 20, 2011 17:54

Option 1: Open-source X.Org Radeon userspace driver

Install x11-drivers/xf86-video-ati

Uninstall ati-drivers

Edit /etc/X11/xorg.conf and change "fglrx" to "ati"

Code: Select all

$ su
Password:
# eselect opengl set xorg-x11
# exit
Reboot.

Option 2: Open-source kernel Radeon module

See Getting rid of Catalyst

xjonquilx
Simple Hen
Posts: 81
Joined: Tue Oct 25, 2011 18:23

Re: ATI driver showing artifacts in Gnome

Post by xjonquilx » Sun Nov 20, 2011 23:05

Thanks!

Post Reply