Page 1 of 1

Gnome 3 w/ Radeon

Posted: Mon Oct 24, 2011 12:45
by bconnolly
I've got a Dell notebook with a Radeon x1400. I can only get Gnome 3 fallback in S7.

I've tried the "Getting rid of Catalyst" technique (http://joostruis.wordpress.com/2011/01/ ... -catalyst/). No luck.

Help!

Thanks in advance.

Brian

PS For the record, I have no trouble with Gnome3 on OpenSUSE or Fedora; but Sabayon is the distro of choice. Very clean.

Re: Gnome 3 w/ Radeon

Posted: Mon Oct 24, 2011 16:55
by bconnolly
ADD ONE: Fedora 16 reports graphic: Gallium 0.4 on ATI RV515. Sabayon 7 reports Gallium 0.4 on llvmpipe

Re: Gnome 3 w/ Radeon

Posted: Tue Oct 25, 2011 10:50
by wolfden
Not an installer issue so moving it here

Re: Gnome 3 w/ Radeon

Posted: Tue Oct 25, 2011 22:49
by HolgiB
bconnolly wrote:ADD ONE: Fedora 16 reports graphic: Gallium 0.4 on ATI RV515. Sabayon 7 reports Gallium 0.4 on llvmpipe
Well, the problem is somewhat obvious:
FC16 runs the open source radeon driver with hardware acceleration while Sabayon 7 runs llvmpipe = software renderer.
Check your xorg.log for any reports if / why initializing the radeon driver for your graphic adapter fails.

BTW: Using the "getting rid of Catalyst" method isn't required. A more recent version of fglrx will not support card as old as your 1600. I trashed my X1900XTX somewhat two years ago when ATI declared the card to be legacy.

The open source radeon on the other hand is in quite nice shape. Even for gaming. :bom:

Re: Gnome 3 w/ Radeon

Posted: Wed Oct 26, 2011 13:30
by bconnolly
I don't see anything in the log. Nothing "failed." What exactly should I be looking for?

Thoughts?

Thanks.

Brian

Re: Gnome 3 w/ Radeon

Posted: Wed Oct 26, 2011 19:13
by HolgiB
bconnolly wrote:I don't see anything in the log. Nothing "failed." What exactly should I be looking for?

Thoughts?

Thanks.

Brian
Well, in the first place you should find out if the radeon drivers are installed at all. Then if the correct firmware is installed. Normally if the radeon xdrivers plus firmware are installed, you should see the corresponding messages inside xorg.0.log

If anything fails you will see error messages as well. I can not really give any examples on what to look for since the error messages are very different.

If you are unsure feel free to post a recent xorg.log on pastebin.com

As for the radeon package I am not shure if I can help here. I used the radeon drivers massively when I was running archlinux a few month ago.

Have a look at the gentoo wiki:
http://en.gentoo-wiki.com/wiki/Radeon

HTH,
Holger

Re: Gnome 3 w/ Radeon

Posted: Thu Nov 03, 2011 18:17
by chasha420
Sorry for being slightly off topic but I'm also facing similar problem as the OP & I don't think it's necessary to post multiple threads of the same type.

Anyway, I have Radeon 5450 graphics card & after a fresh install of Sabayon 7 @ Gnome 3...it seems like I'm in fall back mode all the time. I mean there's no gnome shell and after I updated & installed amdcccle...I also see no effect.

How do I actually disable fallback mode? I think my graphics card is more than adequate to handle gnome 3...also a thing worth mentioning...I have an integrated intel graphics card on my under powered old laptop...and it still runs gnome 3 @ normal mode perfectly fine...so it's either gnome 3 doesn't support my card or I'm doing something wrong.

Anyway let me know what other logs I may need to post and if anyone knows a work around please let me know.

I'm not that desperate but I'm more interested in learning how to solve problem than steering clear of it.

Thanks.

Re: Gnome 3 w/ Radeon

Posted: Thu Nov 03, 2011 21:47
by nickdanger
To quote the press release for Sabayon 7 by lxnay on the Sabayon Home page:

Important Fixes
+Disable GNOME Shell when fglrx is in use due to broken drivers (patch).

I think the wait is for AMD to update the Radeon drivers.
It is not that your hardware is not capable enough.

Regards, N.D.

Re: Gnome 3 w/ Radeon

Posted: Sun Nov 13, 2011 18:39
by Crypto_ahash
Well if you really want to use the Gnome3 in non fall back. (How I call it Fail Back)
Just emerge gnome-session from gentoo, restart X. If its still on fail back. Enable non fail back in settings. Although I think SL7 includes: gnome-base/gnome-session-3.2.1 already and you can enable non fail back from settings already?

But be warned :)