X or nvidia_drv segmentation fault [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Technological Hen
Posts: 344
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: X or nvidia_drv segmentation fault

Post by genfool » Wed Jul 06, 2011 23:59

Thanks for posting,
I diligently put all the nvidia info in my posts above.
When The last poster said they were using a 7600, I was able to reproduce the error with my 7100
My best advice at this time is to install the 173 drivers, The dev are working on a cure, I suspect it will hit the main repos soon.

So far, it seems it is the 7k series card that is affected, The 173 drivers do work, a fix is on the way.

Sagely Hen
Posts: 1084
Joined: Fri Jan 05, 2007 15:08
Location: Washington, DC

Re: X or nvidia_drv segmentation fault

Post by chickpea » Thu Jul 07, 2011 14:23

I also experienced the exact same problem on a GeForce Go 6150.

Just read the fix, haven't tried yet to downgrade to older drivers, but I can confirm that this issue also exists with this chipset.

Sagely Hen
Posts: 8214
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: X or nvidia_drv segmentation fault

Post by Fitzcarraldo » Thu Jul 07, 2011 16:39

Off Topic:
Hi, chickpea, haven't seen you post in these forums for what must be a couple of years. I thought you'd switched to another distribution.

Simple Hen
Posts: 97
Joined: Sun Jan 21, 2007 8:47

Re: X or nvidia_drv segmentation fault

Post by vaettchen » Sat Jul 09, 2011 10:36

Finally back home again, I can get a little deeper into the problem. Just started the Live DVD (KDE _64) and no problem with getting X started. Asking the usual questions, I get:

Code: Select all

sabayon sabayonuser # uname -a
Linux sabayon 2.6.39-sabayon #1 SMP Fri Jun 17 16:40:29 UTC 2011 x86_64 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux
sabayon sabayonuser # eselect opengl list
Available OpenGL implementations:
  [1]   ati
  [2]   nvidia *
  [3]   xorg-x11
sabayon sabayonuser # equo query installed nvidia-drivers
>> Repository sabayon-weekly hasn't been downloaded yet.
>> Repository sabayon-weekly is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!
>>  @@ Searching...
>>      @@ Package: x11-drivers/nvidia-drivers-270.41.19#2.6.39-sabayon branch: 5, [__system__] 
>>         Installed:     version: 270.41.19 ~ tag: 2.6.39-sabayon ~ revision: 0
>>         Slot:          0,2.6.39-sabayon
>>         Homepage:      http://www.nvidia.com/ 
>>         Description:   NVIDIA GPUs kernel drivers 
>>         License:       NVIDIA
>>  Keyword:  nvidia-drivers
>>  Found:    1 entries
So I will try to downgrade to that driver - should be the same one that worked for many months before?

I'll try equo first and, depending upon the outcome, portage afterwards.

1. Attempt:
I tried genfool's suggestion using equo

Code: Select all

equo install x11-drivers/nvidia-drivers-279.41.19#2.6.39-sabayon
but equo won't allow me to set a specific driver version.

2. Attempt:
I tried once more anonimo's / micia's way of using portage to install the dsired driver - this time at least with partial success: I see for a short moment the nvidia logo and then get to an login screen that I guess is the X login screen. It won't recognize my username and password, but at least, X is up and running. Next question: How do I get back into KDE?

Back into KDE was easy: Somebody / something (not me!) had changed my /etc.conf.d/xdm to use xdm instead of kde. Just setting it (back) to

Code: Select all

did the job.

So thanks for an interesting learning experience,

User avatar
Growing Hen
Posts: 108
Joined: Tue Feb 01, 2011 14:00

Re: X or nvidia_drv segmentation fault [Solved]

Post by anonimo » Sun Jul 10, 2011 11:28

I have installed 275 nvidia driver with nvidia geforce 7 series!!
Today while I'm doing updates with sulfur, i have read after the installation of xorg.conf that if you disable the voice useevents in xorg.conf would leave even the driver 275 for nvidia 6xxx and 7xxx cards. so I edited xorg.conf
Alt + F2 -> gksu gedit / etc/X11/xorg.conf -> Run -> your password
so i removed # and set UseEvents to false, updated nvidia driver and now new drivers run!!

Growing Hen
Posts: 101
Joined: Thu Jan 18, 2007 23:37

Re: X or nvidia_drv segmentation fault [Solved]

Post by gallienus » Wed Jul 20, 2011 13:51

I know this is marked solved but I was wondering if anyone else had tried this fix and what the results were.

Simple Hen
Posts: 97
Joined: Sun Jan 21, 2007 8:47

Re: X or nvidia_drv segmentation fault [Solved]

Post by vaettchen » Wed Jul 20, 2011 14:08

I haven't - will take the next quiet period in my professional life (end August) to try a usual equo update / upgrade), and depending on the result, come back to the fix mentioned here. I hope I don't have to...

Post Reply