if XGL/AIGLX don't work, write here.

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: if XGL/AIGLX don't work, write here.

Postby patryk » Tue Nov 20, 2007 7:17

Hello,

I'm trying to get a 3d desktop working on a Sapphire X1600 Pro, 512 MB, AGP 8X.

Code: Select all

# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600]
01:00.1 Display controller: ATI Technologies Inc RV530 [Radeon X1600] (Secondary)
02:03.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 04)
02:04.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
02:04.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
02:05.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
02:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 01)


# eselect opengl show
ati


# cat /var/log/Xorg.*.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering


# cat /etc/sabayon-release
Sabayon Linux x86 3.4


# accel-manager
XGL is not running
DRI ok
OpenGL acceleration is available.
something set currentStatus to  0
DRI ok
fglrx driver is running, checking if driver supports GLX_EXT_texture_from_pixmap
AIGLX is NOT available
DRI ok
Saving...
writeSettings(): accel to set is:  0
disabling xgl
Working...
Disabling XGL system wide (reverting to X.Org)...Done
disabling aiglx
Working...
Disabling AIGLX system wide...
Done
bye!


Thanks for your help :)
patryk
Baby Hen
 
Posts: 1
Joined: Tue Nov 20, 2007 7:04

Re: if XGL/AIGLX don't work, write here. Problems with NVIDIA

Postby mrtabac » Thu Nov 22, 2007 6:57

Hi to all.
I'm Alberto, from Brasil.
Problems between NVIDIA Linux Drivers and Sabayon, are known. in this and other topics, I see many problems of no accleration, blank or whiter of dark screens, loose od beryl working, etc... etc.. I my Sabayon, the NVIDIA working finea after 3 installations, including all video acclerations and GLX, but, when i tried to update all the sabayon with the command emerge world, no more video, only a blank, white screen. i only uble to open sessions in bash or with the simple graphical interface fluxbox, bu no more GNOME or KDE. I restarted the sabayon in simple command line and re-installed the last version of NVIDIA 5200 drivers ( is the same 100.19 version, that previously worked) but since the drivers was the same that sabayon was downloaded, the problem still continue... only a blank screen! I solved this partially, usinf the rescue sabayon resource from the installer/live DVD.... My machine and my Sabayon are 64 bits....
Now, the problem is partialyy solved, no more accleration of video, even in the acceletration manager!....
I see related problems in this in other topics, hardware, video, NVIDIA etc...Appears that the new nVIDIA drivers, does not working very well with sabayon.... Immuy case re intsall beryl does not solve the problem.... Sometimes, vblank or black screen, sometimes beryl does not run, etc, In my Sabayon, no more 3D resources, including Kompiz and Beryl!, I have only common desktops! Some people known a driver, compatible? even more antique? Editing of the xorg.config file also nevre solved. These problems are unfortune, because Sabayon is one of the most amazing and complete between the distros, and is very beautiful!
mrtabac
Baby Hen
 
Posts: 13
Joined: Thu Nov 22, 2007 6:35

Re: if XGL/AIGLX don't work, write here.

Postby wolfden » Thu Nov 22, 2007 7:40

If you are using older nvidia cards you have to use the proper drivers

http://gentoo-wiki.com/HOWTO_nVidia_Dri ... he_drivers
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: if XGL/AIGLX don't work, write here.

Postby commandant » Fri Nov 23, 2007 18:05

Hi,
Here are my results
Code: Select all
localhost ~ # lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 645xx (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 14)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0a.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV31M [GeForce FX Go5600] (rev a1)
localhost ~ # eselect opengl show
nvidia
localhost ~ # cat /var/log/Xorg.*.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
localhost ~ # cat /etc/sabayon-release
Sabayon Linux x86 3.4


I can't select any acceleration in the acceleration manager. Compiz is supposed to be my window manager if I believe the compiz-fusion icon.

Thanks
Dell 4700 - Nvida
DualBoot Ubuntu 7.10 - Sabayon 3.4 [since 24-03-2008]
commandant
Baby Hen
 
Posts: 17
Joined: Wed Oct 03, 2007 19:13

Re: if XGL/AIGLX don't work, write here.

Postby davkt » Tue Dec 04, 2007 20:38

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
05:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)
05:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
05:09.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:09.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
05:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
05:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)


eselect opengl show
xorg-x11

cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

cat /etc/sabayon-release
Sabayon Linux x86 3.4

Had it working perfectly in 3.3, have tried the fixes used on that but no luck.
If I start an acceleration manager session I can configure acceleration fine but go into a real X session and I get a message that acceleration isn't working. The system won't let me change screen resolution either.
Bright ideas anyone?
davkt
Simple Hen
 
Posts: 53
Joined: Fri Feb 02, 2007 23:12

Re: if XGL/AIGLX don't work, write here.

Postby laczi » Sat Dec 08, 2007 15:36

So.. I have an A-64 in a GigaByte NF3 board and a Radeon 9600 pro but I haven't got a 3D desktop. I'm a relatively newbie in linux but I have to get experience because where M$ goes with vista I don't want to go (DRM crap)...

lspci
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:0a.0 IDE interface: nVidia Corporation CK8S Serial ATA Controller (v2.5) (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc M10 NQ [Radeon Mobility 9600]
01:00.1 Display controller: ATI Technologies Inc M10 NQ [Radeon Mobility 9600] (Secondary)
02:0b.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)

eselect opengl show
ati

cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(EE) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX: Screen 0 is not DRI capable

cat /etc/sabayon-release
Sabayon Linux x86-64 3.4
laczi
Baby Hen
 
Posts: 1
Joined: Sat Dec 08, 2007 15:24

Re: if XGL/AIGLX don't work, write here.

Postby likwidsage » Mon Dec 10, 2007 7:10

I can't get AIGLX to work. I tried the following:
1) eselect opengl set xorg-x11(Neither XGL nor AIXGL works)
2) eselect opengl set ati (Only XGL works)
3) emerge ati-drivers && ln -s /usr/lib/opengl/ati/lib/libGL.so.1 /usr/lib/libGL.so.1 && emerge desktop-acceleration-helpers (Didn't help)

lspci
Code: Select all
00:00.0 Host bridge: nVidia Corporation C55 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a2)
00:00.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.7 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:03.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:06.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:07.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
01:00.0 VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600]
01:00.1 Display controller: ATI Technologies Inc RV530 [Radeon X1600] (Secondary)
04:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

eselect opengl show
Code: Select all
ati


cat /var/log/Xorg.*.log | grep "(EE)"
Code: Select all
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom

cat /etc/sabayon-release
Code: Select all
Sabayon Linux x86 3.4
likwidsage
Baby Hen
 
Posts: 6
Joined: Fri Feb 23, 2007 2:21

Re: if XGL/AIGLX don't work, write here.

Postby Phristen » Thu Dec 20, 2007 6:27

Hi

XGL doesn't work for me, the accel-manager just keeps reverting back to no acceleration :(
glxinfo | grep direct says yes.
eselect opengl show says ati
lspci says 03:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550 Silent]
cat /etc/sabayon-release says Sabayon Linux x86-64 3.4

And cat /var/log/Xorg.*.log | grep "(EE)" says this
Code: Select all
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib64/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering
home crisis # cat /var/log/Xorg.*.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib64/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering


It would appear as if the system wants to use AIGLX, but the only option I have in accel-manager is XGL.
Also, the livedvd worked fine, so its really weird :x I've tried emerging ati-drivers, but that didn't do it.
Phristen
Baby Hen
 
Posts: 1
Joined: Thu Dec 20, 2007 6:16

Re: if XGL/AIGLX don't work, write here.

Postby erendiz » Fri Dec 21, 2007 12:22

Code: Select all
localhost erendiz #     lspci
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:09.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
06:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550 Silent]
06:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550 Silent]



Code: Select all
localhost erendiz #     eselect opengl show
xorg-x11



Code: Select all
localhost erendiz #     cat /var/log/Xorg.*.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
(EE) AIGLX: Screen 0 is not DRI capable


Code: Select all
localhost erendiz #     cat /etc/sabayon-release
Sabayon Linux x86-64 3.4


thx for help........
erendiz
Baby Hen
 
Posts: 1
Joined: Fri Dec 21, 2007 12:12

Re: if XGL/AIGLX don't work, write here.

Postby ExZen » Wed Jan 16, 2008 22:25

I made an erroneous new thread in the forum, which belonged here (sorry didn't see that).
I just installed the miniCD version of Sabayon. Compizfusion seems to be working, but seems kinda laggy or slow...having a cube workspace works well, and switching work spaces and having wobbly windows is all good and fine, but minimizing windows seems to cause a pause, and then a clunky minimization animation...I only wonder, because I had Ubuntu installed previously and compizfusion worked much more slickly it seemed there. Otherwise I prefer Sabayon in almost all other respects. Here are my specs

Abit AN-M2HD motherboard
Athlong 64 X2 5200+ EE processor
2 gigs of ram
nvidia 7050pv integrated graphics.

typing "glxinfo | grep direct" in the terminal yields direct rendering: Yes

Any help smoothing things out is greatly appreciated. Thanks for your time.
ExZen
Young Hen
 
Posts: 29
Joined: Mon Mar 05, 2007 13:22

PreviousNext

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron