if XGL/AIGLX don't work, write here.

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: if XGL/AIGLX don't work, write here.

Postby wolfden » Thu Oct 18, 2007 21:51

it's because you are missing the use flags

viewtopic.php?f=57&t=10558

add the flags and recompile
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: if XGL/AIGLX don't work, write here.

Postby c_sarmento » Fri Oct 19, 2007 15:21

wolfden wrote:it's because you are missing the use flags

viewtopic.php?f=57&t=10558

add the flags and recompile



I'm sorry but i don't know what to do with the link.
I'm a total noob, how can i add the flags?, what is a flag?
what do i have recompile?

sorry :oops:
c_sarmento
Baby Hen
 
Posts: 5
Joined: Mon Oct 15, 2007 17:40

Re: if XGL/AIGLX don't work, write here.

Postby wolfden » Fri Oct 19, 2007 22:51

did you read that link?

1.)

Add in /etc/make.conf after USE=

opengl qt4 qt3 qt3support gtk sdl png gif


can't get more simple than that

than follow:
viewtopic.php?f=53&t=9882
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: if XGL/AIGLX don't work, write here.

Postby skzo » Tue Oct 23, 2007 23:47

hello, I just made a fresh install of sabayon, i have a radeon 9200, and on the live cd, aiglx and XGL were both working.

After i installed with gnome desktop, the first thing i noticed is that /usr/sbin/accel-manager, had a typo, it was using kdesu, instead of gksudo, since i installed the gnome desktop. i also don't have direct rendering, neither aiglx/XGL of course.

i've also tried to install the new ATI driver that came out today (8.42), but i have a "no display found" error starting X, using that new fglrx driver.

so these are my outputs:

lspci
Code: Select all
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
02:01.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


eselect opengl show:
Code: Select all
xorg-x11


cat /var/log/Xorg.*.log | grep "(EE)"
Code: Select all
[        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.


cat /etc/sabayon-release
Code: Select all
 Sabayon Linux x86 3.4



hope you can help me !
skzo
Baby Hen
 
Posts: 3
Joined: Tue Oct 23, 2007 23:30

Re: if XGL/AIGLX don't work, write here.

Postby c_sarmento » Thu Oct 25, 2007 14:34

wolfden wrote:did you read that link?

1.)

Add in /etc/make.conf after USE=

opengl qt4 qt3 qt3support gtk sdl png gif


can't get more simple than that

than follow:
viewtopic.php?f=53&t=9882



the first part i did it, but to do the asked inb the link you sent me i think that i need to have an internet connection to do that, because it show a lot of times "download ... failed"... , with i don't have...
Is there any way of simply put compiz working?
After i can run compiz i'll dedicate my time confirguring it to have internet on it...
c_sarmento
Baby Hen
 
Posts: 5
Joined: Mon Oct 15, 2007 17:40

compiz loves me no more after a kernel upgrade.

Postby myfunny » Wed Oct 31, 2007 14:44

i had compiz up and working on my intel video card. then, i upgraded my kernel using the sabayon one as explained in the wiki. after reboot, trying to run compiz, i got this output:
Code: Select all
$ compiz --replace
libGL warning: 3D driver claims to not support visual 0x64
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

this is my lspci output about the graphic card
Code: Select all
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)


eselect opengl show says:
Code: Select all
xorg-x11


#cat /var/log/Xorg.*.log | grep "(EE)" shows no errors, and i got the Sabayon Linux x86.miniEdition 3.4.

huge amount of kisses to anyone who cares to help,
myfunny.
myfunny
Baby Hen
 
Posts: 1
Joined: Wed Oct 31, 2007 14:18

Re: if XGL/AIGLX don't work, write here.

Postby Moparguy » Fri Nov 09, 2007 7:34

compiz worked find on livecd, after install nothing...

00:00.0 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8T800Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:0e.0 Ethernet controller: VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet Adapter (rev 11)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800 GT] (rev a1)

nvidia


(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.


Sabayon Linux x86 3.4
Moparguy
Baby Hen
 
Posts: 3
Joined: Fri Nov 09, 2007 6:37

Re: if XGL/AIGLX don't work, write here.

Postby Enigma » Sat Nov 10, 2007 0:28

Hello!

I'm new to Sabayon. Just installed today. I tried it out a few days back, but dumped it because of the no compiz thing and it screwed up my grub menu.

I've been using Ubuntu. I have Compiz working on Ubuntu with the new ATI proprietary driver, so I know it works with my card.

I have an ATI Radeon X1650 with 512mb...

Can ya help?

Code: Select all
lspci:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 755 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA  [SiS] (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 71c1 (rev 9e)
01:00.1 Display controller: ATI Technologies Inc Unknown device 71e1 (rev 9e)


Code: Select all
[email protected] ~ $ eselect opengl show
ati


Code: Select all
[email protected] ~ $ cat /var/log/Xorg.*.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering


Code: Select all
[email protected] ~ $ cat /etc/sabayon-release
Sabayon Linux x86 3.4


Thanks!

Kevin
Enigma
Baby Hen
 
Posts: 6
Joined: Fri Nov 09, 2007 23:34

Re: if XGL/AIGLX don't work, write here.

Postby REz » Wed Nov 14, 2007 20:47

I have a problem with compiz, when i start a session with accelerator manager it start and all function work propertly,but all the desktop is black if i do a right-click on screen i don't see nothing, but if i do another click i see the burn effect, if i press Alt+Ctrl+arrow i can see change the desktop, but is always black.
i can also draw with fire on screen, all compiz options work, but the screen is dark, if i disable accelerator manager compiz doesn't start and all work, if i run compiz after it doesent work
Code: Select all
localhost ~ # lspci
00:00.0 Host bridge: nVidia Corporation C55 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a2)
00:00.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:00.7 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.3 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.4 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.5 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:01.6 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.0 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.1 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:02.2 RAM memory: nVidia Corporation C55 Memory Controller (rev a1)
00:03.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:05.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:06.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:07.0 PCI bridge: nVidia Corporation C55 PCI Express bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
04:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
05:08.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

localhost ~ # eselect opengl show
nvidia

localhost ~ # cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

localhost ~ # cat /etc/sabayon-release
Sabayon Linux x86-64 3.4
REz
Baby Hen
 
Posts: 1
Joined: Wed Nov 14, 2007 20:41
Location: Italy

Re: if XGL/AIGLX don't work, write here.

Postby SpawN » Mon Nov 19, 2007 20:26

sry 4 offtopic..what are this??

Image
SpawN
Baby Hen
 
Posts: 12
Joined: Mon Nov 12, 2007 19:07

PreviousNext

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest