if XGL/AIGLX don't work, write here.

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

if XGL/AIGLX don't work, write here.

Postby lxnay » Mon Dec 04, 2006 8:30

As written in the subject, if XGL and/or AIGLX don't work and you know to have a supported video card, write here and attach the output of:

Code: Select all
lspci

and
Code: Select all
eselect opengl show

and
Code: Select all
cat /var/log/Xorg.*.log | grep "(EE)"

and
Code: Select all
cat /etc/sabayon-release


thank you.
Last edited by lxnay on Tue Dec 05, 2006 9:11, edited 1 time in total.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby shoarthing » Mon Dec 04, 2006 13:57

Re: AiGLX session-switch errors as reported in bug #28

output from #lspci:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTra nsport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Con troller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscella neous Control
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a 2)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethe rnet PCI Express (rev 11)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethe rnet PCI Express (rev 11)
05:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Cont roller (PHY/Link)
06:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
06:01.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X IOAPIC (rev 01)
06:02.0 PCI bridge: Advanced Micro Devices [AMD] AMD-8131 PCI-X Bridge (rev 12)
06:02.1 PIC: Advanced Micro Devices [AMD] AMD-8131 PCI-X IOAPIC (rev 01)
07:01.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b Link Layer C ontroller (rev 01)

. . from: #eselect opengl show
nvidia
. . from #cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) Error loading keymap /usr/share/X11/xkb/compiled/server-0.xkm
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
shoarthing
Simple Hen
 
Posts: 93
Joined: Wed Sep 27, 2006 21:29
Location: Blighty

XGL does not work

Postby lowboyblue » Tue Dec 05, 2006 4:07

localhost bill # lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:01.0 PCI bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE Host-to-AGP Bridge (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AQ [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AQ [Radeon 9600] (Secondary)
02:01.0 Communication controller: Conexant HSF 56k Data/Fax Modem
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:05.0 Multimedia audio controller: Creative Labs SB Audigy LS
localhost bill # eselect opengl show
ati
localhost bill # cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI.
(EE) AIGLX: Screen 0 is not DRI capable
(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom

localhost bill # cat /etc/sabayon-release
Sabayon Linux x86 3.2


Hope this helps..........and thank you. :)
Last edited by lowboyblue on Tue Dec 05, 2006 9:22, edited 1 time in total.
lowboyblue
Simple Hen
 
Posts: 46
Joined: Fri Sep 01, 2006 9:21
Location: San Diego

Postby lxnay » Tue Dec 05, 2006 9:14

lowboyblue,
your problem should be fixed in 3.2...
have you forced the ATI open source driver?
the solution, for you is to run:
Code: Select all
eselect opengl set xorg-x11

OR (to use the proprietary driver):
Code: Select all
eselect opengl set ati
sed -i '/do not remove/ s/"radeon"/"fglrx"/' /etc/X11/xorg.conf
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby jagged » Tue Dec 05, 2006 13:59

AIGLX worked with the Live DVD, but not after an install.

[email protected] ~ $ sudo lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
05:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)
[email protected] ~ $ eselect opengl show
nvidia
[email protected] ~ $ cat /var/log/Xorg.*.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Mouse3 no synaptics touchpad detected and no repeater device
(EE) Mouse3 Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Mouse3"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
[email protected] ~ $ cat /etc/sabayon-release
Sabayon Linux x86 3.2
jagged
Baby Hen
 
Posts: 2
Joined: Tue Dec 05, 2006 13:55

Thanks Ixnay

Postby lowboyblue » Tue Dec 05, 2006 16:42

lxnay wrote:lowboyblue,
your problem should be fixed in 3.2...
have you forced the ATI open source driver?
the solution, for you is to run:
Code: Select all
eselect opengl set xorg-x11

OR (to use the proprietary driver):
Code: Select all
eselect opengl set ati
sed -i '/do not remove/ s/"radeon"/"fglrx"/' /etc/X11/xorg.conf


Thanks Ixnay that worked like a charm.
I'm so stoked....I had been on stuck on RC2 for so long. This is great, thanks again!
lowboyblue
Simple Hen
 
Posts: 46
Joined: Fri Sep 01, 2006 9:21
Location: San Diego

Postby jagged » Tue Dec 05, 2006 17:15

jagged wrote:AIGLX worked with the Live DVD, but not after an install.


Oops.. I figured out my problem. It is necessary to run the Acceleration Manager after installing.
jagged
Baby Hen
 
Posts: 2
Joined: Tue Dec 05, 2006 13:55

Re: Thanks Ixnay

Postby lxnay » Tue Dec 05, 2006 18:58

lowboyblue wrote:Thanks Ixnay that worked like a charm.
I'm so stoked....I had been on stuck on RC2 for so long. This is great, thanks again!

Which version were you running?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby lowboyblue » Tue Dec 05, 2006 19:10

[email protected] ~ $ cat /etc/sabayon-release
Sabayon Linux x86 3.2


I was stuck on Sabayon 3.0 rc2 for just a little while....
:lol:
lowboyblue
Simple Hen
 
Posts: 46
Joined: Fri Sep 01, 2006 9:21
Location: San Diego

Postby lxnay » Tue Dec 05, 2006 19:18

lowboyblue,
what you did to get it working in the end?
which one of the two commands?
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron