LXDE l10n

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

LXDE l10n

Postby ReemZ » Wed May 04, 2011 2:52

I've been playing with LXDE for a few days now and I'm liking it more and more, I've already found ways of customising bits of it to my personal taste but there's one thing bothering me about it: it will only speak American English to me, and I want it to speak Queen's. Or, should it happen I install it on my mum's lappy, Dutch. I've done some googling on localisation in LXDE, but I've not found anything helpful - partly because lxde.org seems to be in rather bad health.
One post on the PCLinuxOS forum mentions Menu > More Applications > Configuration > Add Locale, but there is no More Applications in the menu. Perhaps the menu has been restructured in the past year, as that post is over a year old. Speaking of the menu, Sabayon logo by default, please ;)
Neither Entropy nor Portage have l10n packages for LXDE like they do for KDE and Libre Office.
Before I file a package request, I'd like to know if such a package even exists.
Has anyone tried this recently, perhaps on a different distro, and if so, what were the results?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: LXDE l10n

Postby ReemZ » Wed May 04, 2011 3:15

Related question: how to change the calendar (which pops up when clicking the clock) so that Monday is the first day of the week, not Sunday?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: LXDE l10n

Postby Fitzcarraldo » Sat May 07, 2011 13:19

To change to language to en_GB, see my post Re: en_GB language missing after install (although you may not want all of the locale environment variables to be en_GB, so you'll need to experiment) and the Gentoo Linux Localization Guide.

If I recall correctly, LC_TIME="en_GB.UTF-8" has the week starting on Monday rather than Sunday (which I find strange, as I was always taught that the first day of the week is Sunday). However, if, after applying the above you find that Monday is not the first day of the week then you can customise the locale -- see the following blog post (and comments on it) for how to do that in Ubuntu: Change the Week Start Day in Ubuntu. Although it's not something I've had to do myself, I expect the procedure to be basically the same in any distribution.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: LXDE l10n

Postby ReemZ » Sat May 07, 2011 17:36

Fitzcarraldo wrote:To change to language to en_GB, see my post Re: en_GB language missing after install (although you may not want all of the locale environment variables to be en_GB, so you'll need to experiment) and the Gentoo Linux Localization Guide.
Thanks mate, I'll try that.
Once I try this on my mum's lappy (installed SL on her machine last week but kept to KDE to keep it simple for her, but she did show interest in LXDE as well) I'll go for the .bashrc approach, as I want to change her account's locale to Dutch and keep the global one English.
I'll skip steps 1 and 2 in your post though, as our keyboards are all US-intl.

Fitzcarraldo wrote:If I recall correctly, LC_TIME="en_GB.UTF-8" has the week starting on Monday rather than Sunday (which I find strange, as I was always taught that the first day of the week is Sunday).
Yeah, that's what my girlfriend said too, here it's Monday though ;)

Fitzcarraldo wrote:However, if, after applying the above you find that Monday is not the first day of the week then you can customise the locale -- see the following blog post (and comments on it) for how to do that in Ubuntu: Change the Week Start Day in Ubuntu. Although it's not something I've had to do myself, I expect the procedure to be basically the same in any distribution.
Thanks a lot mate, I'll go play with it now :)
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: LXDE l10n

Postby ReemZ » Sat May 07, 2011 18:04

No worky, and /usr/share/i18n/locales/en_GB already has both first_weekday and first_workday set to 2 :scratch:
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: LXDE l10n

Postby ReemZ » Sat May 07, 2011 18:09

OK this is bad! I've just logged into KDE to check how things look there, and even if all settings were still the same (language set to British English in System Settings -> Locale) my KDE environment is now in American English! :shock:
Undid the changes and now KDE is back to British English.
This makes no sense at all :evil:
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: LXDE l10n

Postby ReemZ » Sat May 07, 2011 19:14

Changed first_weekday in /usr/share/i18n/locales/en_US from 1 to 2, performed a locale-gen and that changed the calendar to Monday-first, both in LXDE and cal.

Sidenote: just did this same thing on my 32-bit machine, locale-gen is now generating 381 locales, where that's only four on the lappy: twice en_US.UTF-8 and twice en_US.ISO-8859-1 :scratch:
Another sidenote: AltGr works differently on both machines; for example, Shift-AltGr-4 will give me the GBP sign (£) and AltGr-s the German "Ringel-S" (ß) on the lappy (which I think is rather cool, I like it!), but it doesn't work on the 32-bit machine. Bit of a shame really, and I've no idea what causes it as apart from one being 64-bit and the other 32, there's no real difference in configuration.
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron