Gnome and defaults apps

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Gnome and defaults apps

Postby enether » Sun Apr 03, 2011 23:55

Hello,

I've got a problem with default applications after last GNOME-related updates. The problem is: icecat was my default web browser for centuries, and now, after update, even with icecat SET as default web browser my SL runs opera.

I tried to change it via menu, via gconf-editor, I even tried exporting BROWSER variable. Nothing works.
SL 5.5 x86_64, xorg 1.9.4, ati-drivers 11.2, kernel 2.6.37, gnome-desktop 2.32.1
enether
Baby Hen
 
Posts: 11
Joined: Sun Jun 13, 2010 11:43

Re: GNOME and defaults apps

Postby Skull Fire » Mon Apr 04, 2011 6:58

i find that many times the last installed app becomes the default. maybe try reinstalling icecat and see if it moves up to default.

do you use opera at all ? maybe uninstall it. :lol:

edit* does opera's menu list it as default ?
multi-booting Sabayon 5.5 kde 64 bit and others
intel e6600 @ 3.0 ghz core duo
6gb ddr2 800
biostar tpower i45 motherboard
nvidia 9800 gt
3) 7200 sata's non-raid
Skull Fire
Growing Hen
 
Posts: 131
Joined: Sun Nov 14, 2010 14:32

Re: Gnome and defaults apps

Postby batvink » Mon Apr 04, 2011 18:42

Go to System->Preferences->Preferred Applications->Browser, choose Custom and type the command icecat %s.

or,

Select "Tools | Options" from the main menu in icecat.

Change to the "General" tab/section.

Click the "Set Default Browser" button.

Click "OK".

Close al icecat windows
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Gnome and defaults apps

Postby enether » Mon Apr 04, 2011 20:51

I did it before guys, it does not work.

I'm not using opera, but i need it 'cause my sister is using this computer too and she hates mozilla-based browsers.
enether
Baby Hen
 
Posts: 11
Joined: Sun Jun 13, 2010 11:43

Re: Gnome and defaults apps

Postby Fitzcarraldo » Mon Apr 04, 2011 21:53

Open a Terminal window and enter the following commands under your user account:

These two commands will tell you the default browser configured for GNOME:

Code: Select all
gconftool-2 -R /desktop/gnome/url-handlers/http
gconftool-2 -R /desktop/gnome/url-handlers/https

If they confirm that Opera is the default browser, do the following:

Code: Select all
gconftool-2 --set --type=string /desktop/gnome/url-handlers/http/command 'icecat %s'
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/http/need-terminal false
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/http/enabled true
gconftool-2 --set --type=string /desktop/gnome/url-handlers/https/command 'icecat %s'
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/need-terminal false
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/https/enabled true
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Gnome and defaults apps

Postby enether » Mon Apr 04, 2011 22:47

Results of gconftool-2:
Code: Select all
([email protected] ~) % gconftool-2 -R /desktop/gnome/url-handlers/http
 command = icecat %s
 needs_terminal = false
 enabled = true
([email protected] ~) % gconftool-2 -R /desktop/gnome/url-handlers/https
 command = icecat %s
 needs_terminal = false
 enabled = true


It looks like a GNOME bug, i'll search for it one more time.
enether
Baby Hen
 
Posts: 11
Joined: Sun Jun 13, 2010 11:43

Re: Gnome and defaults apps

Postby Fitzcarraldo » Tue Apr 05, 2011 6:51

Try the following:

Open a Terminal.

Enter the command gconf-editor

Expand desktop/gnome/applications/browser

What is the value of the exec key?

Then expand desktop/gnome/url-handlers and click on each entry in turn (aim, callto, chrome, etc.) to see what is the value of the command key. Do any contain opera as the command?

Also, what is returned when you enter the following command?

Code: Select all
xdg-mime query default x-scheme-handler/http
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Gnome and defaults apps

Postby enether » Tue Apr 05, 2011 14:53

The value of exec key is "icecat". [ofc without quotation marks]

desktop/gnome/url-handlers don't contain any opera values.

and xdg-mime command returns nothing.
enether
Baby Hen
 
Posts: 11
Joined: Sun Jun 13, 2010 11:43

Re: Gnome and defaults apps

Postby Fitzcarraldo » Tue Apr 05, 2011 17:19

Please try the following:

Code: Select all
$ mkdir -p /home/enether/.local/share/applications
$ echo "x-scheme-handler/http=icecat.desktop" > /home/enether/.local/share/applications/defaults.list
$ echo "x-scheme-handler/https=icecat.desktop" >> /home/enether/.local/share/applications/defaults.list
$ xdg-mime query default x-scheme-handler/http

(Notice the first echo command has one ">" and the second has ">>".)

I don't have icecat installed so I don't know whether "icecat.desktop" is the actual name of the .desktop file for the browser, so please modify it if it is different.

Then try to see if IceCat becomes the default browser. If that doesn't work, do the following and then try again:

Code: Select all
$ su
Password:
# cp /home/enether/.local/share/applications/defaults.list /etc/gnome/defaults.list
# exit
$
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Gnome and defaults apps

Postby enether » Tue Apr 05, 2011 18:55

I tried both of this, icecat.desktop was actually called icecat-3.6.desktop, but it still doesn't work.
Code: Select all
([email protected] ~) % xdg-mime query default x-scheme-handler/http
icecat-3.6.desktop

I loged out and in again, but still nothing.

Well, i think I'll just wait and watch GNOME bugs looking for similiar problem. It's kinda annoying, but harmless.

Thanks for help Fitzcarraldo, batvink and Skull Fire :wink:
enether
Baby Hen
 
Posts: 11
Joined: Sun Jun 13, 2010 11:43

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest