can't get opengl on ati mobility x1600

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

can't get opengl on ati mobility x1600

Postby gowger » Sun Mar 20, 2011 20:17

I hadn't used this laptop in quite some time but I needed in recently and updated it to the latest only to find that opengl doesn't seem to be working any more. Glxgears and glxinfo both segfault when I run them and compiz doesn't run. Information that I find says that the gpl drivers support this card well. I presume they mean 3d works well?

I did have 3d working before though, in fact since the earliest versions of sabayon that had beryl running and it ran quite well. Any idea if it's possible to use older drivers with a modern like 2.6.38 at time of writing, if that is the problem ?

Thanks in advance for any help.
gowger
Young Hen
 
Posts: 32
Joined: Thu Mar 02, 2006 17:13

Re: can't get opengl on ati mobility x1600

Postby Fitzcarraldo » Sun Mar 20, 2011 22:16

I used a laptop with the ATI Mobility Radeon X1600 about a year ago, and the open-source Radeon driver worked well with it, including Compiz. AMD stopped closed-source driver support for that GPU back in early 2009 -- Catalyst for Linux 9.3 was the last closed-source driver for it -- so the FGLRX driver is a big no-no for the Mobility Radeon X1600 and today's kernels. Am I correct in assuming you are now using the open-source Radeon driver? The RadeonHD driver is dead and buried (see The open-source RadeonHD driver bows out). The procedure for installing the Radeon driver for your GPU is the same as that given for the ATI Radeon 9550 GPU in the post Re: ATI Radeon 9550 - need help. Give that a try if you haven't already.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron