KMix not responding [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KMix not responding [Solved]

Postby Fitzcarraldo » Fri Mar 11, 2011 18:06

I'm just posting this in case anyone else is experiencing these problems with KMix performance.

While I was using KDE 4.6.0, a few days ago KMix started to misbehave. Although the KMix icon was present in the System Tray on the Panel, clicking on it would have no effect, and using the wheel on the mouse would not change the volume any more. Sometimes, after a minute or more, suddenly the KMix window would appear, or the volume would change, i.e. a very delayed response to my earlier actions. Actually, sometimes the KMix icon did not even appear in the System Tray after start-up.

I also noticed that KMix was using a lot of CPU time, e.g. 12%.

When I launched KMix from the command line, after a while the following message would appear:

Code: Select all
unnamed app(8273): Communication problem with  "kmix" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

I tried deleting ~/.kde4 but it didn't solve the problem (and of course is a real pain because you have to reconfigure your Desktop).

So I decided to install KDE 4.6.1 in the hope that the problem would go away. It didn't.

I found a 'solution' in the KDE Forums post Re: Kmix eating up all available CPU time on one core:

Code: Select all
killall -9 kmix
rm -rf $(kde4-config --localprefix)/share/apps/kmix/
rm -f $(kde4-config --localprefix)/share/config/kmix*
kmix &

Apparently it's due to a corrupt KMix profile. The remaining question is: Why?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KMix not responding

Postby lxnay » Fri Mar 11, 2011 22:34

Because upstream sucks so bad in terms of .kde* config files backward compatibility. And this happens regularly since KDE 3.x
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: KMix not responding [Solved]

Postby raman » Sat Mar 12, 2011 9:00

Yep :(
I'm a little confused, why old bug in KDE are not repaired for so long time. They give KDE 4.6.0. with sorry i must said this: simple, basic stuff bugs. Now they repaired some new issues from 4.6.0 in 4.6.1, but still basic configuration files and basic program like kmix have old, well know bugs.
I don't understanding this.
Don't take me wrong, another X-windows like Gnome have some issues too.
raman
Advanced Hen
 
Posts: 236
Joined: Mon Sep 06, 2010 17:18
Location: Poland


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest