KDE 4.6 does not work

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDE 4.6 does not work

Postby detestable » Tue Feb 15, 2011 22:13

Hi all,

I run SL on my computer with GNOME as default WM sometimes using KDE. KDE worked pretty well for me until I upgraded it to 4.6. Now when I try to start a KDE session it either refuses to load returning to the login screen or loads after two or three minutes but even then everything is totally frozen and I have to reload the machine.

Does anyone have an idea how to fix it?

Thank you in advance.
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: KDE 4.6 does not work

Postby wolfden » Wed Feb 16, 2011 6:26

gonna need some log files/errors, etc...
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: KDE 4.6 does not work

Postby detestable » Wed Feb 16, 2011 7:39

wolfden wrote:gonna need some log files/errors, etc...


Below I attach a copy of .xsession-errors.

xsession.txt
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: KDE 4.6 does not work

Postby wolfden » Wed Feb 16, 2011 12:16

first thing I would do is run

equo deptest

equo libtest
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: KDE 4.6 does not work

Postby detestable » Wed Feb 16, 2011 13:53

wolfden wrote:first thing I would do is run

equo deptest

equo libtest


Well I run these two commands. There was no broken dependencies and several broken libraries. I don't know whether they have any connection to the problem. Below is the corresponding part of the logs:

Code: Select all
>>  @@ Matching broken libraries/executables
>>  @@ Libraries/Executables statistics:
>>  ## Not matched:
...
>>  ## Matched:
>>    /usr/lib/ghc-6.12.3/base-3.0.3.2/libHSbase-3.0.3.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/integer-gmp-0.2.0.1/libHSinteger-gmp-0.2.0.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libmozldap.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-seq-0.4.0/libHSdph-seq-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/filepath-1.1.0.4/libHSfilepath-1.1.0.4-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/bytestring-0.9.1.7/libHSbytestring-0.9.1.7-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/cairo/libcairo-trace.so.0.0.0 => x11-libs/cairo-1.10.0-r3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libimglib2.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/bin-package-db-0.0.0.0/libHSbin-package-db-0.0.0.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/ghc-prim-0.2.0.0/libHSghc-prim-0.2.0.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/process-1.0.1.3/libHSprocess-1.0.1.3-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libgkplugin.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/old-locale-1.0.0.2/libHSold-locale-1.0.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libwidget_gtk2.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/containers-0.3.0.0/libHScontainers-0.3.0.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libgkgfxthebes.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/array-0.3.0.1/libHSarray-0.3.0.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-prim-seq-0.4.0/libHSdph-prim-seq-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/ghc-6.12.3/libHSghc-6.12.3-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/cairo/libcairo-trace.so => x11-libs/cairo-1.10.0-r3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-par-0.4.0/libHSdph-par-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/time-1.1.4/libHStime-1.1.4-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/hpc-0.5.0.5/libHShpc-0.5.0.5-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/directory-1.0.1.1/libHSdirectory-1.0.1.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-prim-interface-0.4.0/libHSdph-prim-interface-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/random-1.0.0.2/libHSrandom-1.0.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/old-time-1.0.0.5/libHSold-time-1.0.0.5-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/pretty-1.0.1.1/libHSpretty-1.0.1.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/base-4.2.0.2/libHSbase-4.2.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libaccessibility.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-base-0.4.0/libHSdph-base-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/unix-2.4.0.2/libHSunix-2.4.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/cairo/libcairo-trace.so.0 => x11-libs/cairo-1.10.0-r3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/syb-0.1.0.2/libHSsyb-0.1.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/template-haskell-2.4.0.1/libHStemplate-haskell-2.4.0.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/thunderbird/components/libgklayout.so => mail-client/thunderbird-3.1.7-r2 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/haskell98-1.0.1.1/libHShaskell98-1.0.1.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/Cabal-1.8.0.6/libHSCabal-1.8.0.6-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/extensible-exceptions-0.1.1.1/libHSextensible-exceptions-0.1.1.1-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/ghc-binary-0.5.0.2/libHSghc-binary-0.5.0.2-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>    /usr/lib/ghc-6.12.3/dph-prim-par-0.4.0/libHSdph-prim-par-0.4.0-ghc6.12.3.so => dev-lang/ghc-6.12.3 [sabayonlinux.org]
>>  @@ Installing available packages in 10 seconds ...
>> Running with --pretend ...
>>  @@ These are the chosen packages:
>>    # (1/3) [sabayonlinux.org] dev-lang/ghc-6.12.3
>>     Versions: 6.12.3 / NoTag / 2 ===> 6.12.3 / NoTag / 2
>>    Action:       Reinstall
>>    # (2/3) [sabayonlinux.org] mail-client/thunderbird-3.1.7-r2
>>     Versions: 3.1.7-r2 / NoTag / 0 ===> 3.1.7-r2 / NoTag / 0
>>    Action:       Reinstall
>>    # (3/3) [sabayonlinux.org] x11-libs/cairo-1.10.0-r3
>>     Versions: 1.10.0-r3 / NoTag / 1 ===> 1.10.0-r3 / NoTag / 1
>>    Action:       Reinstall
>>  @@ Packages involved: 3
>>  @@ Calculating dependencies ...
>>  @@ These are the packages that would be installed:
>>  ## [R] [sabayonlinux.org] x11-libs/cairo-1.10.0-r3|1   [1.10.0-r3|1]
>>  ## [R] [sabayonlinux.org] dev-lang/ghc-6.12.3|2   [6.12.3|2]
>>  ## [R] [sabayonlinux.org] mail-client/thunderbird-3.1.7-r2|0   [3.1.7-r2|0]
>>  @@ Packages needing to be installed/updated/downgraded: 3
>>  @@ Packages needing to be removed: 0
>>  @@ Packages needing to be installed: 0
>>  @@ Packages needing to be reinstalled: 3
>>  @@ Packages needing to be updated: 0
>>  @@ Packages needing to be downgraded: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 195.8MB of free space
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: KDE 4.6 does not work

Postby Fitzcarraldo » Wed Feb 16, 2011 22:07

Did KDE 4.6.0 work initially, or has it never worked for you? If the former, try the following (it solved my problem of KDE 4.6.0 freezing at the KDE splash screen after the HDD icon appeared):

Code: Select all
# mv /home/detestable/.kde4 /home/detestable/.kde4.old
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.6 does not work

Postby detestable » Thu Feb 17, 2011 0:32

Did KDE 4.6.0 work initially, or has it never worked for you?


No, it never worked for me.

If the former, try the following


Although it was not the case I made a try and after that KDE is loading smoothly. Hopefully the main trouble is over. But now I have empty dark screen and the pointer alone is visible on it. What should I do to restore the KDE desktop?
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: KDE 4.6 does not work

Postby dunsurfin » Thu Feb 17, 2011 9:33

Have you tried the suggestion by wolfden in this post?:
viewtopic.php?f=53&t=22916
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: KDE 4.6 does not work

Postby detestable » Thu Feb 17, 2011 15:15

dunsurfin wrote:Have you tried the suggestion by wolfden in this post?:
viewtopic.php?f=53&t=22916


Yes I tried but with null result.
detestable
Young Hen
 
Posts: 20
Joined: Mon Jul 21, 2008 16:29

Re: KDE 4.6 does not work

Postby Fitzcarraldo » Fri Feb 18, 2011 9:38

What's your GPU? Are you using an X.Org video driver or one of the closed-source drivers? If you're using a closed-source driver then you need to make sure the OpenGL library symlinks are set correctly:

If you're using the nvidia-drivers driver:

Code: Select all
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
# eselect opengl set nvidia
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
#

If you're using the ati-drivers (a.k.a. FGLRX) driver:

Code: Select all
# eselect opengl list
Available OpenGL implementations:
  [1]   ati
  [2]   xorg-x11 *
# eselect opengl set ati
# eselect opengl list
Available OpenGL implementations:
  [1]   ati *
  [2]   xorg-x11
#

If you are using the open-source drivers xf86-video-nv (or xf86-video-nouveau) or xf86-video-ati then you would have to make sure you do eselect opengl set xorg-x11 instead.

Check what video driver you are using, and what the OpenGL symlinks are.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron