xdm wont start after boot [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

xdm wont start after boot [Solved]

Postby apiaio » Sun Jan 30, 2011 20:40

Hi there.
Everthing works nice after fresh installation. Only one thing bother me .I have to start kdm manually.
DISPLAYMANAGER="kdm" is set in /etc/conf.d/xdm. xdm added in default level.
After reboot kde doesn't start automatically. I have to run
kdm
or
/etc/init.d/xdm restart
and kdm starts.
Seems, that kdm starts before xdm ( opinions from others forrums ). Howto fix it with SL?
Thanks
Last edited by apiaio on Mon Feb 07, 2011 21:47, edited 3 times in total.
apiaio
Growing Hen
 
Posts: 115
Joined: Thu Jul 30, 2009 19:44

Re: xdm want start fter boot

Postby Fitzcarraldo » Sun Jan 30, 2011 20:45

Is xdm in the boot runlevel?

Code: Select all
# rc-update show -v | grep xdm
                  xdm |                                           boot
            xdm-setup |

If not, you can add it:

Code: Select all
# rc-update del xdm default
# rc-update add xdm boot
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xdm want start fter boot

Postby apiaio » Sun Jan 30, 2011 21:03

I have xdm in boot level now. Result is the same.
apiaio
Growing Hen
 
Posts: 115
Joined: Thu Jul 30, 2009 19:44

Re: xdm want start after boot

Postby Fitzcarraldo » Sun Jan 30, 2011 22:01

What does /etc/conf.d/xdm contain? Here's mine:

Code: Select all
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | kdm-4.3 | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
#
# KDE-specific note:
# - If you are using kdeprefix go with "kdm-4.Y", e.g. "kdm-4.3".
#     You can find possible versions by looking at the directories in /usr/kde/.
# - Else, if you are using KDE 3 enter "kdm-3.5"
# - Else, if you are using KDE 4 enter "kdm" without a version
DISPLAYMANAGER="kdm"
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xdm want start after boot

Postby apiaio » Mon Jan 31, 2011 13:57

The same here.
apiaio
Growing Hen
 
Posts: 115
Joined: Thu Jul 30, 2009 19:44

Re: xdm want start after boot

Postby Fitzcarraldo » Mon Jan 31, 2011 14:14

After booting, can you enter the command:

Code: Select all
/etc/init.d/xdm start

or do you have to enter the following command:

Code: Select all
/etc/init.d/xdm restart

i.e. did the xdm initscript run automatically, or did it never run until you run it?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xdm want start after boot

Postby smb96 » Mon Jan 31, 2011 14:28

Hi,

in case you used a coreCD or the textinstaller to install, have a look in your grub.cfg and search for a nox option. That will stop X form starting.
smb96
Simple Hen
 
Posts: 70
Joined: Mon Nov 23, 2009 11:44

Re: xdm want start after boot

Postby apiaio » Tue Feb 01, 2011 9:01

Deleting gentoo=nox from grub.cfg solved problem.
Thanx guys.
apiaio
Growing Hen
 
Posts: 115
Joined: Thu Jul 30, 2009 19:44


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron