Compiz will only run with an open terminal [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Compiz will only run with an open terminal [Solved]

Postby spikeyb » Mon Jan 03, 2011 11:39

I had compiz and emerald working ok. I was playing around with the ccsm settings and the pc locked up. I had to hard reboot to get going again.

Upon reboot I could not change the emerald themes and seemed to get a default window border (the colour changed with the gtk theme colour). While trying to find a solution I came across this command to troubleshoot at the compiz wiki: compiz --replace ccp & emerald --replace &

This command causes compiz/emerald to work perfectly but only while the terminal is open. When I close the terminal, the window decoration disappears.

I have reinstalled compiz and emerald and the same behaviour occurs.

Does anyone know why it will only work with the terminal open. Hopefully the answer will help me to solve my problem.

I am running Sabayon 5.4 64 bit with gnome.
Last edited by spikeyb on Tue Jan 04, 2011 23:03, edited 1 time in total.
spikeyb
Simple Hen
 
Posts: 44
Joined: Fri May 22, 2009 19:25

Re: Compiz will only run with an open terminal

Postby batvink » Mon Jan 03, 2011 13:29

open the RUN dialog box by typing the combination: ALT-F2, and type: fusion-icon
if it's not installed, open up console, and type:
Code: Select all
sudo equo install fusion-icon


goto gnome-panel -> system -> preferences -> and open 'startup programs'

in the dialog box that appears, click ADD, give it a name, eg. 'run-compiz',
and type at command:
Code: Select all
fusion-icon
click the ADD button.

that should do the job.
next time you reboot, you should have compiz enabled again.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Compiz will only run with an open terminal

Postby spikeyb » Mon Jan 03, 2011 14:28

That's an interesting point you make. I do have fusion-icon installed. However, after I reinstalled it I am unable to run it using the menu system because an error informs me that I do not have permission. I did have permission prior to the reinstallation.

Originally when things were working ok, for some reason, your suggestion of adding fusion-icon to the startups did not work. I had to change a setting in the configuration editor to swap gnome-wm for compiz and that worked. Not sure if that is related.

I wonder if the fact that things work while the terminal is open gives a big clue (that I am unable to fathom) as to the problem.
spikeyb
Simple Hen
 
Posts: 44
Joined: Fri May 22, 2009 19:25

Re: Compiz will only run with an open terminal

Postby batvink » Mon Jan 03, 2011 18:05

can you check if fusion-icon has proper rights?
it's located in /usr/bin
type as root:
Code: Select all
ls -al /usr/bin/fusion-icon

it should look like this:
-rwxr-xr-x 1 root root 1818 apr 13 2010 fusion-icon


if not, change it:
as root:
Code: Select all
cd /usr/bin

Code: Select all
chown root:root fusion-icon

(sets owner to root, and group to root)
and:
Code: Select all
chmod 755 fusion-icon

(gives owner read,write,execute rights; group and others read,execute rights)
try to run fusion-icon again with this settings.
if it still doesn't work, try to add compiz --replace ccp and emerald --replace (without the "&") to system-preferences-startup programs,
until there's a solution.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Compiz will only run with an open terminal

Postby albfneto » Mon Jan 03, 2011 18:48

This command causes compiz/emerald to work perfectly but only while the terminal is open. When I close the terminal, the window decoration disappears.



seems tomethe normal behaviour. the command will close if terminal is closed.


for using compiz,and emerald,opne it using fusion icon, and substitute mertacity by compiz,then use emerald.
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Compiz will only run with an open terminal

Postby spikeyb » Tue Jan 04, 2011 22:37

Thanks batvink, I have managed to get the fusion-icon permissions sorted and can get it to run. Unfortunately, the start up suggestion does not work. Even when compiz/emerald was working ok,I could only get it to load automatically via configuration settings, not using start up entries.

With your startup suggestion, compiz does appear to load but emerald will not. Currently, emerald only works while the terminal is open and the compiz --replace ccp & emerald --replace & command is run.
spikeyb
Simple Hen
 
Posts: 44
Joined: Fri May 22, 2009 19:25

Re: Compiz will only run with an open terminal

Postby spikeyb » Tue Jan 04, 2011 22:42

albfneto wrote:for using compiz,and emerald,opne it using fusion icon, and substitute mertacity by compiz,then use emerald.
I agree that it should work that way but it appears not to for some reason. It seems that I can get compiz working but cannot change emerlad themes.
spikeyb
Simple Hen
 
Posts: 44
Joined: Fri May 22, 2009 19:25

Re: Compiz will only run with an open terminal [Solved]

Postby spikeyb » Tue Jan 04, 2011 23:11

batvink and albfneto

Thank you for your help. Your suggestions have created small sparks of inspiration which have yielded a solution.

My solution is to set compiz as the window manager using the configuration editor > desktop > gnome > session > required_component

and to set a start up application containing the command emerald --replace

Thank you again for your time and efforts. They are very much appreciated.
spikeyb
Simple Hen
 
Posts: 44
Joined: Fri May 22, 2009 19:25

Re: Compiz will only run with an open terminal [Solved]

Postby batvink » Wed Jan 05, 2011 19:52

you can add/load emerald within Compiz.
this way emerald gets auto loaded with Compiz so you don't need a script.

oopen compiz settings (ccsm)
and on the left side of the window click on effects.

then, on the right side of the window, click on window decoration.

a new window appears, enter at the Command (above mipmap option) emerald --replace

click back, and mark window-decoration. click close
on the gnome panel, on the right, right-click the compiz icon,
Select Window Decorator, and mark Emerald.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: ajr784 and 1 guest