Several gnome apps don't work anymore [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
Sisko43
Growing Hen
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Several gnome apps don't work anymore [Solved]

Post by Sisko43 » Sun Dec 26, 2010 16:03

I'm running the latest KDE on 64bit and I noticed that several gnome apps I use don't work anymore such as file-roller, gnome-mplayer, gecko-mediaplayer and many other applications.

Every prog gives the same error message:

Code: Select all

Gtk:ERROR:gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)


On other distros this problem sometimes was solved by reinstalling "gnome-icon-theme", but not here...

Merry Christmas to everyone!
Last edited by Sisko43 on Mon Dec 27, 2010 23:27, edited 3 times in total.

alonsoty
Advanced Hen
Posts: 236
Joined: Sat Sep 16, 2006 20:39
Location: Marchesonia - Italy

Re: Several gnome apps don't work anymore

Post by alonsoty » Sun Dec 26, 2010 23:12

I'm sorry, I'm really heedless (first I recommended to reinstall gnome-icon-theme)! :lol:

You also tried to reinstall the gtk+ (seems indirectly involved):

Code: Select all

# equo install gtk+

Happy Holidays.

alonsoty
Advanced Hen
Posts: 236
Joined: Sat Sep 16, 2006 20:39
Location: Marchesonia - Italy

Re: Several gnome apps don't work anymore

Post by alonsoty » Sun Dec 26, 2010 23:31

If it does not work, try also to delete the file:
~/.gtkrc-2.0-kde4

Perhaps this issue is related:
https://bugs.launchpad.net/inkscape/+bug/651678

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Several gnome apps don't work anymore

Post by wolfden » Mon Dec 27, 2010 6:05

should also run

equo deptest
equo libtest

make sure stuff is sane

Sisko43
Growing Hen
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: Several gnome apps don't work anymore

Post by Sisko43 » Mon Dec 27, 2010 14:46

Reinstalled gtk+, deleted ~/.gtkrc-2.0-kde4, and run equo deptest/libtest: everything sane. Problem was not solved.

But I noticed that I could start the relevant gnome-apps when starting it from command-line after I executed

Code: Select all

su -


So I created a new user-account and voila everything runs just fine. But not in my old account. Same issue with the account of my wife.

We use these accounts since Sabayon 3.0, so it seems there's something in it , that's not compatible anymore after the last gnome-updates the past weeks. Last thing I did was deleting ".gconf, .gconfd, .gnome and .gnome2". Brought no success.

So I created two new accounts, moved the data over to it and deleted the old ones.

Thanks for the help!

Now everything is solved and runs perfect again!

Sisko43
Growing Hen
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: Several gnome apps don't work anymore

Post by Sisko43 » Mon Dec 27, 2010 20:05

I think I was to fast. Problem occurred again after I changed some settings in KDE via systemsettings.

The actual situation is when I create a fresh account and don't change anything the mentioned gnome-apps runs fine.
But when I make a little change in the look of kde something gets corrupted.

Example:

1. Create new account
2. file-roller starts and unpack my tar.bz-file
3. gnome-mplayer starts and plays my video-file
4. I go into systemsettings change the window-decoration no matter what
5. file-roller and gnome-mplayer crash with above mentioned message

Even if I revert the changes in window-decoration to the origin style gnome-apps crash...

I'm still able to start gnome-apps with the "su -" - trick

alonsoty
Advanced Hen
Posts: 236
Joined: Sat Sep 16, 2006 20:39
Location: Marchesonia - Italy

Re: Several gnome apps don't work anymore

Post by alonsoty » Mon Dec 27, 2010 22:33

It really looks like a problem with the fallback icons and gtk+...
Try to edit the gtkrc file of theme in use:

/usr/share/themes/YOUR_THEME/gtk-2.0/gtkrc
adding or modify line:

Code: Select all

gtk-fallback-icon-theme="oxygen"

i don't use KDE but should be present... :roll:

then, to be sure, delete the files (if exists):
~/.gtkrc-2.0-kde4
~/.gtkrc-2.0

and the hidden folder of gnome apps to test (optional?!):
~/.evolution
~/.gnome2
etc...


I hope you do not have to do it again every time you change your themes!!!
...more than that I would not know! :cry:

Sisko43
Growing Hen
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: Several gnome apps don't work anymore

Post by Sisko43 » Mon Dec 27, 2010 23:26

Strike! :cheers:

Added "gtk-fallback-icon-theme="oxygen" to gtkrc in the "/usr/share/themes/default"-Folder and/or the preferred theme. Can change now whatever I want and everything works !!!

Thank you so much! I owe you one!!

Post Reply