Gnome-Shell --replace error.

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Gnome-Shell --replace error.

Postby DelightedWalrus » Sun Nov 21, 2010 0:29

Hey all,

I've been trying to get Gnome-Shell working on Sabayon for a while now. I always run into the same error and then hop over to Fedora or Arch for a while until it gets fixed. What the problem is, is that every time I run gnome-shell --replace I run into this error:

Code: Select all
Failed to start shell
Traceback (most recent call last):
  File "/usr/bin/gnome-shell", line 422, in <module>
    shell = start_shell()
  File "/usr/bin/gnome-shell", line 158, in start_shell
    stdout=subprocess.PIPE)
  File "/usr/lib64/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1132, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied


I did install gir-repository, and I installed pygtk to see if it would help since it keeps complaining about python.
Are there any suggestions on what to do, or what is going wrong?

Thanks! :)
DelightedWalrus
Baby Hen
 
Posts: 2
Joined: Sun Nov 21, 2010 0:21

Re: Gnome-Shell --replace error.

Postby wolfden » Tue Nov 23, 2010 7:44

did you file a bug report?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Gnome-Shell --replace error.

Postby DelightedWalrus » Wed Nov 24, 2010 4:56

Yeah, it should be filed under the ID of 1988.
DelightedWalrus
Baby Hen
 
Posts: 2
Joined: Sun Nov 21, 2010 0:21


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 3 guests