Can't log into KDE after upgrade of Qt [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Can't log into KDE after upgrade of Qt [Solved]

Postby magesha » Sat Nov 13, 2010 16:19


I just installed the latest updates to Qt via Entropy, using equo commandline. There was a problem during the install and it just stalled. After waiting for 2+ hours, I killed the process and then re-ran the installation. Everything went fine, but then after I rebooted, I can't log into KDE anymore. I share some of the logs here.

fdisk -l: (btw, this took a long time from sabutil menu, and slowed my system down like crazy so I had to stop it and use fdisk -l | pastebunz instead)
Hardware Info:

Please let me know if anything else is needed. I see a lot of errors in kdm.log and in .xsession-errors, but can't make any sense.. :cry: Help much appreciated.

Last edited by magesha on Sun Nov 14, 2010 20:35, edited 1 time in total.
Young Hen
Posts: 21
Joined: Fri Oct 22, 2010 21:09

Re: Can't log into KDE after upgrade of Qt

Postby free_energy » Sun Nov 14, 2010 8:26

I had a similar problem with my amd64 cpu and nvidia card.
Fortunately you have the full equo and emerge facility without kdm.
Use eselect list and you might see a new kernel version selected. I saw 2.2.36 on one of your logs.
If the last kernel you eselected video for was 2.6.35 ,which is where I am at, you need to eselect your video card.
For nvidia I had to emerge the genkernel source for the nvidia driver to install properly. Nvidia requires kernel source to compile. I don't have any experiance with the intel video card which I think it is open source and is already included in the kernel. The video driver must be installed for each kernel upgrade.
I'm new to Sabayon and have good hopes it can get me to a flexible system. I have the same kind of problems with Ubuntu and their lack of source kernel and build-essential utilities in their install disc. I see you have Windows so you can look at the Sabayon wiki page. I have learned to always have two operating systems on every computer.
Baby Hen
Posts: 5
Joined: Wed Apr 28, 2010 8:45
Location: Florida, USA

Re: Can't log into KDE after upgrade of Qt

Postby magesha » Sun Nov 14, 2010 20:35

Thanks free_energy, but I don't think the problem was caused by change to the new kernel, although it could be and it only blew up when I update Qt. Anyway, the kind people in the irc (genfool and Azerthoth, among others) helped me out, and I did a few things:

1. Deleted ~/.kd* first to see if it fixed it but it didn't,
2. equo install kde-meta: which installed, to my surprise 107 packages, Still didn't fix
3. equo libtest && equo deptest: The libtest installed some18 packages, and deptest installed two, after restarting x, I got KDE but lost sabayon customizations,
4. Copied /etc/skel/.kd* into my ~/ preserving the paths (cp -a /etc/skel/.kde* ~/)

Now, it is back to how it was in a fresh install. I am going to mark this as SOLVED.

Young Hen
Posts: 21
Joined: Fri Oct 22, 2010 21:09

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests