KDE 4.2.4: No option in Device Notifier to play Audio CD

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

KDE 4.2.4: No option in Device Notifier to play Audio CD

Postby Fitzcarraldo » Wed Jul 22, 2009 23:06

Can you believe that Amarok 2 does not "currently" support Audio CD playback?

http://amarok.kde.org/wiki/FAQ#How_do_I_play_audio-CDs

FAQ - Amarok Wiki wrote: How do I play audio-CDs

Amarok 2 does not currently support audiocd playback.


Talk about one step forward and two steps backward. :roll:

While we're talking about one step forward and two steps backward, KDE 4.2.4 on my SL-4.1-world-upgraded-to-4.2 installation only shows the option to "Extract Digital Audio with K3b" in the Device Notifier when I insert an Audio CD. There is no option to play the darn CD! It's no surprise that, amongst other options, KDE 3.5.10 offered you the option of playing an Audio CD. Turns out that this is yet another area where KDE 4 lags behind KDE 3.5.10. Anyway, here's what I had to do to get the Device Notifier to give me the option to play an Audio CD:

In the directory /usr/share/apps/solid/actions/ create the file kscd_open_audiocd.desktop with the following contents:

Code: Select all
[Desktop Entry]
X-KDE-Solid-Predicate=[ StorageVolume.ignored == false AND OpticalDisc.availableContent == 'Audio' ]
Type=Service
Actions=open;

[Desktop Action open]
Name=Play CD with KsCD
Exec=kscd -s
Icon=kscd

Now log-out and back in again, insert an Audio CD and you should find that Device Notifier offers you an extra action.

If you don't like KsCD (let's face it, who does?) and would prefer to use e.g. Kaffeine then you can create a file kaffeine_open_audiocd.desktop with the following contents instead:

Code: Select all
[Desktop Entry]
X-KDE-Solid-Predicate=[ StorageVolume.ignored == false AND OpticalDisc.availableContent == 'Audio' ]
Type=Service
Actions=open;

[Desktop Action open]
Name=Play CD with Kaffeine
Exec=kaffeine -d %u AudioCD
Icon=kaffeine

If you're like me, your next action would probably be to try and create a file for Amarok 2 -- now you know why I mentioned Amarok 2 at the beginning of this post. :D Well, if you have Amarok 1.4.10-* installed instead of 2.* then you can create a file amarok1_open_audiocd.desktop for that (not that I've tried it out):

Code: Select all
[Desktop Entry]
X-KDE-Solid-Predicate=[ StorageVolume.ignored == false AND OpticalDisc.availableContent == 'Audio' ]
Type=Service
Actions=open;

[Desktop Action open]
Name=Play CD with Amarok 1
Exec=amarok --cdplay %d
Icon=amarok


I hope this saves somebody wasting too much time trying to figure out why KDE 4.2 and/or Amarok 2 doesn't want to play his/her Audio CDs.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: KDE 4.2.4: No option in Device Notifier to play Audio CD

Postby wolfden » Thu Jul 23, 2009 5:16

what are these strange things called an audio cd?

:P

I don't even know where my audio cds are, ripped em all to hard drive and never looked back

Good work on a solution!
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests