KDE 4.2.0

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

joost
Sagely Hen
Posts: 2810
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

KDE 4.2.0

Post by joost » Sat Jan 31, 2009 1:11

KDE 4.2.0 is now available in entropy.

I could not keep full support for KDE 4.1.4 but i think its worth it.
Knock yourself out.

The split language packages will follow.

:D
My blog | Mastodon | Please support Sabayon: Become a Patron

eMxyzptlk
Young Hen
Posts: 23
Joined: Sat Jun 07, 2008 1:15
Location: Rennes
Contact:

Re: KDE 4.2.0

Post by eMxyzptlk » Sat Jan 31, 2009 1:16

Nice :) :) :)

Thx Joost

/me give Joost a beer :P
Image

curse
Simple Hen
Posts: 53
Joined: Tue Jul 03, 2007 13:15
Location: Gran Canaria
Contact:

Re: KDE 4.2.0

Post by curse » Sat Jan 31, 2009 4:29

thanx, will be interesting to checkout KDE 4.* only heard crap about it, but people have been hoping 4.2 is the turn to being useable

denijane
Growing Hen
Posts: 175
Joined: Tue Feb 13, 2007 19:54
Location: Sofia
Contact:

Re: KDE 4.2.0

Post by denijane » Tue Feb 03, 2009 19:35

Am I going to be the first to comment on KDE 4.2.0? Oh, well :)
So, although I was very pessimistic about it, I of course, decided to try it. Installed it trough Equo. At first, it looked like 4.1 and I wouldn't use it, but my networkmanager stop working and I could have internet only on KDE 4.2. (and only wired one). So, today, I use 4.2. the whole day.

Surprisingly, I managed to get a full functionality- all the panels I'm used to and so on are here, and that's pretty cool. Well, it's not as simple as it's in kde 3.5 but it's doable. Also, I like some of the plasmoids, though I don't think there's something I can't live without. Also, the kwin composite offers some fun without the need to use Compiz (and I don't use it because I find it too annoying). And it's pretty all right. I guess it could get even prettier, but I don't have the time for this.
And I like the alt+f2 new menu. It's very useful. And cute.
The weather widget also is nice.
That was the bright side.

On the not-so-bright side- the installation of some plasmoids is too hard-if they are the right format, they install, but don't appear in all the menus. If they are not the right format, they are not appearing at all.
I don't have a seeable digital clock-for some unknown to me reasons, the clock is invisible.It's there, but you cannot see it. Though on hover, it shows the time.
I can't connect to wireless. I read that it's a problem with knetworkmanager, but so what. My guess is that if I didn't have a protected wireless net, I would be able to connect to it, but mine is protected. The wired connection is ok, though it looks little bit slow to me.
Kopete crashes plasma. It restarts almost immediately, but it's EXTREMELY annoying, so much that I use penguin instead. The use of the Dictionary widget also crashes Plasma.
The Desktop viewer don't show me text under the icons-luckily I turned off the "shadow on focus" option and now I see the text when I hover. But still, it's not very practical for someone like me who adores the untidy Desktop.
Also it seems like the reaction to my click is somewhat slow.
The Ocular unlike kpdf and the kdvi cannot export to pdf, neither to print to pdf and that's very distressing, I'm looking for an alternative now.
And yeah, the freezing of X that I started to encounter since my upgrade to SL4 become more frequent. And that's not so good.
Well, I think that's all I found out today. Although there are some bugs that have to be fixed, I think that KDE 4.2. is usable and until I get working internet on the 3.5 I'll have to use it. And maybe even afterwards. It's quite beautiful and if I fix the problems, it's gonna be quite usable. Just be careful with "remove this quicklaunch"!

joost
Sagely Hen
Posts: 2810
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: KDE 4.2.0

Post by joost » Tue Feb 03, 2009 20:12

To fix the "missing fonts and no clock"

For best results set all fonts to "Gullim" and then in Konsole edit your profile and set it to a different type like bitstream or something.
My blog | Mastodon | Please support Sabayon: Become a Patron

denijane
Growing Hen
Posts: 175
Joined: Tue Feb 13, 2007 19:54
Location: Sofia
Contact:

Re: KDE 4.2.0

Post by denijane » Tue Feb 03, 2009 20:26

Wow, that indeed fixed it. I only changed to Gullim and now I see text again. Cool! Though on the clock, I had to manually change it to that font.
Thank you joost , you were very helpful! :D Now, I like it even more :P If only I get the network manager to work.

joost
Sagely Hen
Posts: 2810
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: KDE 4.2.0

Post by joost » Tue Feb 03, 2009 20:29

If you find anything that could have been compiled in a different way to support whatever better, let me know and i'll look into that.
Remember this is just the initial port from portage. We didn't do any modifications on skel yet.

:D

We are also looking into getting networkmanager support back for KDE ASAP.
My blog | Mastodon | Please support Sabayon: Become a Patron

joost
Sagely Hen
Posts: 2810
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: KDE 4.2.0

Post by joost » Tue Feb 03, 2009 20:36

Ooh over here the plasmoids don't crash.

Kopete is also fine on x86.
//edit
It only crashes when somebody pages me.. :alien:

Did you reboot your system after post-install KDE 4.2? I know it needs for some stuff to be restarted like dbus.
Best would be a complete reboot.
My blog | Mastodon | Please support Sabayon: Become a Patron

denijane
Growing Hen
Posts: 175
Joined: Tue Feb 13, 2007 19:54
Location: Sofia
Contact:

Re: KDE 4.2.0

Post by denijane » Tue Feb 03, 2009 22:08

Hey! Yes, I rebooted after the installation (it was yesterday, actually), so this shouldn't be the problem.
My Kopete crashes plasma only when somebody sends me a message and I receive the notification above the tray. Otherwise it works fine.

What I'd like to see fixed, besides the network, is that freezing I'm experiencing. It happened on the 3.5 but only from time to time for around a second. Now it's more often and maybe 2 seconds. When it freezes, the mouse stops moving and the music stops. I edited somewhat xorg.conf to try to solve the problem but it didn't help. :( Ideas?
(I'm using 64bit SL) and ati video card.

Updated: As suggested, I posted my question to another thread. http://forum.sabayonlinux.org/viewtopic.php?f=5&t=16012
Last edited by denijane on Tue Feb 03, 2009 23:42, edited 1 time in total.

joost
Sagely Hen
Posts: 2810
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: KDE 4.2.0

Post by joost » Tue Feb 03, 2009 23:07

well lets not go offtopic to much cuzz i think thats not really KDE related.

My guess would be anyway that your using a closed source driver.
These are kinda hard to predict sometimes.

More info would be needed to solve this, maybe start a new topic about this and post some stuff about your rigg, some logs (e.g. dmesg or dmesg | tail right after something weird happens)
and lspci and lsmod

We could digg into this for sure.
My blog | Mastodon | Please support Sabayon: Become a Patron

Post Reply