winkey.desktop superkey problem [Solved]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: winkey.desktop superkey problem

Postby Tanis Shadow » Tue Dec 30, 2008 0:06

OK, I tried and unfortunatelly it didn't work.
I added the line
Option "DontVTSwitch" "true"
to the ServerFlags Section in xorg.conf but nothing changed.

But I found another thing, after I killed my XServer with Ctrl+Alt+Backspace and logged back in everything is as it should, meaning that console switching is disabled and using the winkey or Alt+Functionkey does what it should.

EDIT:
I'm out of ideas. I've tried serveral options that should disable the vt switching but none of them worked.
The method of killing the xserver via Ctrl+Alt+Backspace and logging back in works though.
Tanis Shadow
Baby Hen
 
Posts: 5
Joined: Mon Dec 29, 2008 19:16

Re: winkey.desktop superkey problem

Postby Tanis Shadow » Tue Dec 30, 2008 11:57

I found a solution and here is what I did
1. go to /usr/src/linux/drivers/char and copy the file defkeymap.map (if the path is does not apply for you, use the find command to look for the file) to your home or working directory
2. open the file with an editor and look for any lines including "console" and delete the entries according to the following example:
keycode 59 = F1 F11 Console_13 <-- delete only the "Console_13"
control keycode 59 = F1 <-- delete nothing
alt keycode 59 = Console_1 <-- delete the whole line
control alt keycode 59 = Console_1 <-- delete the whole line

also delete everything starting with "compose" (meaning all the stuff at the end of the file). I'm not sure why though but if I don't I get an error at startup stating "keymaps failed to load" and the line number where the first "compose" appears.

and save this
3. now go to /usr/share/keymaps/i386/ and then to qwertz or qwerty or whatever you use
4. in the folder look for the keymap you are using and make a safety copy (e.g. I use de.map so I copied de.map.gz)
5. in your working directory rename the modified defkeymap.map according to what you just copied (e.g. in my case defkeymap.map became de.map)
6. make an *.gz archive of the new *.map (de.map --> de.map.gz)
7. replace the *.map.gz file in /usr/share/keymaps/i386/ with the one you just created (as root of course)
8. reboot and cross fingers
Alternatively stop after step 2 and use the loadkeys command to try it out ($ sudo loadkeys defkeymap.map)

That did it for me. Hope it helps.

Based on:
http://www.linuxjournal.com/article/187
http://ftp.utcluj.ro/pub/docs/how-to/mi ... /Keystroke
http://humanreadable.nfshost.com/sdeg/right_alt_key.htm
Tanis Shadow
Baby Hen
 
Posts: 5
Joined: Mon Dec 29, 2008 19:16

Re: winkey.desktop superkey problem

Postby dagurasu » Tue Dec 30, 2008 17:57

Tanis Shadow wrote:Hi there,
I've got the same problem. Hitting the super key switches to the maintenance prompt. And the same happens when I use ALT+F1 (or F2 or F3 and so on).
Since I'm using Gnome I would normaly use ALT+F2 for the run application window but right now ....
I have searched for quite some time now but I haven't found a solution yet so if anything turns up it would be if some could post it here.
Tanis Shadow


First I'm going to assume you meant cntrl-alt-F2.. alt-F2 passes to apps for me, as it should. If this is not the case for you, then yes something is wrong(edit: unusual/non-standard/weird at least).

If you do mean cntrl-alt-F2, I understand your concern, but to be fair, ctrl-Alt-FN where n =1 1thourgh maybe 8 has always since the beginning of linux been used to switch to virtual consoles.. I used it even before I used X at all (back when x did nothing much more useful than open x-terms anyway, yes I'm starting to feel old.. the computing world will do that to you). In fact after switching (either this way, or using the windows key) you can get back to windows by pressing alt-F7 in most setups. VC's are very nice becasue they give you quick root accessibility from a prompt when windowing things aren't working, without requiring a reboot. That said, just because this has always been this way doesn't mean you have to do it that way. If you want to just disable VC's altogether, I'm pretty sure even in 2008 you can do this in the /etc/inittab.

The windows key thing is new to me, but it may also have some history, certainly not as long of a history. Anyway, it doens't really, matter we can try to make things the way we like.

It looks like there may be a couple of fixes in here, so that's good.
dagurasu
Simple Hen
 
Posts: 82
Joined: Fri Jun 01, 2007 23:33

Re: winkey.desktop superkey problem

Postby Tanis Shadow » Tue Dec 30, 2008 22:11

dagurasu wrote:First I'm going to assume you meant cntrl-alt-F2.. alt-F2 passes to apps for me, as it should. If this is not the case for you, then yes something is wrong(edit: unusual/non-standard/weird at least).


Nope, I didn't. I meant alt-F2. And you're right normally it passes to apps which it does .... but at the same time it switched to VT for me which is kind of annoying.

dagurasu wrote:In fact after switching (either this way, or using the windows key) you can get back to windows by pressing alt-F7 in most setups.


I know but having to press alt-F7 to get back to X every time I used the winkey or alt-F2 without the intent of switching to console .....

dagurasu wrote:If you want to just disable VC's altogether, I'm pretty sure even in 2008 you can do this in the /etc/inittab.


That may be true but I have to admit that I don't know how. For disabling VCs or the switching altogether, all I only found was the "DontVTSwitch" Option for the xorg.conf and that didn't do anything for me.
Tanis Shadow
Baby Hen
 
Posts: 5
Joined: Mon Dec 29, 2008 19:16

Re: winkey.desktop superkey problem

Postby lvulliermet » Wed Dec 31, 2008 12:21

Hello there!

Same issue here : I have installed sabayon 4 x86 on my inspiron 1720 in french and the win, alt+F2 ... etc lead to the same issue.
Even getting back to kde with alt + F7 is useless as the touchpad is not active anymore... will try with a usb mouse as it is a pain to reboot each time.

Which I found hard is that the live cd is working fine but once installed.... oops.

I will try to dig it further after tonight (I have to get back on my cooking ^^) which could be the difference that make it work !

Happy new year to you all !
lvulliermet
Baby Hen
 
Posts: 3
Joined: Wed Dec 31, 2008 12:14

Re: winkey.desktop superkey problem

Postby colejv » Wed Dec 31, 2008 18:43

Yeah I installed on my Latitude D620 and noticed that the touchpad goes away after you use alt-f7 to restore, this model also has an eraser(it's funny I can't think of what else to call it) and seperate set of mouse buttons which continue to work
colejv
Young Hen
 
Posts: 32
Joined: Sat Aug 04, 2007 19:30

Re: winkey.desktop superkey problem

Postby dagurasu » Wed Dec 31, 2008 21:27

I see.. left atl-Fsomethings swithces, right alt doesn't.. except for right alt-F5 and F6 I think... very odd. Pretty sure this should only be cntrl-alt in "normal" setups. I agree.. that's annoying. I still have bigger things to fiddle with for now though. As for inittab just commenting otu the terminal lines will disable them... but what I realized/remembered is I think it will still switch.. just to a blank screen though. I'll check out your fix then.
dagurasu
Simple Hen
 
Posts: 82
Joined: Fri Jun 01, 2007 23:33

windows key

Postby garrywestwell » Thu Jan 01, 2009 19:02

Hi All

When I have accidentally pressed with 'windows' key on my laptop the screen changes to a kind of 'terminal' style screen and I have no idea how to get back into the normal session without shutting down.

Has anyone any ideas?

Thanks

Garry
garrywestwell
Baby Hen
 
Posts: 5
Joined: Thu Jan 01, 2009 12:58

Re: windows key

Postby DHalens » Thu Jan 01, 2009 19:31

I'm having the same issue...
Ctrl+Alt+F7 will return you into graphical mode.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: windows key

Postby chrono » Thu Jan 01, 2009 21:48

DHalens wrote:I'm having the same issue...
Ctrl+Alt+F7 will return you into graphical mode.

... or you can keep pressing it (which cycles through terminals, 12 times or so) until you're back to X.
I have the same issue and would appreciate ideas about solving this. It blows my mind how this behaviour can be default (I just installed Sabayon) - for me it's a surprisingly big inconvenience as I use the win key for dozens of shortcuts (despite having used linux for 6 or so years) and I guess anybody who has ever used Windows for any length of time will probably feel the same.
From what I could see this isn't an issue of KDE configuration (most notably because this win key works outside KDE, as well as alt + <arrow-left> or <arrow-right> switch terminals forward/back).

Any ideas appreciated (for the life of me I can't figure out where the config files concerned are)...
chrono
Baby Hen
 
Posts: 8
Joined: Mon Aug 14, 2006 1:11

PreviousNext

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron