Xfce keyboard layout

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Xfce keyboard layout

Postby johnbro » Tue Jul 29, 2008 1:14

Hi all!
Recently installed Sabayon, loving it!
Been trying xfce and would like to know how I enable the UK keyboard layout. If I log in to Kde the layout is fine, log in to Xfce and its the US layout, try as I might can't get the UK layout, is this just one of those grin and bear it moments?
Cheers
Jon
johnbro
Baby Hen
 
Posts: 13
Joined: Tue Jul 29, 2008 1:06

Re: Xfce keyboard layout

Postby sjieke » Tue Jul 29, 2008 8:09

Xfce has a keyboard configuration tool called XFKC. You can run it from the settings menu (I don't know the entry, not on my linux box right now) or execute the the command
Code: Select all
xfkc

To apply your changes you need to run
Code: Select all
xfkc --apply

If on reboot the changes aren't saved, add xfkc to your autostarted applications.
There is also a keyboard layout switcher for the panel 'xfce4-xkb-plugin'. This let you change between all available keyboards set up using xfkc. It is available in equo as 'xfce4-xkb'. Just execute (as root)
Code: Select all
equo install xfce4-xkb
and add it to your panel.
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: Xfce keyboard layout

Postby johnbro » Tue Jul 29, 2008 15:36

Hi Sjieke!
Thanks for the input, however I've already tried using XFKC, running it from settings, with no luck. Tried running it from terminal adn when I run apply I get this:-
xfkc --apply
Error: Can't find file "uk" for symbols include
Exiting
Abandoning symbols file "(null)"
[1217341754,000,xklavier_config_xkb.c:xkl_config_get_keyboard/] Could no t load /usr/bin/xkbcomp output as XKM file, got 127 (asked 127)

H'mm, any more ideas, I know its not a major problem, just a bit annoying!
johnbro
Baby Hen
 
Posts: 13
Joined: Tue Jul 29, 2008 1:06

Re: Xfce keyboard layout

Postby sjieke » Tue Jul 29, 2008 15:57

The uk keyboard layout doesn't exist on your system. Try adding another one by using Xfkc, just press add or edit and select the correct one from the list. If I'm not mistaken it should be called 'gb' instead of 'uk'. For the shell keymaps (/etc/conf.d/keymaps) 'uk' works but for xorgs xkb it is 'gb' I think.

On a side note. There is a package in equo called 'sys-apps/keyboard-configuration-helpers' this installs a python script called 'keyboard-setup' written by lxnay himself. This can configure your keyboard for system (this is the shell used in the virtual terminals), xorg, gnome, kde and xfce. If the previous failes I would try this script.
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests