Cant update compiz fusion

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Cant update compiz fusion

Postby tman7510 » Thu Jun 05, 2008 18:55

I've followed wolfdens tutorial and am using the script but I get these errors when trying to upgrade

I'm using 3.4f

Calculating dependencies... done!
[ebuild U ] dev-libs/glib-2.16.3 [2.12.11] USE="-debug -doc -fam% -hardened
(-selinux) -xattr%" 4,435 kB
[ebuild N ] x11-libs/compiz-bcop-9999 0 kB [1]
[ebuild N ] dev-db/mysql-init-scripts-1.2 0 kB
[ebuild U ] x11-libs/libxklavier-3.6 [3.1] USE="-doc" 452 kB
[ebuild U ] dev-libs/liboil-0.3.14 [0.3.11] USE="-doc" 801 kB
[ebuild U ] dev-libs/dbus-glib-0.74-r1 [0.73] USE="-debug -doc (-selinux)" 6
40 kB
[ebuild U ] x11-libs/pango-1.20.3 [1.16.3] USE="X%* -debug -doc" 1,384 kB
[ebuild U ] gnome-base/libgnomekbd-2.22.0 [2.18.1] USE="-debug" 397 kB
[ebuild U ] x11-wm/metacity-2.22.0 [2.18.2] USE="xinerama -debug" 2,024 kB
[ebuild N ] media-plugins/gst-plugins-dvb-0.10.6 1,736 kB
[ebuild N ] dev-db/mysql-5.0.60-r1 USE="berkdb perl ssl -big-tables -cluste
r -debug -embedded -extraengine -latin1 -max-idx-128 -minimal (-selinux) -static
" 27,369 kB
[ebuild N ] virtual/mysql-5.0 0 kB
[ebuild N ] dev-perl/DBD-mysql-4.00.5 120 kB
[ebuild N ] media-libs/gmyth-0.7 USE="-debug" 487 kB
[ebuild N ] media-plugins/gst-plugins-mythtv-0.10.6 0 kB
[ebuild U ] media-libs/gstreamer-0.10.19 [0.10.12] USE="nls%* -debug% -test%
" 2,168 kB
[ebuild U ] media-libs/gst-plugins-base-0.10.19 [0.10.12] USE="nls%* -debug
(-X%*) (-alsa%*) (-esd%*) (-oss%) (-xv%*)" 1,866 kB
[ebuild U ] media-libs/gst-plugins-bad-0.10.6 [0.10.4] USE="-debug" 0 kB
[ebuild U ] media-plugins/gst-plugins-fluendo-mpegdemux-0.10.15 [0.10.4] 281
kB
[ebuild N ] media-plugins/gst-plugins-meta-0.10-r2 USE="X a52 alsa dvb dvd
esd ffmpeg flac mythtv ogg theora -mad -mpeg -oss -vorbis -xv" 0 kB
[ebuild N ] dev-util/gtk-doc-am-1.10-r1 395 kB
[ebuild U ] x11-libs/gtk+-2.12.10 [2.10.11] USE="X cups%* tiff xinerama -deb
ug -doc -jpeg* -vim-syntax%" 15,851 kB
[ebuild U ] gnome-base/gnome-desktop-2.22.2 [2.18.1] USE="-debug -doc" 1,410
kB
[ebuild N ] gnome-base/gnome-settings-daemon-2.22.2.1 USE="alsa esd -debug
-gstreamer" 1,113 kB
[ebuild N ] gnome-base/control-center-2.22.2.1 USE="alsa esd hal -debug -ed
s" 2,061 kB
[ebuild N ] x11-wm/compiz-9999 USE="dbus gnome kde svg -fuse -gtk -kde4 -xc
b" 0 kB [1]
[ebuild N ] x11-libs/libcompizconfig-9999 0 kB [1]
[ebuild N ] x11-plugins/compiz-fusion-plugins-main-9999 USE="gnome" 0 kB [1
]
[ebuild N ] x11-plugins/compiz-fusion-plugins-wallpaper-9999 0 kB [1]
[ebuild N ] x11-plugins/compiz-plugins-screensaver-9999 0 kB [1]
[ebuild N ] x11-plugins/compiz-fusion-plugins-unsupported-9999 0 kB [1]
[ebuild N ] dev-python/compizconfig-python-9999 0 kB [1]
[ebuild N ] x11-libs/compizconfig-backend-kconfig-9999 USE="xinerama -debug
" 0 kB [1]
[ebuild N ] x11-plugins/compiz-fusion-plugins-extra-9999 USE="gnome" 0 kB [
1]
[ebuild N ] x11-libs/compizconfig-backend-gconf-9999 0 kB [1]
[ebuild N ] x11-apps/ccsm-9999 0 kB [1]
[ebuild N ] x11-apps/fusion-icon-9999 USE="-gtk -qt4" 0 kB [1]
[ebuild N ] x11-wm/emerald-9999 0 kB [1]
[ebuild N ] x11-themes/emerald-themes-9999 0 kB [1]
[ebuild N ] x11-wm/compiz-fusion-9999 USE="gnome kde -unsupported" 0 kB [1]
[blocks B ] <=dev-util/gtk-doc-1.10 (is blocking dev-util/gtk-doc-am-1.10-r1 )
[blocks B ] <media-libs/gst-plugins-ugly-0.10.6-r1 (is blocking media-libs/g streamer-0.10.19)
[blocks B ] <gnome-base/gnome-control-center-2.22 (is blocking gnome-base/gn ome-settings-daemon-2.22.2.1)

Total: 40 packages (13 upgrades, 27 new), Size of downloads: 64,982 kB
Conflict: 3 blocks (3 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/portage/local/layman/desktop-effects

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
tman7510
Simple Hen
 
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Re: Cant update compiz fusion

Postby wolfden » Thu Jun 05, 2008 23:47

sure you can if you take care of the blocks

3.4 is terribly old and makes updating it very hard and next to impossible if you don't know portage.


I would grab a copy of 3.5 Loop3 and than update Compiz
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Cant update compiz fusion

Postby xlnagla » Fri Jun 06, 2008 4:17

Wolden's right - we'll start with that, but if you really like 3.4f then the way to deal with those blocks is just update the pacakages that are blocking. But touching anything on 3.4 will precipitate a long chain of updates, especially if it involves python or (to a lesser extent) java. Best of luck.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: Cant update compiz fusion

Postby tman7510 » Fri Jun 06, 2008 16:21

I've taken care of the blocks but now I get this new error and have no idea how to fix this!

Emerging (4 of 16) x11-plugins/compiz-fusion-plugins-main-9999 to /
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
>>> Unpacking source...
* git update start -->
* repository: git://anongit.compiz-fusion.org/fusion/plugins-main
fatal: ambiguous argument 'master': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions
fatal: Couldn't find remote ref master
*
* ERROR: x11-plugins/compiz-fusion-plugins-main-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 2969: Called git_src_unpack
* environment, line 2214: Called git_fetch
* environment, line 2196: Called die
* The specific snippet of code:
* ${EGIT_UPDATE_CMD} ${EGIT_OPTIONS} origin ${EGIT_BRANCH}:${EGIT_BRANCH} || die "${EGIT}: can't update from ${EGIT_REPO_URI}.";
* The die message:
* git.eclass: can't update from git://anongit.compiz-fusion.org/fusion/plugins-main.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-plugins/compiz-fusion-plugins-main-9999/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-plugins/compiz-fusion-plugins-main-9999/temp/environment'.
tman7510
Simple Hen
 
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Re: Cant update compiz fusion

Postby xlnagla » Sat Jun 07, 2008 2:10

git sources might be bad... wait a day or so, they're updated frequently.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron