Page 1 of 1

logout, x shutdown problem [Solved]

Posted: Wed Mar 26, 2008 8:33
by acfreema
my problem is basically the same as this situation, except, i'm using 32bit and no compiz. logout, switch user, reset x, etc leave me with a black screen with a blinking cursor at the top-left. changing to any of the other terminals results in a red border that says "terminal" in big letters. i installed the ati drivers specified for my gpu (mobile hd 2600) and... i'm not sure what else could be the culprit.

need more info? and ideas?

Re: logout, x shutdown problem

Posted: Wed Mar 26, 2008 13:55
by xlnagla
If you're not using C-F, remove it. I've only ever seen this as a C-F error, and fusion-icon has been known to background before.

~xlnagla

Re: logout, x shutdown problem

Posted: Wed Mar 26, 2008 22:04
by acfreema
no compiz, i removed all of it after determining that it didn't accelerate the desktop

Re: logout, x shutdown problem

Posted: Thu Mar 27, 2008 7:30
by acfreema
so... no one has anything? come on, someone has to know something

Re: logout, x shutdown problem

Posted: Thu Mar 27, 2008 15:02
by xlnagla
hm... you could try on IRC, or make a new post so that more people notice it - though you may want to include a footnote apologizing to the mods for creating two different posts.

~xlnagla

Re: logout, x shutdown problem

Posted: Thu Mar 27, 2008 16:14
by acfreema
i should make another thread because this one is being ignored? i don't follow that reasoning

Re: logout, x shutdown problem

Posted: Thu Mar 27, 2008 16:33
by DontPanic
I'm also having a similar problem, and I don't have a solution either. I have several Sabayon installs, and one Gentoo install, and the problem is not consistent with all installations. Some have it and some don't.

It is interesting to see you having the problem with an ATI card. I was thinking it was some configuration error in my nVidia setup.

Re: logout, x shutdown problem

Posted: Thu Mar 27, 2008 17:15
by DontPanic
OK, you motivated me to find a solution to my problem. Let's see if the same solution works for you.

Edit your /usr/kde/3.5/share/config/kdm/kdmrc

See if you have a line like:

Code: Select all

#TerminateServer=true
Uncomment that line, then close everything down and restart your X-server (<ctrl><alt><backspace>).

Let me know if this works for ATI cards also.

Re: logout, x shutdown problem

Posted: Sat Apr 05, 2008 12:32
by acfreema
sorry i've been gone for so long - i was uninstalling, editing, installing, blah blah blah... i forgot to mention that i am using gnome.

anyway, i found a solution. i don't know about nvidia, but with my gpu, when installing the drivers, there was some sort of collision with (i hope i remember correctly) /lib/share/drivers/video/fglrx.ko. i removed that and the drivers installed correctly! glxgears hovers in the 4600-4800fps range, instead of below 1000. direct rendering is a go; i was even able to run enemy territory.

whoo! i just need to get a couple of other things running smoothly with linux, and i can beat windows into the smallest non-swap partition!