XGL white screen ?!?

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

XGL white screen ?!?

Postby l1nux » Sun Jan 27, 2008 15:21

When i select XGL Acceleration there is only white screen when the KDE starts. But when i used only the Live DVD before the install there was no problem, compiz used to work :D why now it won't ? :D i have navidia geforce 6200 128mb Agp card. There is nvidia setting, everything elese is fine, but it's odd, there must be some conflicts, should i try downloading the latest driver from nvidia.com, and uninstall the stock one from sabayon?
how can i remove it? thanks for any further solutions, sorry if my english isn't that good :P


PS i fixed xorg.conf with "nv" instead of "nvidia"
installed the latest accelerated drivers and used AIGLX instead, i works now, but a bit slower.. :P
l1nux
Baby Hen
 
Posts: 1
Joined: Sun Jan 27, 2008 15:09

Re: XGL white screen ?!?

Postby joost » Sun Jan 27, 2008 20:56

Nvidia should work with AIGLX, or even Native compositing support directly from the driver itself.
Remeber that XGL is depreciated at this time. Even for Ati.

In other words, you don't need XGL/AIGLX at all.
Better disable XGL/AIGLX using accel-manager and then edit /etc/X11/xorg.conf:
Code: Select all
Section "Extensions"
   #Option "Composite" "Enable"
EndSection


You can simply enable this by removing the # before the Option "Composite" "Enable" line.

I want to note that using the "nv" driver isn't gonna work, be sure to use the "nvidia" driver.

also you might wanna run the eselect to switch opengl to use nvidia:

Code: Select all
eselect opengl set nvidia


Cheers.
joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest