How to turn off glx from command line

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

How to turn off glx from command line

Postby edi_meister » Mon Dec 24, 2007 4:10

On one older 32-bit machine, aiglx sort of works, but not well, and glx makes an unreadable desktop. GLX was turned on and it always boots with an unreadable login screen. I can ssh to the machine from another box and stop/start xdm.

Using the command line, how do I disable the glx? What config file do I need to edit and what do I need to change? Is there a way to do a "safe mode" boot so I can run the acceleration manager and disable it?

I did try to do ssh -X machine in hopes of running acceleration-manager by remote X, but I don't have that properly configured yet, and it couldn't find a display tunnel.

How do I do this without having to reinstall?

Thanks,

Andrew
edi_meister
Baby Hen
 
Posts: 8
Joined: Sun Dec 16, 2007 5:42

Re: How to turn off glx from command line

Postby Fitzcarraldo » Mon Dec 24, 2007 17:29

From the command line as root, try aiglx-setup disable and xgl-setup disable

See the SL Wiki:

http://wiki.sabayonlinux.org/index.php? ... er_Install

(You may have to emerge desktop-acceleration-helpers first if that package is not already installed.)
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron