Perfect on LiveDVD, Doesn't work installed

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Perfect on LiveDVD, Doesn't work installed

Postby tequemoflia » Wed Oct 10, 2007 2:43

I have the LiveDVD and works extremely perfect all the 3D Desktop Stuff

AIGLX works with no problems, and, games run really fast.

Really good I mean. Even Nexuiz works better than it works on Win***s XP

But, when I install, with KDE or GNOME. Compiz is deactivated, and don't work XGL and AIGLX.
Tried to activate one by one. And nothing. I searched in the forum and try installing all, for example, installing gnome although I use KDE, and more.

My video is NV36 GeForce 5700LE
tequemoflia
Baby Hen
 
Posts: 1
Joined: Wed Oct 10, 2007 2:07

Re: Perfect on LiveDVD, Doesn't work installed

Postby rand.a » Wed Oct 10, 2007 19:27

Did you run accel-manager? If so, paste the error compiz gives.
rand.a
Growing Hen
 
Posts: 163
Joined: Fri Mar 23, 2007 20:08
Location: Shelton, WA

Re: Perfect on LiveDVD, Doesn't work installed

Postby sanjan » Fri Oct 26, 2007 12:13

Hi.. I'm having the same problem.
i am very new to linux.
my vga card is an ATI mobility radeon x1300
i ran the accel-manager. but i dunno how to start XGL.
therez the option to choose XGL and it says OpenGL working.
and when i choose xgl and say configure. it just closes the window.
and i get an error when i type compiz-start on the terminal.
but i can start the compiz icon on the taskbar panel
my linux version is sabayon linux 3.4F
i'm using the GNOME desktop environment
please help
sanjan
Baby Hen
 
Posts: 4
Joined: Fri Oct 26, 2007 12:05

Re: Perfect on LiveDVD, Doesn't work installed

Postby wolfden » Fri Oct 26, 2007 12:57

run accel-manager
select your setting
restart X

should be working
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Perfect on LiveDVD, Doesn't work installed

Postby sanjan » Fri Oct 26, 2007 18:50

sorry it doesnt work that way.
please help. it works fine in live cd environment.
im using root login now.
do i hv to use the other login?
but when i log in from a limited account i can't find accelmanager or linux terminaql
sanjan
Baby Hen
 
Posts: 4
Joined: Fri Oct 26, 2007 12:05

Re: Perfect on LiveDVD, Doesn't work installed

Postby sanjan » Sat Oct 27, 2007 16:34

this is thed error i get. i configured accel manager

localhost ~ # compiz-start
Using KDE decorator
Starting Compiz with: --replace ccp --sm-disable
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 158
Minor opcode: 4
Resource id: 0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
Major opcode: 158
Minor opcode: 4
Resource id: 0x0
compiz (core) - Fatal: No composite extension
sanjan
Baby Hen
 
Posts: 4
Joined: Fri Oct 26, 2007 12:05

Re: Perfect on LiveDVD, Doesn't work installed

Postby sanjan » Sat Oct 27, 2007 17:05

now this is what i get

localhost ~ # LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib compiz --sm-disable --replace ccp
Segmentation fault
localhost ~ # compiz-start
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Using KDE decorator
Starting Compiz with: --replace ccp --sm-disable
/usr/bin/compiz-start: line 58: 9320 Segmentation fault LD_LIBRARY_PATH="/usr/lib/opengl/xorg-x11/lib" compiz $COMPIZ_OPTIONS ini
localhost ~ #

when i start compiz-fusion icon. all these errors comes up and when the window manager is compiz all the title bars in the windows disappear and keyboard is not responsive. i have to change the window manager to kwin to get the title bar back and get key board working

please help.
sanjan
Baby Hen
 
Posts: 4
Joined: Fri Oct 26, 2007 12:05

Re: Perfect on LiveDVD, Doesn't work installed

Postby goodnewz » Thu Jan 03, 2008 0:52

Had the same problem on teh 3.4 mini I use with an old nVidia 4 mx 4000 card, so here's the solution:
1. install sabayon in graphical mode
2. once it finishes and reboots set accel-manager on AIGLX
3. if the drivers get you into trouble install the drivers from the nVidia website yourself.
4. generate an xorg.conf from the nvidia-settings and make sure you have the following 2 option lines to xorg.conf in Section "Device" and you'll get your window title bars.
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
User avatar
goodnewz
Young Hen
 
Posts: 28
Joined: Tue May 01, 2007 22:14

Re: Perfect on LiveDVD, Doesn't work installed

Postby wolfden » Thu Jan 03, 2008 1:16

why not install the drivers from portage like your suppose to - always use the package manager
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Perfect on LiveDVD, Doesn't work installed

Postby goodnewz » Fri Jan 04, 2008 16:05

@ wolfden - its hard to get portage support for legacy drivers like in the case of GeForce 4 mx 4000 card I had, since the new drivers add those 2 option lines xorg.conf, but the old drivers don't ;)
User avatar
goodnewz
Young Hen
 
Posts: 28
Joined: Tue May 01, 2007 22:14

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest