Monitor resolution problem

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Monitor resolution problem

Postby fsandor » Tue Oct 02, 2007 9:20

I just have installed sabayon 3.4 mini. The first thing on my todo list is changing the monitor settings in xorg.conf according to my monitor specs. (it's a Samsung SyncMaster 795DF 17" CRT). DE is KDE. Video card is an ATI Radeon 9550 AGP with 128 MB. Desired resolution is [email protected] It works well until I start XGL and Compiz, which seems to override the res to [email protected] which is unusable on this monitor. And this is the only res inthe screen size options, although xorg.conf allows 1024*768 as max resolution.

Are there any obscure monitor settings in some XGL/Compiz config files, or it just forces the highest possible resolution specs directly from the video card?

Any help is welcome. Thx.
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby rand.a » Tue Oct 02, 2007 11:13

Strange.... can you post your xorg.conf?
rand.a
Growing Hen
 
Posts: 163
Joined: Fri Mar 23, 2007 20:08
Location: Shelton, WA

Re: Monitor resolution problem

Postby fsandor » Tue Oct 02, 2007 19:31

Here is my xorg.conf. If I uncomment the Mode lines in screen section, after launching xgl/compiz resolution is set to 640*480, even if I leave there just the 1024*768. Again: with no desktop acceleration, everything works fine.


Code: Select all
Section "Files"


    #FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/corefonts"

EndSection

# **********************************************************************
# Module section -- this is an optional section which is used to specify
# which run-time loadable modules to load when the X server starts up.
# **********************************************************************

Section "Module"

    Load   "dbe"
    Load   "i2c"
    Load   "glx"
    Load   "ddc"
    Load   "type1"
    Load   "freetype"
    Load   "extmod"
    Load   "synaptics"
    Load   "vbe"
    Load        "dri"

EndSection


# **********************************************************************
# Server flags section.  This contains various server-wide Options.
# **********************************************************************

Section "ServerFlags"

     Option    "AllowMouseOpenFail" "true"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier      "Synaptics1"
    Driver      "synaptics"
    Option      "SendCoreEvents"   "true"
    Option      "Device"      "/dev/psaux"
    Option      "Protocol"      "auto-dev"
    Option      "HorizScrollDelta"   "0"
    Option      "SHMConfig"      "on"
    # For ALPS/MacBook TouchPads
    #Option      "MaxSpeed"      "0.7"
    #Option      "MinSpeed"      "0.18"
    #Option      "AccelFactor"      "0.08"
    #Option      "TopEdge"      "120"
    #Option      "LeftEdge"      "120"
    #Option      "BottomEdge"      "830"
    #Option      "RightEdge"      "650"
    #Option      "FingerLow"      "25"
    #Option      "FingerHigh"      "30"
    # MacBook touchpad
    #Option      "MaxTapTime"      "180"
    #Option      "MaxTapMove"      "220"
    #Option      "MaxDoubleTapTime"   "180"
    #Option      "VertScrollDelta"   "20"
    #Option      "HorizScrollDelta"   "50"
    #Option      "TapButton2"      "3"
    #Option      "TapButton3"      "2"
    #Option      "VertTwoFingerScroll"   "1"

    # Do you keep moving the mouse while typing? Try this trick.
    #synclient TouchpadOff=1 disable your synaptics touchpad
    #synclient TouchpadOff=0 enable your synaptics touchpad
EndSection


Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"
   
    Option   "AutoRepeat"   "500 5"
    Option      "XkbModel"   "pc105"
    Option   "XkbLayout"   "us"
    Option      "XkbRules"      "xorg"
    # Macintosh keyboard
    #Option   "XkbOptions"   "lv3:rwin_switch"

EndSection


Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom1"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom2"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom3"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier   "Mouse1"
    Driver   "mouse"

    Option   "Device"   "/dev/psaux"
    Option   "Protocol"   "ImPS/2"
    Option   "ZAxisMapping"   "4 5"
     
EndSection

Section "InputDevice"
    Identifier   "Mouse2"
    Driver   "mouse"
    Option   "Protocol"   "ImPS/2"
    Option   "Device"   "/dev/input/mice"
    Option    "ZAxisMapping" "4 5"
EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier   "Generic Monitor"
    #Option      "DPMS"

    VertRefresh 50 - 160
    HorizSync   30 - 85
   
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA"
    Driver      "fglrx" # do not remove vesa
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
EndSection


# **********************************************************************
# Screen sections.
# **********************************************************************

Section "Screen"

# The Identifier, Device and Monitor lines must be present

    Identifier   "Screen 1"
    Device   "VESA"
    Monitor   "Generic Monitor"
    #Option "AddARGBGLXVisuals" "true"

# The favoured Depth and/or Bpp may be specified here

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection


EndSection


Section "ServerLayout"
# The Identifier line must be present

    Identifier   "Main Layout"
    Screen 0    "Screen 1"
    InputDevice   "Mouse1" "CorePointer"
    InputDevice   "Mouse2" "SendCoreEvents"
    #InputDevice "Synaptics1" "SendCoreEvents"
    #InputDevice "wacom1" "SendCoreEvents"
    #InputDevice "wacom2" "SendCoreEvents"
    #InputDevice "wacom3" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby fsandor » Thu Oct 04, 2007 10:55

The problem is persisting, so any help is welcome.
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby fsandor » Fri Oct 12, 2007 16:31

up
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby rand.a » Sat Oct 13, 2007 1:41

Your "Modes" lines in xorg.conf are commented out, remove the # infront of those lines.
rand.a
Growing Hen
 
Posts: 163
Joined: Fri Mar 23, 2007 20:08
Location: Shelton, WA

Re: Monitor resolution problem

Postby fsandor » Sat Oct 13, 2007 9:39

Yes, I've tried that too. As I said in the pervious post:

"If I uncomment the Mode lines in screen section, after launching xgl/compiz resolution is set to 640*480, even if I leave there just the 1024*768"
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby Fitzcarraldo » Sat Oct 13, 2007 13:15

Have a look at my post in the following thread, as it might be of some help:

viewtopic.php?f=56&t=10074&p=58987

Here's my xorg.conf (when I'm using my external 1440x900 monitor on my 1680x1050 laptop), which might help you to find something that works for your model of monitor. I got the Modeline data for my model of monitor from the /var/log/ file. (BTW, in case you notice it, I added the line Option "AIGLX" "FALSE" to get rid of an error message in the /var/log/ file as I'm not using AIGLX, but that error message is harmless and has nothing to do with the monitor resolution.)

Code: Select all
# **********************************************************************
# xorg.conf.1440x900.v1
# **********************************************************************
Section "Files"


    #FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/corefonts"

EndSection

# **********************************************************************
# Module section -- this is an optional section which is used to specify
# which run-time loadable modules to load when the X server starts up.
# **********************************************************************

Section "Module"

    Load   "dbe"
    Load   "i2c"
    Load   "glx"
    Load   "ddc"
    Load   "type1"
    Load   "freetype"
    Load   "extmod"
    Load   "synaptics"
    Load   "vbe"
   Load        "dri"

EndSection


# **********************************************************************
# Server flags section.  This contains various server-wide Options.
# **********************************************************************

Section "ServerFlags"

     Option    "AllowMouseOpenFail" "true"
     Option "AIGLX" "FALSE"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier      "Synaptics1"
    Driver      "synaptics"
    Option      "SendCoreEvents"   "true"
    Option      "Device"      "/dev/psaux"
    Option      "Protocol"      "auto-dev"
    Option      "HorizScrollDelta"   "0"
    Option      "SHMConfig"      "on"
    # For ALPS TouchPads
    #Option      "MaxSpeed"      "0.7"
    #Option      "MinSpeed"      "0.18"
    #Option      "AccelFactor"      "0.08"
    #Option      "TopEdge"      "120"
    #Option      "LeftEdge"      "120"
    #Option      "BottomEdge"      "830"
    #Option      "RightEdge"      "650"
    #Option      "FingerLow"      "25"
    #Option      "FingerHigh"      "30"
    # Do you keep moving the mouse while typing? Try this trick.
    #synclient TouchpadOff=1 disable your synaptics touchpad
    #synclient TouchpadOff=0 enable your synaptics touchpad
EndSection


Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"
   
    Option   "AutoRepeat"   "500 5"
    Option      "XkbModel"   "pc105"
    Option   "XkbLayout"   "gb"
    Option      "XkbRules"      "xorg"

EndSection


Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom1"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom2"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom3"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier   "Mouse1"
    Driver   "mouse"

    Option   "Device"   "/dev/psaux"
    Option   "Protocol"   "ImPS/2"
    Option "ZAxisMapping" "4 5"
     
EndSection

Section "InputDevice"
    Identifier   "Mouse2"
    Driver   "mouse"
    Option   "Protocol"   "ImPS/2"
    Option   "Device"   "/dev/input/mice"
    Option    "ZAxisMapping" "4 5"
EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"
    Identifier   "Laptop LCD"
    VendorName "Samsung"
    ModelName "LTN154P1-L02"
    Modeline "1680x1050"  121.00  1680 1704 1792 1876  1050 1051 1054 1065 +Hsync +Vsync
    Modeline "1440x900"  121.00  1440 1704 1792 1876  900 1051 1054 1065 +Hsync +Vsync
    Modeline "1280x1024"  121.00  1280 1704 1792 1876  1024 1051 1054 1065 +Hsync +Vsync
    Modeline "1152x864"  121.00  1152 1704 1792 1876  864 1051 1054 1065 +Hsync +Vsync
    Modeline "1024x768"  121.00  1024 1704 1792 1876  768 1051 1054 1065 +Hsync +Vsync
    Modeline "800x600"  121.00  800 1704 1792 1876  600 1051 1054 1065 +Hsync +Vsync
    Modeline "640x480"  121.00  640 1704 1792 1876  480 1051 1054 1065 +Hsync +Vsync
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "FGLRX"
    Driver      "fglrx"
EndSection

# **********************************************************************
# Screen sections.
# **********************************************************************

Section "Screen"
    Identifier   "Laptop Screen"
    Device   "FGLRX"
    Monitor   "Laptop LCD"
    DefaultDepth 24
    SubSection "Display"
        Viewport 0 0
        Virtual 1440 900
        Depth 24
        Modes "1680×1050" "1440×900" "1280×1024" "1152×864" "1024×768" "800×600" "640×480"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Laptop Screen"
    InputDevice   "Mouse1" "CorePointer"
    InputDevice   "Mouse2" "SendCoreEvents"
    InputDevice "Synaptics1" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Monitor resolution problem

Postby fsandor » Mon Oct 15, 2007 22:40

I just can't figure out what's causing the problem.
Help :cry:
fsandor
Baby Hen
 
Posts: 9
Joined: Tue Oct 02, 2007 9:08

Re: Monitor resolution problem

Postby DontPanic » Tue Oct 16, 2007 15:01

I don't know if this will work, but it is something easy to try.

Try adding the following line to the "Monitor" section of your xorg.conf file:

Code: Select all
Option "Metamodes" "1024x768"


I was having the opposite problem from you. Xorg would not give me any higher than 640x480 when running my nvidia driver. This line was the solution to my problem.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron