Spell checker for German AND English in the same KDE Plasma

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Spell checker for German AND English in the same KDE Plasma

Postby linuxfluesterer » Fri Jun 16, 2017 14:35

Hallo guys.
My Plasma DE is a native German with a spell checker for German language.
But I often write English texts and all words are red lined because they seem wrong spelled in German.
I would like to know, how can I activate a German spell checker (I don't know, which one is installed with KDE / Sabayon at all) and additionally an English spell checker also while keeping my German Desktop.

And, where can I do the settings, pls?

Thank you in advance.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 783
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Spell checker for German AND English in the same KDE Pla

Postby Fitzcarraldo » Sat Jun 17, 2017 11:07

1. System Settings > Regional Settings > Language

Make sure all the languages you want to spell-check are in the 'Preferred Languages' box.

2. System Settings > Regional Settings > Spell Check

Select 'Enable autodetection of language' and 'Automatic spell checking by default' (if you want that).

3. In e.g. KWrite:

Tools > Spelling

Select 'Automatic spell checking' (Ctrl+Shift+O) and 'Change Dictionary...'

There will be a pull-down Dictionary menu at the bottom on the KWrite window and you can select the dictionary language you want to use.

https://docs.kde.org/trunk5/en/kde-work ... index.html

Make sure you have the relevant dictionaries installed. In my case I have app-text/hunspell, app-dicts/myspell-en and app-dicts/myspell-pt-br installed because my preferred languages are English and Brazilian Portuguese.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8077
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Spell checker for German AND English in the same KDE Pla

Postby linuxfluesterer » Sat Jun 17, 2017 23:36

Thank you Fitz.
Honestly, your tips didn't work for me. I have started checked for those three packages:
Code: Select all
equo s app-dicts/myspell-en
equo s app-dicts/myspell-de
equo s app-text/hunspell


and every package is already installed. Then I started KWrite and checked for the settings were already done.
But though 'Auto language detection' (my translation from German) was set, I receive red lines, when I begin to write English words. My aim was, that my entered words belong to English and were not marked.
Also I would like then, when I enter German words in some places, that those words are not complained also.

And: I have a big graphics problem also. Sometimes in KWrite when I see the dictionary at the bottom, and one word is complained, then all lines in that row are written one over another, so that I can neither read anything clearly nor that I can press a button in that row. I assume this is aWayland problem, but I'm not sure. On the other hand I also have these graphic errors, when I enter numbers in LibreOffice Calc fields. One can not read them until pressed <Enter>.

By the way, in LibreOffice Writer with some (many) clicks I can make the spell checker checking for correct English. It seems, 'Auto language detection seems to work, though I forgot to how to set in Writer.

Last not least, my original aim was to write comments and posts in this forum. I use Vivaldi, which is based on Chrome. Here it seems to be much easier. When I right click, I can choose 'in all my languages' or a separate language. It works.
So at this point here I am content.

Again, thank you, Fitz.

-Linuxfluesterer (I love KDE...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 783
Joined: Thu Sep 20, 2012 19:47
Location: Germany


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests