no wireless connection [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

no wireless connection [Solved]

Postby rbrick49 » Sat May 27, 2017 11:01

Hello today I installed a tp link wireless pci adapter it wont work for love nor money,I have searched high and low no luck any ideas or help would be great it tells me its a broadcom 4360 I installed relevant deivers and firmware.it works on my other linux os,s on this box
regards Ron
Last edited by rbrick49 on Sat May 27, 2017 21:42, edited 1 time in total.
dell ultra wide monitor,asrock extreme4 motherboard,Intel® Core™ i7-4770K CPU @ 3.50GHz ,manjaro xfce,sapayon kde
tomorrow never comes
rbrick49
Simple Hen
 
Posts: 82
Joined: Sun Apr 08, 2012 13:46

Re: no wireless connection

Postby rbrick49 » Sat May 27, 2017 11:03

heres my inxi

System: Host: sabayon.local Kernel: 4.8.0-sabayon x86_64 (64 bit)
Desktop: KDE Plasma 5.9.5
Distro: Sabayon Linux amd64 17.04
Machine: Device: desktop Mobo: ASRock model: Z97 Extreme4
UEFI: American Megatrends v: P2.50 date: 07/27/2016
CPU: Quad core Intel Core i7-4770K (-HT-MCP-) cache: 8192 KB
clock speeds: max: 3900 MHz 1: 3868 MHz
2: 2021 MHz 3: 3168 MHz 4: 2791 MHz
5: 2062 MHz 6: 2645 MHz 7: 3728 MHz
8: 2012 MHz
Graphics: Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Display Server: X.org 1.19.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: 56x19
Audio: Card-1 C-Media CMI8788 [Oxygen HD Audio]
driver: snd_virtuoso
Card-2 Logitech Webcam Pro 9000
driver: USB Audio
Sound: ALSA v: k4.8.0-sabayon
Network: Card-1: Intel Ethernet Connection (2) I218-V
driver: e1000e
IF: enp0s25 state: down
mac: d0:50:99:71:21:bc
Card-2: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter
driver: bcma-pci-bridge
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 1980.4GB (1.4% used)
ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB

ID-2: /dev/sdb model: WDC_WD10EZRX size: 1000.2GB

ID-3: /dev/sdc model: Samsung_SSD_850 size: 250.1GB

ID-4: /dev/sdd model: INTEL_SSDSC2BW24 size: 240.1GB

ID-5: /dev/sde model: INTEL_SSDSC2BW24 size: 240.1GB

ID-1: / size: 50G used: 9.8G (21%) fs: ext4 dev: /dev/dm-2
ID-2: /boot size: 477M used: 47M (11%) fs: ext4 dev: /dev/sdd2
ID-3: /home size: 155G used: 361M (1%) fs: ext4 dev: /dev/dm-1
ID-4: swap-1 size: 16.71GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 44.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 268 Uptime: 7 min Memory: 739.6/31865.7MB
Init: systemd
Client: Shell (bash) inxi: 2.3.4
[email protected] ~ $
dell ultra wide monitor,asrock extreme4 motherboard,Intel® Core™ i7-4770K CPU @ 3.50GHz ,manjaro xfce,sapayon kde
tomorrow never comes
rbrick49
Simple Hen
 
Posts: 82
Joined: Sun Apr 08, 2012 13:46

Re: no wireless connection

Postby Fitzcarraldo » Sat May 27, 2017 12:25

The Broacom BCM4360 Wi-Fi adapter uses the Broadcom STA (wl) driver, if I'm not mistaken. You need to edit the file /etc/modprobe.d/blacklist.conf to blacklist the other Broadcom Wi-Fi drivers and whitelist the wl driver. I.e. you need to change:

Code: Select all
## make broadcom-sta happy
## <2012-12-08.
#blacklist ssb
#blacklist bcma
#blacklist brcmsmac
#blacklist b43

# make b43 happy (ditch broadcom-sta)
# 2012-12-08. Testing needed.
blacklist wl

to:

Code: Select all
## make broadcom-sta happy
blacklist ssb
blacklist bcma
blacklist brcmsmac
blacklist b43

#blacklist wl

After you reboot, use the lsmod command as root user to check which modules are loaded.

N.B. If your installation does not already have the Broadcom STA module installed, you need to install it first:

Code: Select all
equo install broadcom-sta

If the STA (wl) module is not loaded automatically after you have made sure the driver is installed, edited /etc/modprobe.d/blacklist.conf and rebooted (and checked the output of the lsmod command), you may also need to create the file /etc/modules-load.d/wl.conf containing the following:

Code: Select all
wl
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8085
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: no wireless connection

Postby rbrick49 » Sat May 27, 2017 21:41

all good thanks fitz
dell ultra wide monitor,asrock extreme4 motherboard,Intel® Core™ i7-4770K CPU @ 3.50GHz ,manjaro xfce,sapayon kde
tomorrow never comes
rbrick49
Simple Hen
 
Posts: 82
Joined: Sun Apr 08, 2012 13:46


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 4 guests

cron