No wlan0 on older installation

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Young Hen
Posts: 39
Joined: Thu Feb 16, 2012 2:42

Re: No wlan0 on older installation

Post by pottzie » Fri Jul 14, 2017 6:37

My laptop was never connected to the Belkin, it's worked since I first installed Sabayon without having to do anything to it, using whatever it's internal wireless is. The PC is another matter. I thought I'd added the rt2500usb and rt73usb to /etc/modprobe.d/blacklist.conf, but I just checked, and edited them in. after editing, I tried ifconfig and still no wireless shown, just lo and ethernet.

Code: Select all

larry-pc larry # cat /etc/modprobe.d/blacklist.conf
# This file lists modules which will not be loaded by udev,
# not at coldplugging and not on hotplug events.

# Add your own entries to this file
# in the format "blacklist <name of module>"

# Some examples:
# evbug is a debug tool and should be loaded explicitly
blacklist evbug

# Autoloading eth1394 most of the time re-orders your network
# interfaces, and with buggy kernel 2.6.21, udev persistent-net
# is not able to rename these devices, so you get eth?_rename devices
# plus an exceeded 30sec boot timeout
blacklist eth1394

# You probably want this to not get the console beep loud on every tab :)
#blacklist pcspkr

# these drivers are very simple, the HID drivers are usually preferred
#blacklist usbmouse
#blacklist usbkbd

# Sometimes loading a framebuffer driver at boot gets the console black
#install pci:v*d*sv*sd*bc03sc*i* /bin/true

# hplip and cups 1.4+ use raw USB devices, so it requires usblp not be loaded
blacklist usblp

## make broadcom-sta happy
## <2012-12-08.
#blacklist ssb
#blacklist bcma
#blacklist brcmsmac
#blacklist b43

# make b43 happy (ditch broadcom-sta)
# 2012-12-08. Testing needed.
blacklist wl

# keep nvidia-drivers working, sorry nouveau
blacklist nouveau

# Known to cause kernel OOPS at boot
blacklist ite_cir

# Prevents kernel message: Driver 'pcspkr' is already registered, aborting...
blacklist snd-pcsp
blacklist rt2500usb
blacklist rt73usb
larry-pc larry # 

Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: No wlan0 on older installation

Post by Fitzcarraldo » Sat Jul 15, 2017 1:00

Well, the Linux Kernel configuration CONFIG_P54_USB is definitely for your USB Wi-Fi adapter:
vendor: 050d ("Belkin Components"), product: 7050 ("F5D7050 Wireless G Adapter v1000/v2000 [Intersil ISL3887]")
So either the firmware file is out of date, or, unlikely, some of the other drivers that have been built into the Sabayon Linux kernel image are somehow conflicting with the p54usb driver module:

Code: Select all

sabayon fitzcarraldo # uname -r
sabayon fitzcarraldo # grep -i prism /usr/src/linux/.config
sabayon fitzcarraldo # grep -i p54 /usr/src/linux/.config
sabayon fitzcarraldo #
The two kernel configurations you need in the Sabayon Linux kernel (CONFIG_P54_USB=m and CONFIG_P54_COMMON=m) are indeed resulting in the required drivers; the output of the lsmod command that you posted earlier showed the only two Intersil modules loaded were p54usb and p54common, which is correct. And, now that you have blacklisted all the Ralink modules, that is also correct. Your lsmod output didn't show the modules p54pci and p54spi, so they are not loaded (which is a good thing, as I surmise those two drivers might have conflicted with the p54usb driver). Furthermore, as the p54spi module is not loaded, I doubt its fallback EEPROM blob (built because CONFIG_P54_SPI_DEFAULT_EEPROM=y) has any effect at all. So, in summary, I reckon you will not be able to get this particular USB Wi-Fi adapter working with Sabayon Linux. I have just found your 2011 thread in the Gentoo Linux Forums regarding the same Belkin Wi-Fi adapter, in which you were equally unsuccessful in getting it working in Gentoo Linux despite the help of knowledgable Gentoo Linux user DONAHUE, although you were successful with a different variant of the Belkin F5D7050 Wi-Fi adapter that uses the Ralink RT2573 chipset instead of the Intersil ISL3887 chipset (ID 050d:705a Belkin Components F5D7050 Wireless G Adapter v3000 [Ralink RT2573]).

So, there you have it. My advice would be that you try a different Wi-Fi adapter and not waste any more time with the Belkin Wi-Fi adapter that uses the Intersil chipset (ID 050d:7050 Belkin Components F5D7050 Wireless G Adapter v1000/v2000 [Intersil ISL3887]).

Post Reply