Page 1 of 1

Problem with atheros

Posted: Sat Feb 18, 2017 19:32
by markorians
Hi,
I can't use wpa_supplicant it tell me that I use a wrong key.
But if I boot in safe mode wpa_supplicant works.
Any ideas ???

Please help

Re: Problem with atheros

Posted: Sun Feb 19, 2017 17:43
by markorians
I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot

Re: Problem with atheros

Posted: Sun Feb 19, 2017 19:18
by sabayonino
markorians wrote:I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot
is networkmanager service enabled ?

Code: Select all

# systemctl enable NetworkManager

Re: Problem with atheros

Posted: Thu Feb 23, 2017 19:28
by markorians
sabayonino wrote:
markorians wrote:I solved in this way:
( I use sabayon minimal )
- fresh install of system
- equo update && equo upgrade
- reboot
- equo i networkmanager
- reboot
is networkmanager service enabled ?

Code: Select all

# systemctl enable NetworkManager
Yep !
I never use network manager as my default options.
4 days ago I have discovered this service and I disable them
because it busy wext and nl80211 driver and cause me trouble.
After disabled I configure my wpa_supplicant.conf
and i enable this service

Code: Select all

# systemctl enable [email protected]
This start a wpa association at boot and if I want
I connect with dhcpcd (dhclinet has seg fault).

This is strange for me because dhcpcd not have the hook to auto
call wpa supplicant. In archlinux i enable only [email protected]
service, little different but not a problem :D