No network after today's upgrade!

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: No network after today's upgrade!

Postby Cb7 » Sun Mar 09, 2014 13:33

Could someone with problem see if it would work? It works for me, so…
https://bugs.sabayon.org/show_bug.cgi?id=4621#c2
Why, and how to add "[Solved]" to your post. Please read. ← credits to Fitzcarraldo

Kind regards
~Zetok Zalbavar
Cb7
Growing Hen
 
Posts: 104
Joined: Sun Apr 07, 2013 7:13

Re: No network after today's upgrade!

Postby tollgate » Mon Mar 10, 2014 9:05

I had the same problem today after I rebooted follwing the latest updates. Also, my external USB drives would not mount.

So I guessed it was probably something to do with openRC and the need to convert to systemd. I had been putting it off for sometime now, so today in a terminal as root:

eselect init set systemd

and then

systemctl enable kdm.service

Rebooted, and to my surprise (I expected problems), networking was working again and USB drives mounted.
tollgate
Growing Hen
 
Posts: 105
Joined: Thu May 31, 2012 3:57
Location: Jomtien, Thailand

Re: No network after today's upgrade!

Postby linuxfluesterer » Mon Mar 10, 2014 10:47

... perfect.
Anyway, since long time in Rigo it was announced, the (Gnome) users, and for me it means, all users, are recommended to change to systemd. It was clearly said, that OpenRC will no more be supported.
So, why waiting so long time with switching to Systemd then? I mean, this was a decision by the Sabayon developers (as there is Fabio...).

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 695
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: No network after today's upgrade!

Postby imaginasys » Mon Mar 10, 2014 16:28

Same for me here : no network after last update.
I had to start manually the network from a shell (ifconfig eth0 ; dhcpcd eth0).

(I'm on an AMD cpu, Kernel 3.13.5 I can give more info tonight when I'll be at home).

I'm also unable to connect in KDE anymore, I think there is a problem with kwin (but I will open another thread for that).
I can log to fluxbox though.

May be it's related so I'm bringing it here too.

Just my 0,02$,
regards,
Bernard :mrgreen:

PS: Same for my other machine at work that is on sabayon too... Something smell bad!
And I was already on systemd on both machines.
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: No network after today's upgrade!

Postby linuxfluesterer » Mon Mar 10, 2014 18:21

Could you just try to boot with a Sabayon Live system to check for network connection, pls?

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 695
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: No network after today's upgrade!

Postby imaginasys » Mon Mar 10, 2014 21:31

network works if you set it up by hand. It will work too for live CD 14.02 since I installed from it and it used to work before that update...

Something is wrong with NetworkManager. The service NetworkManager is not anymore working.

I have extracted the following messages from systemd log :

Code: Select all
mar 10 05:50:09 p179675x NetworkManager[3176]: <info> NetworkManager (version 0.9.8.8) is starting...
mar 10 05:50:09 p179675x NetworkManager[3176]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
mar 10 05:50:09 p179675x NetworkManager[3176]: <info> WEXT support is enabled
mar 10 05:50:09 p179675x avahi-daemon[3178]: Found user 'avahi' (UID 108) and group 'avahi' (GID 444).
mar 10 05:50:09 p179675x avahi-daemon[3178]: Successfully dropped root privileges.
mar 10 05:50:09 p179675x avahi-daemon[3178]: avahi-daemon 0.6.31 starting up.
mar 10 05:50:09 p179675x systemd[1]: Started Avahi mDNS/DNS-SD Stack


mar 10 05:50:09 p179675x avahi-daemon[3228]: chroot.c: open() failed: No such file or directory
mar 10 05:50:09 p179675x avahi-daemon[3178]: Failed to open /etc/resolv.conf: Invalid argument
mar 10 05:50:09 p179675x avahi-daemon[3178]: Loading service file /services/sftp-ssh.service.
...

mar 10 05:50:09 p179675x avahi-daemon[3178]: Loading service file /services/ssh.service.
mar 10 05:50:10 p179675x NetworkManager[3176]: <info> VPN: loaded org.freedesktop.NetworkManager.vpnc
mar 10 05:50:10 p179675x NetworkManager[3176]: <info> VPN: loaded org.freedesktop.NetworkManager.openvpn
mar 10 05:50:10 p179675x NetworkManager[3176]: <info> VPN: loaded org.freedesktop.NetworkManager.pptp
mar 10 05:50:10 p179675x dbus[3180]: [system] Activating via systemd: service name='org.freedesktop.PolicyKit1' unit='polkit.service'
mar 10 05:50:10 p179675x avahi-daemon[3178]: Network interface enumeration completed.
mar 10 05:50:10 p179675x avahi-daemon[3178]: Registering HINFO record with values 'X86_64'/'LINUX'.
mar 10 05:50:10 p179675x avahi-daemon[3178]: Server startup complete. Host name is p179675x.local. Local service cookie is 2497543888.
mar 10 05:50:10 p179675x avahi-daemon[3178]: Service "p179675x" (/services/ssh.service) successfully established.
mar 10 05:50:10 p179675x avahi-daemon[3178]: Service "p179675x" (/services/sftp-ssh.service) successfully established.


mar 10 05:50:18 p179675x NetworkManager[3176]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
mar 10 05:50:18 p179675x NetworkManager[3176]: <error> [1394445018.844385] [main.c:547] main(): failed to initialize settings storage: Could not load plugin 'ifnet': /usr/lib64/N
mar 10 05:50:18 p179675x NetworkManager[3176]: <info> exiting (error)
mar 10 05:50:18 p179675x systemd[1]: NetworkManager.service: main process exited, code=exited, status=1/FAILURE
mar 10 05:50:18 p179675x systemd[1]: Failed to start Network Manager.
-- Subject: Unit NetworkManager.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
--
-- Unit NetworkManager.service has failed.
--
-- The result is failed.
mar 10 05:50:18 p179675x systemd[1]: Unit NetworkManager.service entered failed state.
mar 10 05:50:18 p179675x systemd[1]: Starting Network.

-- The start-up result is done.
mar 10 05:50:18 p179675x NetworkManager[3176]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
mar 10 05:50:18 p179675x NetworkManager[3176]: <error> [1394445018.844385] [main.c:547] main(): failed to initialize settings storage: Could not load plugin 'ifnet': /usr/lib64/NetworkManager/libnm-settings-plugin-ifnet.so: Unable to open share object :  no file or directory of that type
mar 10 05:50:18 p179675x NetworkManager[3176]: <info> exiting (error)
mar 10 05:50:18 p179675x systemd[1]: NetworkManager.service: main process exited, code=exited, status=1/FAILURE
mar 10 05:50:18 p179675x systemd[1]: Failed to start Network Manager.
-- Subject: Unit NetworkManager.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
--
-- Unit NetworkManager.service has failed.
--
-- The result is failed.
mar 10 05:50:18 p179675x systemd[1]: Unit NetworkManager.service entered failed state.
mar 10 05:50:18 p179675x systemd[1]: Starting Network.


There have been other error messages before :

    from systemd: Failed at set EXEC spawning /usr/bin/mkdir: No such file or directory
    from systemd : kmod-static-nodes.service : control process exited, code=exited, status=203 failed to create list of device nodes for the current kernel
    from systemd-udevd : inotify add watch(7,/dev/dm-4, 10) failed: No such file or directory

May be the root of the problem is with creation of device nodes that failed before ???

Regards,

Bernard :mrgreen:
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: No network after today's upgrade!

Postby Stupot » Mon Mar 10, 2014 21:53

Has anybody tried what was suggested above?

A “fix” to it working for me:
# sed -i 's/ifnet,//g' /etc/NetworkManager/NetworkManager.conf

From:
https://bugs.sabayon.org/show_bug.cgi?id=4621

That should be the fix because:
if use systemd; then
if [[ ${REPLACING_VERSIONS} < 0.9.8.6 ]]; then
ewarn "Ifnet plugin won't be used with systemd support enabled"
ewarn "as it is meant to be used with openRC and can cause collisions"
ewarn "(like bug #485658)."
ewarn "Because of this, you will likely need to reconfigure some of"
ewarn "your networks."
fi

if [[ -e "${EROOT}etc/NetworkManager/NetworkManager.conf" ]]; then
if grep -q plugins "${EROOT}etc/NetworkManager/NetworkManager.conf" | grep -q ifnet; then
ewarn "You seem to use 'ifnet' plugin in ${EROOT}etc/NetworkManager/NetworkManager.conf"
ewarn "Since it won't be used when running under Systemd, you will need to stop setting"
ewarn "ifnet plugin there to allow NetworkManager to work."
fi
fi
fi


http://sources.gentoo.org/cgi-bin/viewv ... iew=markup
Stupot
Sagely Hen
 
Posts: 1509
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: No network after today's upgrade!

Postby imaginasys » Tue Mar 11, 2014 3:52

Yes https://bugs.sabayon.org/show_bug.cgi?id=4621 helped solve the problem,

But the 'sed' expression is not correct, the coma is missing in /ifnet,/. All I did is remove the [ifnet] section in NetworkManager.conf. I had to recreate my connection for eth0, it wasn't there anymore in the NetworkManager config.

Problem solved here and I got back my KDE too (!!!???).

I hope this patch will get added into current version of NetworkManager, I don't want to do it again next update!

Just joking! I know that many peoples are working hard to keep Sabayon fast and bug free. Sh.. happens!

Keep on the good work and thanks to all who participated to solve this issue very quickly.

Regards,
Bernard :mrgreen:
imaginasys
Simple Hen
 
Posts: 51
Joined: Sat Nov 23, 2013 6:59

Re: No network after today's upgrade!

Postby artbody » Sun Mar 30, 2014 8:27

Hy
I run into the same trouble (update yesterday)
NetworkManager didn't start
so the first thing was as described above
Code: Select all
sed -i 's/ifnet,//g' /etc/NetworkManager/NetworkManager.conf

and after this i reconfigured the network

BUT !!! kmod-static-nodes.service didn't start
Code: Select all
from systemd: Failed at set EXEC spawning /usr/bin/mkdir: No such file or directory
from systemd : kmod-static-nodes.service : control process exited, code=exited, status=203 failed to create list


SO WHY /usr/bin/mkdir: No such file or directory
/bin/mkdir will work as it should
but there is NO /usr/bin/mkdir :oops:
as work around i created a link from /bin/mkdir to /usr/bin
:bom:

who (tf) has manipulated this script ?
Thx
Achim
Gentoo and Sabayon on different machines
artbody
Baby Hen
 
Posts: 5
Joined: Sun Mar 30, 2014 8:12
Location: Germany

Re: No network after today's upgrade!

Postby artbody » Sun Mar 30, 2014 9:34

Next step

who (tf) has manipulated this script ?
Code: Select all
nano /usr/lib64/systemd/system/kmod-static-nodes.service

Code: Select all
[Service]
Type=oneshot
RemainAfterExit=yes
ExecStartPre=/usr/bin/mkdir -p /run/tmpfiles.d

:oops:
ExecStartPre=/usr/bin/mkdir
changed to
Code: Select all
ExecStartPre=/bin/mkdir -p /run/tmpfiles.d


reboot and :D

Code: Select all
 systemctl status kmod-static-nodes.service
kmod-static-nodes.service - Create list of required static device nodes for the current kernel
   Loaded: loaded (/usr/lib64/systemd/system/kmod-static-nodes.service; static)
   Active: active (exited) since So 2014-03-30 10:23:01 CEST; 2min 0s ago
  Process: 2197 ExecStart=/bin/kmod static-nodes --format=tmpfiles --output=/run/tmpfiles.d/kmod.conf (code=exited, status=0/SUCCESS)
  Process: 2183 ExecStartPre=/bin/mkdir -p /run/tmpfiles.d (code=exited, status=0/SUCCESS)
 Main PID: 2197 (code=exited, status=0/SUCCESS)

Mär 30 10:23:01 tine.local systemd[1]: Started Create list of required stat....
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
Hint: Some lines were ellipsized, use -l to show in full.



now this works again, as expected :mrgreen:
Thx
Achim
Gentoo and Sabayon on different machines
artbody
Baby Hen
 
Posts: 5
Joined: Sun Mar 30, 2014 8:12
Location: Germany

PreviousNext

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest