Network broken after suspend

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Network broken after suspend

Postby udiljak » Tue Feb 25, 2014 17:45

Hi everybody.

Since my last "equo upgrade" I'm having trouble with my network (wired) after suspend / hibernate. In Gnome UI the network looks like it properly connected, but it doesn't do nothing. DNS resolution hangs and also pinging an IP hangs without any time out. Even when trying to ping my router.

Any one any idea? Or having the same problem?

Thanks for any hints!
Ben
udiljak
Young Hen
 
Posts: 35
Joined: Sat Nov 27, 2010 17:18

Re: Network broken after suspend

Postby svantoviit » Sun Mar 02, 2014 12:02

Manually restart NetworkManager using /etc/init.d/… or systemctl restart depending on your init system.
Not a real fix but you should get the connection back.
svantoviit
Old Dear Hen
 
Posts: 649
Joined: Sun Feb 28, 2010 17:55

Re: Network broken after suspend

Postby udiljak » Sun Mar 02, 2014 20:19

Hei.

Thanks for your reply. Restarting NetworkManager doesn't help. Anyway it helps restarting the network device.

sudo ifconfig eth0 down
sudo ifconfig eth0 up

I guess the problem lies somewhere deeper. Maybe connected with the VPN.

Thank for any more hints!
Ben
udiljak
Young Hen
 
Posts: 35
Joined: Sat Nov 27, 2010 17:18

Re: Network broken after suspend

Postby DeadlyWolf » Mon Mar 03, 2014 6:39

udiljak wrote:Hi everybody.

Since my last "equo upgrade" I'm having trouble with my network (wired) after suspend / hibernate. In Gnome UI the network looks like it properly connected, but it doesn't do nothing. DNS resolution hangs and also pinging an IP hangs without any time out. Even when trying to ping my router.

Any one any idea? Or having the same problem?

Thanks for any hints!
Ben


I updated today and am having the same issue but with wireless and KDE, after resume from sleep the Network Manager tries to connect to my networks, 2.4 or 5.0 but can not connect as normal. I have not tried wired yet.
Linux User #521458.
DeadlyWolf
Young Hen
 
Posts: 34
Joined: Sat Aug 28, 2010 5:49
Location: Queensland Australia


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 2 guests

cron