Network manager not working suddenly

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Network manager not working suddenly

Postby qantum251 » Wed Jun 19, 2013 8:05

Dear Sabayon users,

I'm starting this new thread since no solution has been found regarding a strange and sudden behavior of network manager, usually I plug the usb modem and connect by a single click using the network manager yesterday started it and network manager gave this error when clicking on its icon in the upper right side then on the only option available "Connection Settings":

Code: Select all
The system network services are not compatible with this version.



I noticed that the when I click on the network manager icon the connections list drops down and shows one single choice "Network Settings" as if no interface exists. then the Network Settings left panel shows only the "Network proxy" and nothing else.

here what I tried in a random catastrophic manner:

1/
Code: Select all
/etc/init.d/NetworkManager restart
or stop then start

it gives
Code: Select all
Starting NetworkManager ...[ ok ]
Connecting...............    1s
 * Marking NetworkManager as inactive. It will automatically be marked
 * as started after a network connection has been established.
 * WARNING: NetworkManager has started, but is inactive


2/
modified the /etc/rc.conf file: by setting net.* services to start

Code: Select all
rc_hotplug="net.*"


3/
since no internet conection there is available for me on this machine, I manually emerged newer version of the network manager package by copying distfiles using ebuild package merge command but none of these worked

the initial network manager version that gave the error was : networkmanager-0.9.4.0-r7 now I'm on networkmanager-0.9.6.4-r1

please consider helping me out, I'm using sabayon for scientific calculations for almost two years running it on six machines and never faced such a problem.

Thanks a lot.

info: I'm posting this thread using that very same usb modem on a second machine running sabayon gnome 10 x64 kernel 3.5 and networkmanager-0.9.4.0-r7 ?


System info:


hp laptop envy dv6 core i7
gnome sabayon 10 x64 running kernel 3.7.10
qantum251
Baby Hen
 
Posts: 5
Joined: Wed Jun 19, 2013 7:20

Re: Network manager not working suddenly

Postby qantum251 » Wed Jun 19, 2013 8:38

here is an update,

here I booted the machine using Gnome Sabayon 10 x64 DVD in live mode and plugged the modem, I am able to access the network manager and connect with the wireless usb modem which I'm using now to post this message, next step, any suggestions?
thanks
qantum251
Baby Hen
 
Posts: 5
Joined: Wed Jun 19, 2013 7:20

Re: Network manager not working suddenly

Postby Ccaccia73 » Thu Jun 20, 2013 10:29

Hi,
I've got the same issue after upgrading sabayon kde yesterday. Afret reboot no network is working.
I use wireless and I know that is up (it's working on the machine I'm using now), also plugging in an ethernet cable seems not working.

Anyone has suggestions?

Thanks
Ccaccia73
Baby Hen
 
Posts: 4
Joined: Sun Mar 17, 2013 17:06

Re: Network manager not working suddenly

Postby qantum251 » Fri Jun 21, 2013 6:58

Dear readers,

the problem has been randomly solved, I started sabayon in recovery mode then provided the root password, having already an ethernet cable plugged in, on the command line I run
Code: Select all
#ifconfig eth0 up
#dhcpcd eth0


then ping http://www.google.com to check it out...it worked then hit CTRL-D to resume the start up

network manager now operates with no errors, the 3g usb modem worked fine once plugged in, got detected.

BUT the sad thing is about the wireless card (Intel Corporation Centrino Wireless-N 2230) on the HP dv6 envy model.... there is no way to switch it on and off under sabayon, since hp :evil: teamed up with microsoft :evil: and provided acces to the wireless enabling button only under the ugly useless win 8 :cyclops: - hope that the next kernel will support the wireless enabling feature.

thanks
qantum251
Baby Hen
 
Posts: 5
Joined: Wed Jun 19, 2013 7:20

Re: Network manager not working suddenly

Postby lxnay » Sat Jun 22, 2013 7:09

Code: Select all
rc-update del logind boot

Just guessing, since you did not post any proper system logs.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Network manager not working suddenly

Postby qantum251 » Sat Aug 03, 2013 0:48

Dear Sabayon forum;

sorry for being away for that long...recently on this very same issue which makes the wireless adapter behave randomly,I just noticed that a very simple action enables the switch on button to activate the wireless card systematically it has nothing special but it just WORK! every single time:

please notice that I have rfkill installed and it fails to switch on hp-bluetooth and hp-wireless locking down wireless connectivity:
1/ ON BATTERY when sabyon is running with wireless card is off just hit the wireless button on "ONE SINGLE TIME"
2/close the laptop! and wait few seconds for it to enter the sleep state
3/now open it up, normally your laptop is up and wireless has been brought to life and the switch button now works, and by the way rfkill has all wireless devices unlocked.

you just have to perform the above steps when the wireless is lost (usually when you power off the machine having the wifi off) if you power it off having the wifi up it just conserves its activated state next reboot and you don't have to redo the trick.

this it not a good work around but it does work systematically, it saved me from reinstalling all the computing software which are already running smoothly on Sabayon 11 x64, :)

please feedback on if this odd trick does really work for you.

best regards
qantum251
Baby Hen
 
Posts: 5
Joined: Wed Jun 19, 2013 7:20


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest