SL 13.04 MATE 1.6: BT problem

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

SL 13.04 MATE 1.6: BT problem

Postby harmon » Fri May 24, 2013 16:44

Hi!
I'm just testing SL 13.04 64 bit MATE 1.6.0 DVD.
There are several problems - for me the most important is BT.
1. I have to start with
Code: Select all
/etc/init.d/bluetooth restart

Why? In many other distribtutions it is not necessary.
2. I can connect to my BT mouse and my smartphone, mouse works, but the smartphone:
I wanted to attach a screenshot, but:
quota has been reached
??
So: On BT preferences my smartphone is displayed, but I can't send or receive files:

Cannot start " Personal File sharing" Preferences
Please verify that the ... program is correctly installed.


Edit:
part of "dmesg":
Code: Select all
[  245.345201] Bluetooth: Core ver 2.16
[  245.345253] NET: Registered protocol family 31
[  245.345260] Bluetooth: HCI device and connection manager initialized
[  245.345278] Bluetooth: HCI socket layer initialized
[  245.345287] Bluetooth: L2CAP socket layer initialized
[  245.345306] Bluetooth: SCO socket layer initialized
[  245.552130] usbcore: registered new interface driver btusb
[  314.097315] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  314.097318] Bluetooth: BNEP filters: protocol multicast
[  314.097328] Bluetooth: BNEP socket layer initialized
[  314.275392] Bluetooth: RFCOMM TTY layer initialized
[  314.275402] Bluetooth: RFCOMM socket layer initialized
[  314.275404] Bluetooth: RFCOMM ver 1.11
[  421.367448] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[  421.367458] Bluetooth: HIDP socket layer initialized
[  421.433578] hid-generic 0005:046D:B008.0003: unknown main item tag 0x0
[  421.433755] input: Bluetooth Laser Travel Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/bluetooth/hci0/hci0:37/input15
[  421.434040] hid-generic 0005:046D:B008.0003: input,hidraw1: BLUETOOTH HID v3.14 Mouse [Bluetooth Laser Travel Mouse] on 88:53:2e:b6:17:81
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Re: SL 13.04 MATE 1.6: BT problem

Postby harmon » Fri May 24, 2013 19:08

Hi!
Edit2:

Code: Select all
[email protected] ~ $ equo query installed blue
>> Repository sabayon-weekly hasn't been downloaded yet.
>> Repository sabayon-weekly is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!
>>  @@ Searching...
>>      @@ Package: net-wireless/bluez-4.101-r5 branch: 5, [__system__]
>>         Installed:     version: 4.101-r5 ~ tag: NoTag ~ revision: 1
>>         Slot:          0
>>         Homepage:      http://www.bluez.org/
>>         Description:   Bluetooth Tools and System Daemons
>>                        for Linux
>>         License:       GPL-2 LGPL-2.1
>>      @@ Package: net-wireless/mate-bluetooth-1.6.0 branch: 5, [__system__]
>>         Installed:     version: 1.6.0 ~ tag: NoTag ~ revision: 0
>>         Slot:          0
>>         Homepage:      http://mate-desktop.org/
>>         Description:   Fork of bluez-gnome focused on
>>                        integration with MATE
>>         License:       GPL-2 LGPL-2.1
>>  Keywords:  blue
>>  Found:     2 entries


Code: Select all
[email protected] ~ $ lsmod | grep btusb
btusb                  12216  0
bluetooth             236518  29 bnep,hidp,btusb,rfcomm


Code: Select all
[email protected] ~ $ /etc/init.d/bluetooth status
/sbin/livecd-functions.sh: line 39: /proc/sys/kernel/printk: Permission denied
 * status: started


Code: Select all
localhost sabayonuser # hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
   BD Address: 88:53:2E:B6:17:81  ACL MTU: 310:10  SCO MTU: 64:8
   UP RUNNING PSCAN ISCAN
   RX bytes:8807 acl:166 sco:0 events:196 errors:0
   TX bytes:2826 acl:39 sco:0 commands:87 errors:0
   Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x59 0x87
   Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
   Link policy: RSWITCH HOLD SNIFF PARK
   Link mode: SLAVE ACCEPT
   Name: 'localhost-0'
   Class: 0x4a0100
   Service Classes: Networking, Capturing, Telephony
   Device Class: Computer, Uncategorized
   HCI Version: 3.0 (0x5)  Revision: 0x1b07
   LMP Version: 3.0 (0x5)  Subversion: 0xfc00
   Manufacturer: Intel Corp. (2)
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Re: SL 13.04 MATE 1.6: BT problem

Postby belcocco » Sat May 25, 2013 9:39

Can clarify if you talk about a test done from a live DVD or a HD installation or even on a virtualization?
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: SL 13.04 MATE 1.6: BT problem

Postby harmon » Sat May 25, 2013 12:52

Hi!
I'm just testing SL 13.04 64 bit MATE 1.6.0 DVD.

Live DVD!
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Re: SL 13.04 MATE 1.6: BT problem

Postby belcocco » Sat May 25, 2013 14:54

Ok!
Install and then if there are any problems we will solve them one at a time with questions about this forum.
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: SL 13.04 MATE 1.6: BT problem

Postby harmon » Sat May 25, 2013 16:29

Hi!
No - BT is important for me and my family; I had too much unsolved problems with BT in several distributions
[except KDE editions, but I don't like KDE].
What should be different after installation?
How is it that in half a dozen distributions BT works out of the box (e.g. Fuduntu or Kubuntu)?
We can connect via BT phones (smartphones and old phones) within seconds - why not Linux <-> Smartphone?
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Re: SL 13.04 MATE 1.6: BT problem

Postby belcocco » Sat May 25, 2013 16:49

harmon wrote:Hi!
What should be different after installation?

All ! :D 8)
If you install you can edit the configuration file and correct any failure of the live DVD..
A live DVD helps you understand a distro, but it is not the distro.
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: SL 13.04 MATE 1.6: BT problem

Postby harmon » Mon May 27, 2013 16:02

Hi!
I tried to install SL onto USB3 - failed.
From DVD:
Questions:
1. Why "restart"?
2. "browse files on smartphone" - no device.
3. Sending from Smartphone - no success.
4. When I try to send a picture from notebook to smartphone (which is recognized):
Sending files via BT: From To "hexcode"
... connecting...
! Unable to find service record

It must be possible to give an advice, even if SL is not installed.
Problem: Kernel? Packages? Module? Another BT manager?
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Re: SL 13.04 MATE 1.6: BT problem

Postby belcocco » Mon May 27, 2013 17:29

The problem could be anywhere. The BT on my system works for years and I've never had any problems. 8)
Question:
If you connect the smartphone with the usb cable, the system sees it and can work on it?
Ciao
belcocco
Old Dear Hen
 
Posts: 452
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: SL 13.04 MATE 1.6: BT problem

Postby harmon » Tue May 28, 2013 12:40

Hi!
After having installed SL on USB:
As I was guessing: same results.
First question: It must be possible to avoid "restart" with Terminal. I suppose you can edit a file - which one and what to add?
harmon @ Linux multiboot
harmon
Growing Hen
 
Posts: 165
Joined: Sat Jun 19, 2010 16:35

Next

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron