Starting sshd & enabling ssh? [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Starting sshd & enabling ssh? [Solved]

Postby kwacorn » Thu May 09, 2013 13:08

I now have two computers on my home network, sysA and sysB, both with Sabayon KDE installed and fully up to date with sabayon-weekly.

sysA is a laptop, originally with Sabayon 10 installed sometime last year (2012).
sysB is a desktop onto which I have just done a fresh install of Sabayon 13.04.

I am trying to understand what I need to do to enable communication from one system to the other using ssh. Reading the forums and other searches have not helped me so far.

The ssh_config and sshd_config files are identical on each system, I have made no changes to them, I assume their default values are sufficient for basic ssh communication, but their behavior when trying to start sshd is different.

Trying to start sshd on sysA and view its status appears to be ok:
Code: Select all
sysA ~ # /etc/init.d/sshd start
 * Starting sshd ...

sysA ~ # /etc/init.d/sshd status
 * status: started

Whilst on sysB the same results in:
Code: Select all
sysB ~ # /etc/init.d/sshd start
 * WARNING: sshd is already starting

sysB ~ # /etc/init.d/sshd status
 * You are attempting to run an openrc service on a
 * system which openrc did not boot.
 * You may be inside a chroot or you may have used
 * another initialization system to boot this system.
 * In this situation, you will get unpredictable results!
 * If you really want to do this, issue the following command:
 * touch /run/openrc/softlevel

Issuing the ssh command on either system results in the following warning message regardless of whether their firewalls are disabled or have rules to allow ssh:
Code: Select all
sysB ~ # ssh sysA.local
ssh: Could not resolve hostname sysA.local: Name or service not known

Could you please advise how I should proceed to get the ssh services working?
Last edited by kwacorn on Thu May 16, 2013 17:55, edited 1 time in total.
kwacorn
Young Hen
 
Posts: 37
Joined: Sat Jan 21, 2012 11:50

Re: Starting sshd & enabling ssh?

Postby manifesto » Sat May 11, 2013 20:45

look at the error message, it is not ssh pb but host resolution.
I have the same message using a dummy name :
$ ssh nothostname
ssh: Could not resolve hostname nothostname: Name or service not known

Use IP instead name as you have not host name resolution for this.
manifesto
Growing Hen
 
Posts: 168
Joined: Mon Jul 19, 2010 22:21

Re: Starting sshd & enabling ssh?

Postby lxnay » Sat May 11, 2013 21:37

On sysB you're using systemd!!
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Starting sshd & enabling ssh?

Postby kwacorn » Sun May 12, 2013 20:19

Ah, thanks for the hint, that has led me to discovering I need to learn about using systemctl for systemd systems and realising why the warning messages with my erroneous command /etc/init.d/sshd. Now I know this I will see how much progress I can make configuring the system, sysB, though I expect I may still need some help again later.
kwacorn
Young Hen
 
Posts: 37
Joined: Sat Jan 21, 2012 11:50


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest