Atheros Wireless card not coming online automagically

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
adsicks
Simple Hen
Posts: 56
Joined: Mon Jan 19, 2009 18:18
Location: Rush Springs, OK USA
Contact:

Atheros Wireless card not coming online automagically

Post by adsicks » Sun Apr 07, 2013 21:51

After the last update, my Atheros wireless card in my laptop quit coming on and connecting automagically. If I create the radioon script and run it, it works fine. Saved the script in /usr/bin per this wiki article, and made a symlink in /etc/init.d and added it with rc-update. Still did not work. Thought the radioon script might need to run after wicd, so I renamed the symlink z.radioon, but still no dice. I have to manually turn on the tx now to start the network. Not sure what rule in udev got changed, as that was the only conf files that were changed...
lspci output

Code: Select all

02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
06:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12)

colock
Simple Hen
Posts: 56
Joined: Mon Feb 25, 2013 12:01

Re: Atheros Wireless card not coming online automagically

Post by colock » Sun Apr 07, 2013 23:28

...computers are not about magic... but I hear you :)

You might want to open a bug with all the relevant details on https://bugs.sabayon.org

adsicks
Simple Hen
Posts: 56
Joined: Mon Jan 19, 2009 18:18
Location: Rush Springs, OK USA
Contact:

Re: Atheros Wireless card not coming online automagically

Post by adsicks » Thu Apr 11, 2013 16:38

I disagree, computers are everything about magic, but thanks....

Post Reply