No wireless & no wireless option in settings [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

No wireless & no wireless option in settings [Solved]

Postby ts3 » Sun Feb 26, 2012 20:58

First things first, I am new to Sabayon so please bear with me :)

Second, my wireless card is the infamous Broadcom, more specifically BCM4313. I know from experience with other distributions that I need the wl (WL) driver for the wireless to work, the open source b43 driver does not support BCM4313. I just installed SL8 with gnome 3; the Network tab in System Settings does not even have a wireless option, just wired and proxy.

I did search the forums and did google extensively but nothing I tried works so here I am. For example I looked at the following post

viewtopic.php?f=52&t=26485 and the solution from the wiki http://wiki.sabayon.org/index.php?title ... b43_driver that seems to be working for other people but did not work for me. When I blacklist ssb, b43, brcmsmac nothing happens; when I blacklist bcma I cannot boot into sabayon 8 at all. Booting into recovery mode shows that the boot hangs on "Waiting for uevents to be processed."

When I run lspci -k it shows

Code: Select all
Driver in use bcma-pci-bridge
Kernel modules wl, bcma


I can't figure out what bcma-pci-bridge is and how to get rid of it. Blacklisting and rmmoding it does not help; rmmoding b43 gets rid of it (temporarily until I reboot) and I end up just with

Code: Select all
kernel modules wl, bcma


Modprobing wl does not work for some reason. I don't get any error messages so no help there.

I tried to build the wl driver (I have the tar.gz on a USB just for such occasions) but get errors after make so I reckon I need some libraries I don't have yet. For the driver and instructions how to build it I've always used the Broadcom page at http://www.broadcom.com/support/802.11/linux_sta.php

So basically my questions are 1) Why blacklisting bcma hangs the boot process and what to do about it; 2) what libraries to I need to build from source in SL8 (the Broadcom page refers to needing the "kernel developer or kernel source package" and 3) (that's completely unrelated) how do I get rid of the loud annoying beep whenever I reboot?

Thanks and let me know if I should post more info.

Cheers :)
Last edited by ts3 on Tue Feb 28, 2012 2:23, edited 2 times in total.
ts3
Baby Hen
 
Posts: 6
Joined: Sun Feb 26, 2012 2:37

Re: No wireless & no wireless option in system settings

Postby Fitzcarraldo » Sun Feb 26, 2012 22:35

Try blacklisting the closed-source wl module and the open-source b43 module and load the open-source brcmsmac module instead. Your controller is supported by the brcm80211 module (these days renamed to brcmsmac), which I see from the SL kernel config is compiled as an external kernel module (CONFIG_BRCMSMAC=m) in SL's case, not in-kernel. You'll need to install the linux-firmware package too, as that includes the firmware for the BCM4313.

Code: Select all
echo "blacklist wl" >> /etc/modprobe.d/blacklist.conf
echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
update-modules
equo install linux-firmware
rmmod wl
rmmod b43
modprobe brcmsmac

The above modprobe command is a manual way of loading the module and will not stick over reboots, but it can be automated by adding the module name to the file /etc/conf.d/modules thus:

Code: Select all
modules="brcmsmac"

If you already have some other module/modules declared in that list, leave a space between it/them and the brcmsmac in the string between the quotes.

You mention that blacklisting the bcma module stops SL from loading, so don't blacklist or rmmod that module in your first attempt. If that doesn't work, then rmmod bcma too (see Wi-Fi card does not work or show up since kernel upgrade (brcmsmac): Note: This affects Linux kernels 3.0 and 3.1.). If that works, blacklist it too.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: No wireless & no wireless option in system settings

Postby gamjaevel » Mon Feb 27, 2012 16:56

I have the same wifi-adapter as you do. all i did was

# echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist brcmsmac" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist bcma" >> /etc/modprobe.d/blacklist.conf

and rebooted, and viola.
gamjaevel
Simple Hen
 
Posts: 44
Joined: Tue Sep 27, 2011 18:40

Re: No wireless & no wireless option in system settings

Postby ts3 » Mon Feb 27, 2012 18:38

Fitzcarraldo wrote:Try blacklisting the closed-source wl module and the open-source b43 module and load the open-source brcmsmac module instead.


Great, thanks for the suggestion and the detailed instructions, I'll give it a try when I get to my laptop and will report back :)
Last edited by ts3 on Mon Feb 27, 2012 18:47, edited 1 time in total.
ts3
Baby Hen
 
Posts: 6
Joined: Sun Feb 26, 2012 2:37

Re: No wireless & no wireless option in system settings

Postby ts3 » Mon Feb 27, 2012 18:45

gamjaevel wrote:I have the same wifi-adapter as you do. all i did was

# echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist brcmsmac" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist bcma" >> /etc/modprobe.d/blacklist.conf

and rebooted, and viola.


Yep, that's the first thing that I tried and I couldn't boot into SL at all. By trial and error I found out that blacklisting bcma causes the system to hang at boot. As to why, it's a complete mystery because I've successfully blacklisted bcma on the same laptop on a different partition (different distro obviously). Thanks for the suggestion anyway, this probably works for 9 out of 10 BCM4313 chipsets.
ts3
Baby Hen
 
Posts: 6
Joined: Sun Feb 26, 2012 2:37

Re: No wireless & no wireless option in system settings

Postby ts3 » Tue Feb 28, 2012 2:19

Fitzcarraldo wrote:Try blacklisting the closed-source wl module and the open-source b43 module and load the open-source brcmsmac module instead. Your controller is supported by the brcm80211 module (these days renamed to brcmsmac), which I see from the SL kernel config is compiled as an external kernel module (CONFIG_BRCMSMAC=m) in SL's case, not in-kernel. You'll need to install the linux-firmware package too, as that includes the firmware for the BCM4313.

Code: Select all
echo "blacklist wl" >> /etc/modprobe.d/blacklist.conf
echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
update-modules
equo install linux-firmware
rmmod wl
rmmod b43
modprobe brcmsmac


Wireless is fixed but I ended up using the closed-source wl, unfortunately. Fitzcarraldo, I tried your suggestion and it went well until I tried to modprobe brcmsmac which gave me
Code: Select all
FATAL: Module brcmsmac not found


I googled around a bit and it looks like the module might not be included until kernel 3.3, see bug 2971: http://bugs.sabayon.org/show_bug.cgi?id=2971

Today I was able to remove bcma and load wl by
Code: Select all
rmmod bcma
modprobe wl


For some reason modprobe wl worked (it didn't work yesterday), so I ended up with wl as the driver in use and a working wireless (using it to post this). I am removing wl from blacklist.conf and will try to blacklist bcma again, see if SL boots this time. If not I might end up having to use rmmod bcma/modprobe wl every time I boot until kernel 3.3 rolls around.

I am none too happy about using the closed-source driver but there seems very little choice right now. If I am wrong and there is a way to load brcmsmac please let me know and I'll try. It's definitely not in lib/modules/3.2.0-sabayon/kernel/drivers/staging.

Thanks again for the help, cheers :)

UPDATE: OK, for what it's worth, if anyone comes across the same bizarre problem: NOT blacklisting wl in /etc/modprobe.d/blacklist.conf got me back to square one with no wireless. Blacklisting bcma still makes SL hang on boot so basically the workaround seems to be: blacklist wl (in addition to blacklisting ssb and b43, as per posts above), reboot and

Code: Select all
rmmod bcma
modprobe wl


and the wireless pops up (provided the hardware switch is ON rather than OFF, the rfkill list all and rfkill unblock all can come in handy for that). The whole set-up seems bizarre, the only explanation I can think of is that loading bcma prevents wl from loading, so one has make sure wl does not load by blacklisting, then remove bcma then load wl. Just a guess though. I'll look at Fitzcarraldo's link about blacklisting above but at the end of the day it might be easier to leave things be and just type a couple of commands in the terminal to bring up the wireless.

Anyway, sorry about the serial posting to my own thread, thought this might help if anyone else comes across the same rather unusual issue. Cheers :)
ts3
Baby Hen
 
Posts: 6
Joined: Sun Feb 26, 2012 2:37

Re: No wireless & no wireless option in settings [Solved]

Postby Fitzcarraldo » Tue Feb 28, 2012 3:24

Good to read that you've got wireless working.

When checking the SL kernel config, I was lazy in my previous post and looked at the SL kernel 3.0-r1 config. I've just had a look at the SL kernel 3.2-r13 config and see that brcmsmac has been disabled in the latest SL kernel image. So, if you wanted to use that driver instead of the wl (a.k.a. Broadcom 802.11 Linux STA) driver, you'd need to rebuild the kernel (HOWTO: Upgrade kernel using genkernel) with the relevant kernel parameters set. Unless you're a tinkerer, I wouldn't bother doing it if wireless is now working for you, but, just for information, you'd need to disable/deselect the bcma driver in the kernel config in order to be able to select the brcmsmac driver. Instructions for building a brcmsmac-enabled kernel are on the Linux Wireless Web site (Broadcom brcmsmac (mac80211-based softmac PCIe) and brcmfmac (SDIO) drivers). If you're not familiar with building kernels, don't bother.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 3 guests