atheros ar9285

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Thu Mar 03, 2011 18:42

atheros ar9285

Post by mangamaster99 » Thu Mar 03, 2011 23:30

i have just installed sabayon 5.5 gnome x86_64. and noticed that my bluetooth not working.

and wireless was supposedly working...

i was able to connect to a network... then i can't connect to google.

i tried ping i can ping google.

tried curl... fails.

i know its a atheros ar9285 (i put it in myself physically)

i can get google via ip... but its wrong on so may levels. but not via

so i am thinking it might be some problem with ipv6 (my friend suggested this (gentoo user))

the other interfaces are working. even my phone via wired tether. (on my home network atleast)

this occured last night at a huddle house. and if its going to do this its pointless.

lsmod output

lspci output

i am used to debian based systems but got tired of old kernels and some that didn't work with some devices when they got updated.

so i am somewhat new to gentoo and all.

also about the bluetooth it works anything besides sabayon/gentoo

ubuntu linux mint chakra fedora

i tried rfkill list and only lists wireless lan

... well did a dmesg

seems its trying to load it under ath3k driver via ar30xx

anyway to fix that

User avatar
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: atheros ar9285

Post by Fitzcarraldo » Fri Mar 04, 2011 11:09

The ath9k driver is configured in the SL kernel to be an external module:

Code: Select all

# cat /usr/src/linux/.config | grep ATH9K
so it should be loading. To see which Atheros modules are running:

Code: Select all

# lsmod ath
For your WiFi controller you need the ath9k module, so if the ath5k module is loaded then blacklist it (see example in post Re: wifi card connects to modem but no internet).

If the ath9k module is not loaded, you should be able to load it using the following command:

Code: Select all

# modprobe ath9k

Code: Select all

# ifconfig wlan0 up
(or whatever you WiFi device is called).

You WiFi controller should work if the kernel has been configured correctly ( ... ml#6507317).

Also check the MTU setting: see How to determine the proper MTU size with ICMP pings.

If your router does not support ipv6 then see Possible IPv6 Issue [Solved] and Re: wifi card connects to modem but no internet.

User avatar
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: atheros ar9285

Post by Fitzcarraldo » Sun Mar 20, 2011 10:47

I noticed today that my nettop is using the same Atheros chip as your PC:

Code: Select all

# lspci | grep Wireless
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
The nettop is running the ath9k module, which works fine:

Code: Select all

 # lsmod | grep ath
ath9k                  58009  0 
mac80211              139290  1 ath9k
ath9k_common            1266  1 ath9k
ath9k_hw              219028  2 ath9k,ath9k_common
ath                     9931  2 ath9k,ath9k_hw
cfg80211               95273  3 ath9k,mac80211,ath
See which modules yours is running.

The nettop is running 32-bit SL with KDE 4.6.1. SL is fully upgraded to the latest packages in the Entropy repository.

So my guess is still that your problem lies with your router.

Post Reply